summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-09-22 23:00:01 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-09-22 23:00:01 +0000
commit1a63280be50e25ed3f667dbe284fbb50a8c0148a (patch)
tree0fb70c4649b4b11dd6a23d5c77bd1938db7b664a /net-print/hplip
parentFix manifest (diff)
downloadhistorical-1a63280be50e25ed3f667dbe284fbb50a8c0148a.tar.gz
historical-1a63280be50e25ed3f667dbe284fbb50a8c0148a.tar.bz2
historical-1a63280be50e25ed3f667dbe284fbb50a8c0148a.zip
version bump thanks to Francisco Lloret <fcolloret@terra.es> and Tom Simnett <tomsimnett@yahoo.co.uk> in bug 148393
Package-Manager: portage-2.1.2_pre1
Diffstat (limited to 'net-print/hplip')
-rw-r--r--net-print/hplip/ChangeLog9
-rw-r--r--net-print/hplip/files/digest-hplip-1.6.96
-rw-r--r--net-print/hplip/hplip-1.6.9.ebuild118
3 files changed, 132 insertions, 1 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index 7645ef1afcea..44ce5ce56209 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.41 2006/08/16 20:06:55 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.42 2006/09/22 23:00:01 genstef Exp $
+
+*hplip-1.6.9 (22 Sep 2006)
+
+ 22 Sep 2006; Stefan Schweizer <genstef@gentoo.org> -hplip-1.6.6a.ebuild,
+ -hplip-1.6.7.ebuild, +hplip-1.6.9.ebuild:
+ version bump thanks to Francisco Lloret <fcolloret@terra.es> and Tom Simnett
+ <tomsimnett@yahoo.co.uk> in bug 148393
*hplip-1.6.7 (16 Aug 2006)
diff --git a/net-print/hplip/files/digest-hplip-1.6.9 b/net-print/hplip/files/digest-hplip-1.6.9
new file mode 100644
index 000000000000..fb6a376f5b52
--- /dev/null
+++ b/net-print/hplip/files/digest-hplip-1.6.9
@@ -0,0 +1,6 @@
+MD5 1c4b65222333d048450d37082d521b1e foomatic-db-hpijs-20060720.tar.gz 98252
+RMD160 0c2c09f3cea6fc2a8e5da216bd9996b96d91613d foomatic-db-hpijs-20060720.tar.gz 98252
+SHA256 1e50f603b46b1d07980212b2e5dfc5d72d07c889259e79ecbf09469fef5ad20e foomatic-db-hpijs-20060720.tar.gz 98252
+MD5 38d57f58b48b5b0729d1de507776e7d1 hplip-1.6.9.tar.gz 10018087
+RMD160 d3f8344459830dd9bcced54a1f9e37cd957bb72d hplip-1.6.9.tar.gz 10018087
+SHA256 03d1a8058dcb595882326010ea57915550ddf6489a34fd204b0ca6efbfcf5018 hplip-1.6.9.tar.gz 10018087
diff --git a/net-print/hplip/hplip-1.6.9.ebuild b/net-print/hplip/hplip-1.6.9.ebuild
new file mode 100644
index 000000000000..679f5863282c
--- /dev/null
+++ b/net-print/hplip/hplip-1.6.9.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-1.6.9.ebuild,v 1.1 2006/09/22 23:00:01 genstef Exp $
+
+inherit eutils
+
+DB_V=20060720
+DESCRIPTION="HP Linux Imaging and Printing System. Includes net-print/hpijs, scanner drivers and service tools."
+HOMEPAGE="http://hplip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz
+ foomaticdb? (
+ http://gentooexperimental.org/~genstef/dist/foomatic-db-hpijs-${DB_V}.tar.gz
+ http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-${DB_V}.tar.gz
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="foomaticdb snmp X qt3 ppds scanner"
+
+DEPEND=">=dev-lang/python-2.2.0
+ snmp? ( >=net-analyzer/net-snmp-5.0.9 )
+ !net-print/hpijs
+ !net-print/hpoj"
+
+RDEPEND="virtual/ghostscript
+ scanner? (
+ >=media-gfx/sane-backends-1.0.9
+ || (
+ X? ( >=media-gfx/xsane-0.89 )
+ >=media-gfx/sane-frontends-1.0.9
+ )
+ )
+ qt3? ( >=dev-python/PyQt-3.11 =x11-libs/qt-3* )
+ >=dev-libs/libusb-0.1.10a
+ sys-apps/hotplug-base
+ net-print/cups
+ foomaticdb? ( net-print/foomatic-db-engine )
+ >=net-print/foomatic-filters-3.0.2
+ ${DEPEND}"
+
+pkg_setup() {
+ # avoid collisions with cups-1.2 compat symlinks
+ if [ -e ${ROOT}/usr/lib/cups/backend/hp ] && [ -e ${ROOT}/usr/libexec/cups/backend/hp ]; then
+ rm -f ${ROOT}/usr/libexec/cups/backend/hp{,fax};
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # bug 98428
+ sed -i -e "s:/usr/bin/env python:/usr/bin/python:g" \
+ hpssd.py
+}
+src_compile() {
+ econf \
+ $(use_enable snmp network-build) \
+ $(use_enable cups cups-install) \
+ $(use_enable ppds foomatic-install) \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ if use foomaticdb ; then
+ cd ../foomatic-db-hpijs-${DB_V}
+ econf || die "econf failed"
+ rm -fR data-generators/hpijs-rss
+ emake || die "emake failed"
+ fi
+}
+
+
+src_install() {
+ # cups-1.2 installation paths, make sure that the .desktop is installed
+ sed -i -e "s:/usr/lib/cups:$(cups-config --serverbin):" \
+ -e 's:\(ICON_FILE = \).*:\1hplip.desktop:' \
+ -e 's:\(ICON_PATH = \).*:\1/usr/share/applications:' \
+ Makefile
+
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}"/hplip.init.d hplip
+
+ if use scanner; then
+ insinto /etc/sane.d
+ echo "hpaio" > dll.conf
+ doins dll.conf
+
+ dodir /usr/lib/sane
+ dosym /usr/lib/libsane-hpaio.la /usr/lib/sane/libsane-hpaio.la
+ dosym /usr/lib/libsane-hpaio.so /usr/lib/sane/libsane-hpaio.so
+ dosym /usr/lib/libsane-hpaio.so.1 /usr/lib/sane/libsane-hpaio.so.1
+ dosym /usr/lib/libsane-hpaio.so.1.0.0 /usr/lib/sane/libsane-hpaio.so.1.0.0
+ else
+ rm -f "${D}"/usr/lib/libsane-hpaio.la
+ rm -f "${D}"/usr/lib/libsane-hpaio.so
+ rm -f "${D}"/usr/lib/libsane-hpaio.so.1
+ rm -f "${D}"/usr/lib/libsane-hpaio.so.1.0.0
+ fi
+
+ # bug 106035
+ if ! use qt3 ; then
+ rm -f "${D}"/usr/bin/hp-print
+ rm -f "${D}"/usr/bin/hp-toolbox
+ rm -f "${D}"/usr/share/hplip/print
+ rm -f "${D}"/usr/share/hplip/toolbox
+ rm -f "${D}"/usr/share/applications/hplip.desktop
+ rm -f "${D}"/usr/lib/menu/hplip
+ fi
+
+ rm -rf ${D}/$(cups-config --serverbin)/filter ${D}/usr/bin/foomatic-rip
+
+ if use foomaticdb ; then
+ cd ../foomatic-db-hpijs-${DB_V}
+ emake DESTDIR="${D}" install || die "emake install failed"
+ fi
+}