summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-07-16 14:44:54 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-07-16 14:44:54 +0000
commit7d4d1dc433a0345b1673b7600bafe9e39e70dd57 (patch)
tree6d673830552e0a2a1912e4a49e4404412f426bc0 /net-print/foomatic-db-engine
parentinitial release (diff)
downloadhistorical-7d4d1dc433a0345b1673b7600bafe9e39e70dd57.tar.gz
historical-7d4d1dc433a0345b1673b7600bafe9e39e70dd57.tar.bz2
historical-7d4d1dc433a0345b1673b7600bafe9e39e70dd57.zip
initial release
Diffstat (limited to 'net-print/foomatic-db-engine')
-rw-r--r--net-print/foomatic-db-engine/Manifest3
-rw-r--r--net-print/foomatic-db-engine/files/digest-foomatic-db-engine-3.0.01
-rw-r--r--net-print/foomatic-db-engine/files/perl-module.diff30
-rw-r--r--net-print/foomatic-db-engine/foomatic-db-engine-3.0.0.ebuild34
4 files changed, 67 insertions, 1 deletions
diff --git a/net-print/foomatic-db-engine/Manifest b/net-print/foomatic-db-engine/Manifest
index 4af3ae78b033..caf0e59ef291 100644
--- a/net-print/foomatic-db-engine/Manifest
+++ b/net-print/foomatic-db-engine/Manifest
@@ -1,3 +1,4 @@
-MD5 52f762890447024137ffdcdeb5ec19b5 foomatic-db-engine-3.0.0.ebuild 765
+MD5 69567a33856c6ba886f14263926982cb foomatic-db-engine-3.0.0.ebuild 888
+MD5 993b742b4b855e83e181b6eb1cdfbd78 ChangeLog 332
MD5 8d4bb9556fc4abdf74109f920db4dfff files/digest-foomatic-db-engine-3.0.0 76
MD5 a61100174a95d158d5ce23eedf1f2cea files/perl-module.diff 1050
diff --git a/net-print/foomatic-db-engine/files/digest-foomatic-db-engine-3.0.0 b/net-print/foomatic-db-engine/files/digest-foomatic-db-engine-3.0.0
new file mode 100644
index 000000000000..94c990826c37
--- /dev/null
+++ b/net-print/foomatic-db-engine/files/digest-foomatic-db-engine-3.0.0
@@ -0,0 +1 @@
+MD5 a3c0b0fc6662a7b9afab09cbe74bb292 foomatic-db-engine-3.0.0.tar.gz 271044
diff --git a/net-print/foomatic-db-engine/files/perl-module.diff b/net-print/foomatic-db-engine/files/perl-module.diff
new file mode 100644
index 000000000000..e0c895f42176
--- /dev/null
+++ b/net-print/foomatic-db-engine/files/perl-module.diff
@@ -0,0 +1,30 @@
+diff -urN Makefile.in.1 Makefile.in
+--- Makefile.in.1 2002-07-19 16:18:47.000000000 -0500
++++ Makefile.in 2002-10-17 13:58:09.000000000 -0500
+@@ -178,10 +178,10 @@
+ install-bin: check-config lib/Makefile
+ # This is the only way to get the Perl-generated Makefile using
+ # $(DESTDIR) properly
+- ( cd lib && \
+- $(MAKE) PREFIX=$(DESTDIR)$(PERLPREFIX) && \
+- $(MAKE) PREFIX=$(DESTDIR)$(PERLPREFIX) pure_install \
+- )
++# ( cd lib && \
++# $(MAKE) PREFIX=$(DESTDIR)$(PERLPREFIX) && \
++# $(MAKE) PREFIX=$(DESTDIR)$(PERLPREFIX) pure_install \
++# )
+ install -d $(DESTDIR)$(BINDIR)
+ install -d $(DESTDIR)$(SBINDIR)
+ install -d $(DESTDIR)$(ETCDIR)
+diff -Naur Makefile.in.1 Makefile.in
+--- Makefile.in.1 2003-07-11 16:00:57.000000000 +0200
++++ Makefile.in 2003-07-11 16:01:02.000000000 +0200
+@@ -40,7 +40,7 @@
+ FOOMATIC_RIP=@FOOMATIC_RIP@
+
+ # foomatic-rip path for a "make inplace" installation
+-LOCAL_FOOMATIC_RIP=@LOCAL_FOOMATIC_RIP@
++LOCAL_FOOMATIC_RIP=@FOOMATIC_RIP@
+
+ # Locations for installing the components of this package
+ BINDIR=$(bindir)
diff --git a/net-print/foomatic-db-engine/foomatic-db-engine-3.0.0.ebuild b/net-print/foomatic-db-engine/foomatic-db-engine-3.0.0.ebuild
new file mode 100644
index 000000000000..ac2f70779d68
--- /dev/null
+++ b/net-print/foomatic-db-engine/foomatic-db-engine-3.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-engine/foomatic-db-engine-3.0.0.ebuild,v 1.1 2003/07/16 14:44:17 lanius Exp $
+
+inherit perl-module
+
+DESCRIPTION="Foomatic printer database engine"
+HOMEPAGE="http://www.linuxprinting.org/foomatic"
+SRC_URI="http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE=""
+
+DEPEND="dev-libs/libxml2
+ net-misc/wget
+ net-ftp/curl
+ net-print/foomatic-filters"
+
+src_compile() {
+ epatch ${FILESDIR}/perl-module.diff
+ econf
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ # install perl modules
+ cd lib
+ perl-module_src_prep
+ perl-module_src_compile
+ perl-module_src_test
+ perl-module_src_install
+}