summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-01 15:56:41 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-01 15:56:41 +0000
commit838d8536d096e2590202ab618c2016c4eb5eb77a (patch)
tree9fda93019d8f9d5cde458f2c59a8d2c6f324c36c /net-p2p
parent1 Jul 2002; Stuart Bouyer <stubear@gentoo.org> added freewnn and changed (diff)
downloadhistorical-838d8536d096e2590202ab618c2016c4eb5eb77a.tar.gz
historical-838d8536d096e2590202ab618c2016c4eb5eb77a.tar.bz2
historical-838d8536d096e2590202ab618c2016c4eb5eb77a.zip
version bump
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/lopster/ChangeLog9
-rw-r--r--net-p2p/lopster/files/digest-lopster-1.0.1.200207011
-rw-r--r--net-p2p/lopster/lopster-1.0.1.20020701.ebuild46
3 files changed, 55 insertions, 1 deletions
diff --git a/net-p2p/lopster/ChangeLog b/net-p2p/lopster/ChangeLog
index 42f1c77f9dd4..4c6bfda63aa9 100644
--- a/net-p2p/lopster/ChangeLog
+++ b/net-p2p/lopster/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/lopster
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/lopster/ChangeLog,v 1.2 2002/06/25 11:12:27 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lopster/ChangeLog,v 1.3 2002/07/01 15:56:41 seemant Exp $
+
+*lopster-1.0.1.20020701 (01 Jul 2002)
+
+ 01 Jul 2002; Seemant Kulleen <seemant@gentoo.org>
+ lopster-1.0.1.20020701.ebuild files/digest-lopster-1.0.1.20020701 :
+
+ Updated to CVS snapshot which offers WPNP support.
26 Jun 2002; Thilo Bangert <bangert@gentoo.org> :
diff --git a/net-p2p/lopster/files/digest-lopster-1.0.1.20020701 b/net-p2p/lopster/files/digest-lopster-1.0.1.20020701
new file mode 100644
index 000000000000..bea6704b17df
--- /dev/null
+++ b/net-p2p/lopster/files/digest-lopster-1.0.1.20020701
@@ -0,0 +1 @@
+MD5 fd0643fbbf65f25151b5ae0299597908 lopster-1.0.1.20020701.tar.bz2 500428
diff --git a/net-p2p/lopster/lopster-1.0.1.20020701.ebuild b/net-p2p/lopster/lopster-1.0.1.20020701.ebuild
new file mode 100644
index 000000000000..0b2a3b68be5b
--- /dev/null
+++ b/net-p2p/lopster/lopster-1.0.1.20020701.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lopster/lopster-1.0.1.20020701.ebuild,v 1.1 2002/07/01 15:56:41 seemant Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="A Napster Client using GTK"
+SRC_URI="http://www.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/${P}.tar.bz2"
+HOMEPAGE="http://lopster.sourceforge.net"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="=x11-libs/gtk+-1.2*"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ ./autogen.sh
+ mv po/Makevars.template po/Makevars
+
+ automake m4/Makefile
+ aclocal -I m4
+
+ cp configure.in configure.in.orig
+ sed "s:\(AM_GNU_GETTEXT\):\1([external]):" \
+ configure.in.orig > configure.in
+
+ myconf="--disable-nls"
+
+ econf ${myconf} || die
+
+ cp Makefile Makefile.orig
+ sed "s:^SUBDIRS.*:SUBDIRS = m4 src po:" \
+ Makefile.orig > Makefile
+
+ emake || die
+
+}
+
+src_install () {
+
+ einstall || die
+ dodoc AUTHORS BUGS README ChangeLog NEWS TODO
+}
+