summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-09-24 20:01:25 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-09-24 20:01:25 +0000
commit44ccf1ca19ce94466446fe4d9eb9e6abd33d2af7 (patch)
tree44b6e85b75f9801d424e31722707fc45219c6f1b /net-p2p
parentBump (diff)
downloadhistorical-44ccf1ca19ce94466446fe4d9eb9e6abd33d2af7.tar.gz
historical-44ccf1ca19ce94466446fe4d9eb9e6abd33d2af7.tar.bz2
historical-44ccf1ca19ce94466446fe4d9eb9e6abd33d2af7.zip
Version bump
Package-Manager: portage-2.2_rc9/cvs/Linux 2.6.25-gentoo-r7 i686
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/dclib/ChangeLog7
-rw-r--r--net-p2p/dclib/dclib-0.3.21.ebuild20
-rw-r--r--net-p2p/valknut/ChangeLog7
-rw-r--r--net-p2p/valknut/valknut-0.3.21a.ebuild37
4 files changed, 69 insertions, 2 deletions
diff --git a/net-p2p/dclib/ChangeLog b/net-p2p/dclib/ChangeLog
index 4a64600c2540..3bb5101fe9f9 100644
--- a/net-p2p/dclib/ChangeLog
+++ b/net-p2p/dclib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/dclib
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/ChangeLog,v 1.106 2008/08/23 17:34:23 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/ChangeLog,v 1.107 2008/09/24 19:59:13 armin76 Exp $
+
+*dclib-0.3.21 (24 Sep 2008)
+
+ 24 Sep 2008; Raúl Porcel <armin76@gentoo.org> +dclib-0.3.21.ebuild:
+ Version bump
23 Aug 2008; Markus Meier <maekke@gentoo.org> dclib-0.3.18.ebuild:
amd64 stable, bug #234660
diff --git a/net-p2p/dclib/dclib-0.3.21.ebuild b/net-p2p/dclib/dclib-0.3.21.ebuild
new file mode 100644
index 000000000000..454fb70ecfb4
--- /dev/null
+++ b/net-p2p/dclib/dclib-0.3.21.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/dclib-0.3.21.ebuild,v 1.1 2008/09/24 19:59:13 armin76 Exp $
+
+DESCRIPTION="DirectConnect client library"
+HOMEPAGE="http://sourceforge.net/projects/wxdcgui"
+SRC_URI="mirror://sourceforge/wxdcgui/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=app-arch/bzip2-1.0.2
+ >=dev-libs/libxml2-2.4.22"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/net-p2p/valknut/ChangeLog b/net-p2p/valknut/ChangeLog
index 03c17abc8e72..18603001bbce 100644
--- a/net-p2p/valknut/ChangeLog
+++ b/net-p2p/valknut/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/valknut
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/valknut/ChangeLog,v 1.67 2008/08/23 17:36:11 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/valknut/ChangeLog,v 1.68 2008/09/24 20:01:25 armin76 Exp $
+
+*valknut-0.3.21a (24 Sep 2008)
+
+ 24 Sep 2008; Raúl Porcel <armin76@gentoo.org> +valknut-0.3.21a.ebuild:
+ Version bump
23 Aug 2008; Markus Meier <maekke@gentoo.org> valknut-0.3.18.ebuild:
amd64 stable, bug #234660
diff --git a/net-p2p/valknut/valknut-0.3.21a.ebuild b/net-p2p/valknut/valknut-0.3.21a.ebuild
new file mode 100644
index 000000000000..5ea2a8b4b66b
--- /dev/null
+++ b/net-p2p/valknut/valknut-0.3.21a.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/valknut/valknut-0.3.21a.ebuild,v 1.1 2008/09/24 20:01:25 armin76 Exp $
+
+EAPI=1
+
+inherit qt3
+
+DESCRIPTION="Qt based client for DirectConnect"
+HOMEPAGE="http://sourceforge.net/projects/wxdcgui/"
+SRC_URI="mirror://sourceforge/wxdcgui/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="ssl"
+
+RDEPEND="x11-libs/qt:3
+ >=dev-libs/libxml2-2.4.22
+ ~net-p2p/dclib-0.3.21
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ $(use_with ssl) \
+ --with-libdc=/usr \
+ --with-qt-dir=${QTDIR} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}