summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-04-22 17:50:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-04-22 17:50:25 +0000
commit298b931679dfee7254c4337eb29fc78078ba7190 (patch)
tree075c88ad02475ab2527cefef3f0b6d92e3903220 /net-p2p
parentRefactor ebuild to use python functions correctly. Fixes bug #312665 (diff)
downloadhistorical-298b931679dfee7254c4337eb29fc78078ba7190.tar.gz
historical-298b931679dfee7254c4337eb29fc78078ba7190.tar.bz2
historical-298b931679dfee7254c4337eb29fc78078ba7190.zip
Refactor ebuild to use python functions correctly. Fixes bug #315867
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/torrentinfo/ChangeLog6
-rw-r--r--net-p2p/torrentinfo/Manifest4
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.0.2.ebuild8
3 files changed, 13 insertions, 5 deletions
diff --git a/net-p2p/torrentinfo/ChangeLog b/net-p2p/torrentinfo/ChangeLog
index 48e108f8cdd2..60f356f2271f 100644
--- a/net-p2p/torrentinfo/ChangeLog
+++ b/net-p2p/torrentinfo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/torrentinfo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/torrentinfo/ChangeLog,v 1.4 2010/04/19 16:56:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/torrentinfo/ChangeLog,v 1.5 2010/04/22 17:50:25 hwoarang Exp $
+
+ 22 Apr 2010; Markos Chandras <hwoarang@gentoo.org>
+ torrentinfo-1.0.2.ebuild:
+ Refactor ebuild to use python functions correctly. Fixes bug #315867
19 Apr 2010; Markos Chandras <hwoarang@gentoo.org>
torrentinfo-1.0.2.ebuild:
diff --git a/net-p2p/torrentinfo/Manifest b/net-p2p/torrentinfo/Manifest
index 5f728b8aaa38..4f6248f8b557 100644
--- a/net-p2p/torrentinfo/Manifest
+++ b/net-p2p/torrentinfo/Manifest
@@ -1,4 +1,4 @@
DIST torrentinfo-1.0.2.tar.bz2 5017 RMD160 f9db5c35519822afa8585eb6166caa959c3db579 SHA1 e4097c59f4971a7b8199d39e7b81b2cf0f63d5e0 SHA256 923f5d2e169fc143e2cdc2d799f5c8ac855e70a619d0f306746359f286ccc50e
-EBUILD torrentinfo-1.0.2.ebuild 490 RMD160 45c9df6a1f3f1bd6d6ac37e06ee77b54db151532 SHA1 e23364ede8d3008a357be70867e0093de8a86565 SHA256 0ddce7b06cbc9b04e8e6edd3430f05815108ce8f987c331083255bd66648053f
-MISC ChangeLog 964 RMD160 59b4b984c8ef616420fa9aceb09d9de54d570a06 SHA1 080fbf713d8a299daef87b98c6c27540a8623f93 SHA256 576fad14e04e9c8880d4c0b3e596d658632a60b6f27f1f3b55b083bd3e87d4e7
+EBUILD torrentinfo-1.0.2.ebuild 543 RMD160 55b898157a94783d7aa7c004bb04c485b810c1ae SHA1 5c281d2c89d680df44dc89b817ba79ea95a4051e SHA256 2b2c45311e71a219143a22390399fa0f47f80e9a6ade590b915f81cf1976fe99
+MISC ChangeLog 1117 RMD160 2803a53eed59a21203a0f815cab677b5bb7bd2e2 SHA1 cb0e46a99141f310cba6555f38f1a1c19634e242 SHA256 35087076ad4aca3e2973e9eb9a52b2ac9b84b79412d2371fb1c0d73ff1894fa7
MISC metadata.xml 252 RMD160 44b8a6a712932d7f41ef0a0d48c426ca24d510a7 SHA1 f7c44926598fd9279285daeb2f9cbefa3dc248b7 SHA256 443c35514c1fafc76c882a1273ab6fb81937d5025caa73c8765e6db7179207af
diff --git a/net-p2p/torrentinfo/torrentinfo-1.0.2.ebuild b/net-p2p/torrentinfo/torrentinfo-1.0.2.ebuild
index 89818846a13a..16c97a3ddd69 100644
--- a/net-p2p/torrentinfo/torrentinfo-1.0.2.ebuild
+++ b/net-p2p/torrentinfo/torrentinfo-1.0.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/torrentinfo/torrentinfo-1.0.2.ebuild,v 1.4 2010/04/19 16:56:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/torrentinfo/torrentinfo-1.0.2.ebuild,v 1.5 2010/04/22 17:50:25 hwoarang Exp $
PYTHON_DEPEND="2:2.6"
-inherit distutils
+inherit python distutils
DESCRIPTION="A torrent file parser"
HOMEPAGE="http://vrai.net/project.php?project=torrentinfo"
@@ -14,3 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
+
+pkg_setup() {
+ python_set_active_version 2
+}