summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2003-07-31 03:21:31 +0000
committerCaleb Tennis <caleb@gentoo.org>2003-07-31 03:21:31 +0000
commitbd1da974fce03e3266e7a66fa11f72eccd232995 (patch)
treef7604e3a81e807723724d3e5ace230ffdf937a54 /net-p2p/qtella/qtella-0.6.2.ebuild
parentVersion bump (diff)
downloadhistorical-bd1da974fce03e3266e7a66fa11f72eccd232995.tar.gz
historical-bd1da974fce03e3266e7a66fa11f72eccd232995.tar.bz2
historical-bd1da974fce03e3266e7a66fa11f72eccd232995.zip
Version bump
Diffstat (limited to 'net-p2p/qtella/qtella-0.6.2.ebuild')
-rw-r--r--net-p2p/qtella/qtella-0.6.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-p2p/qtella/qtella-0.6.2.ebuild b/net-p2p/qtella/qtella-0.6.2.ebuild
new file mode 100644
index 000000000000..37a06fa7297b
--- /dev/null
+++ b/net-p2p/qtella/qtella-0.6.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qtella/qtella-0.6.2.ebuild,v 1.1 2003/07/31 03:21:23 caleb Exp $
+inherit kde-base
+
+IUSE="kde"
+use kde && need-kde 3 || need-qt 3
+
+SRC_URI="mirror://sourceforge/qtella/${P}.tar.gz"
+HOMEPAGE="http://www.qtella.net"
+DESCRIPTION="Excellent QT/KDE Gnutella Client"
+
+SLOT="3" # why??
+LICENSE="GPL-2"
+KEYWORDS="x86"
+export MAKEOPTS="$MAKEOPTS -j1"
+
+# weird workaround
+#PATCHES="${FILESDIR}/${P}-nokde.diff"
+
+src_compile() {
+ kde_src_compile myconf
+ use kde || myconf="$myconf --with-kde=no"
+ kde_src_compile configure make
+}