summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-06-25 10:26:11 +0000
committerThilo Bangert <bangert@gentoo.org>2002-06-25 10:26:11 +0000
commit07a2e481814af85e47e5af94fa20544a0f4c63d4 (patch)
tree02a5573027989d2b28469736e68d86f20955bc7f /net-p2p/gnut/gnut-0.4.28.ebuild
parentnew version, compiles with gcc 3.1 (diff)
downloadhistorical-07a2e481814af85e47e5af94fa20544a0f4c63d4.tar.gz
historical-07a2e481814af85e47e5af94fa20544a0f4c63d4.tar.bz2
historical-07a2e481814af85e47e5af94fa20544a0f4c63d4.zip
initial commit for net-p2p - these are all the p2p ebuilds listed in my mail. Note: they have not yet been removed from net-misc or media-sound
Diffstat (limited to 'net-p2p/gnut/gnut-0.4.28.ebuild')
-rw-r--r--net-p2p/gnut/gnut-0.4.28.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-p2p/gnut/gnut-0.4.28.ebuild b/net-p2p/gnut/gnut-0.4.28.ebuild
new file mode 100644
index 000000000000..8522a49322c4
--- /dev/null
+++ b/net-p2p/gnut/gnut-0.4.28.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnut/gnut-0.4.28.ebuild,v 1.1 2002/06/25 10:26:11 bangert Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Text-mode gnutella client"
+SRC_URI="http://www.gnutelliums.com/linux_unix/gnut/tars/gnut-0.4.28.tar.gz"
+HOMEPAGE="http://http://www.gnutelliums.com/linux_unix/gnut/"
+
+DEPEND="virtual/glibc"
+RDEPEND="$DEPEND"
+
+src_compile() {
+ cat /dev/null | ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dohtml doc/*.html
+ dodoc doc/TUTORIAL AUTHORS COPYING ChangeLog GDJ HACKING \
+ INSTALL NEWS README TODO
+}