summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-06-25 10:26:11 +0000
committerThilo Bangert <bangert@gentoo.org>2002-06-25 10:26:11 +0000
commit07a2e481814af85e47e5af94fa20544a0f4c63d4 (patch)
tree02a5573027989d2b28469736e68d86f20955bc7f /net-p2p/gnapster/gnapster-1.5.0-r2.ebuild
parentnew version, compiles with gcc 3.1 (diff)
downloadhistorical-07a2e481814af85e47e5af94fa20544a0f4c63d4.tar.gz
historical-07a2e481814af85e47e5af94fa20544a0f4c63d4.tar.bz2
historical-07a2e481814af85e47e5af94fa20544a0f4c63d4.zip
initial commit for net-p2p - these are all the p2p ebuilds listed in my mail. Note: they have not yet been removed from net-misc or media-sound
Diffstat (limited to 'net-p2p/gnapster/gnapster-1.5.0-r2.ebuild')
-rw-r--r--net-p2p/gnapster/gnapster-1.5.0-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-p2p/gnapster/gnapster-1.5.0-r2.ebuild b/net-p2p/gnapster/gnapster-1.5.0-r2.ebuild
new file mode 100644
index 000000000000..f58c9826d635
--- /dev/null
+++ b/net-p2p/gnapster/gnapster-1.5.0-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnapster/gnapster-1.5.0-r2.ebuild,v 1.1 2002/06/25 10:26:11 bangert Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A napster client for GTK/GNOME"
+SRC_URI="http://jasta.gotlinux.org/files/${P}.tar.gz"
+HOMEPAGE="http://jasta.gotlinux.org/gnapster.html"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+ gtk? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+src_compile() {
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ use gnome \
+ && myconf="${myconf} --with-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ use gtk || myconf="${myconf} --disable-gdk-pixbuf --disable-gtktest"
+
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING README* TODO NEWS
+}