summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-06-25 10:26:11 +0000
committerThilo Bangert <bangert@gentoo.org>2002-06-25 10:26:11 +0000
commit07a2e481814af85e47e5af94fa20544a0f4c63d4 (patch)
tree02a5573027989d2b28469736e68d86f20955bc7f /net-p2p/freenet
parentnew version, compiles with gcc 3.1 (diff)
downloadhistorical-07a2e481814af85e47e5af94fa20544a0f4c63d4.tar.gz
historical-07a2e481814af85e47e5af94fa20544a0f4c63d4.tar.bz2
historical-07a2e481814af85e47e5af94fa20544a0f4c63d4.zip
initial commit for net-p2p - these are all the p2p ebuilds listed in my mail. Note: they have not yet been removed from net-misc or media-sound
Diffstat (limited to 'net-p2p/freenet')
-rw-r--r--net-p2p/freenet/ChangeLog32
-rw-r--r--net-p2p/freenet/files/digest-freenet-200206211
-rw-r--r--net-p2p/freenet/files/freenet33
-rw-r--r--net-p2p/freenet/files/update-freenet17
-rw-r--r--net-p2p/freenet/freenet-20020621.ebuild70
5 files changed, 153 insertions, 0 deletions
diff --git a/net-p2p/freenet/ChangeLog b/net-p2p/freenet/ChangeLog
new file mode 100644
index 000000000000..86c5f0fee962
--- /dev/null
+++ b/net-p2p/freenet/ChangeLog
@@ -0,0 +1,32 @@
+# ChangeLog for net-p2p/freenet
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/freenet/ChangeLog,v 1.1 2002/06/25 10:26:11 bangert Exp $
+
+*freenet-20020621.ebuild ( 21 Jun 2002 )
+
+ 20 Jun 2002; J.Alberto Suárez L. <bass@gentoo.org> freenet-20020621.ebuild:
+ Bumped versión, and a note that explain how down the newest version.
+
+*freenet-20020214.ebuild ( 18 Feb 2002 )
+
+ 18 Feb 2002; Karl Trygve Kalleberg <karltk@gentoo.org> ChangeLog files/digest-freenet-20020214 files/freenet files/update-freenet:
+
+ Freenet is a large-scale peer-to-peer network which pools the power of
+ member computers around the world to create a massive virtual information
+ store open to anyone to freely publish or view information of all kinds.
+ Freenet is:
+
+ * Highly survivable: All internal processes are completely anonymized and
+ decentralized across the global network, making it virtually impossible
+ for an attacker to destroy information or take control of the system.
+ * Private: Freenet makes it extremely difficult for anyone to spy on the
+ information that you are viewing, publishing, or storing.
+ * Secure: Information stored in Freenet is protected by strong
+ cryptography against malicious tampering or counterfeiting.
+ * Efficient: Freenet dynamically replicates and relocates information in
+ response to demand to provide efficient service and minimal bandwidth
+ usage regardless of load. Significantly, Freenet generally requires
+ log(n) time to retrieve a piece of information in a network of size n.
+
+ Ebuild submitted by Per Wigren <wigren@home.se>.
+
diff --git a/net-p2p/freenet/files/digest-freenet-20020621 b/net-p2p/freenet/files/digest-freenet-20020621
new file mode 100644
index 000000000000..ff2d2f062e36
--- /dev/null
+++ b/net-p2p/freenet/files/digest-freenet-20020621
@@ -0,0 +1 @@
+MD5 e65a6aae2c89e82291976ecd529ab4fc freenet-20020621.tgz 1063350
diff --git a/net-p2p/freenet/files/freenet b/net-p2p/freenet/files/freenet
new file mode 100644
index 000000000000..12824ca2da14
--- /dev/null
+++ b/net-p2p/freenet/files/freenet
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+# Freenet init.d-script by Per Wigren <wigren@home.se>
+
+
+depend () {
+ need net
+}
+
+get_seednodes () {
+ if [[ ! -e /var/freenet/seednodes.ref ]]; then
+ echo No seednodes.ref file was found. Fetching a new one...
+ cd /var/freenet
+ wget -q http://hawk.freenetproject.org/~freenet4/seednodes.ref
+ fi
+}
+
+start () {
+ ebegin "Starting Freenet"
+ get_seednodes
+ export CLASSPATH=/usr/lib/freenet/freenet.jar:/usr/lib/freenet/freenet-ext.jar:$CLASSPATH
+ start-stop-daemon --start --quiet --pidfile /var/run/freenet.pid -m \
+ --background \
+ --exec $(java-config --java) -- freenet.node.Main -p /etc/freenet.conf
+ eend $?
+}
+
+stop () {
+ ebegin "Stopping Freenet"
+ start-stop-daemon --stop --quiet --pidfile /var/run/freenet.pid
+ rm -f /var/run/freenet.pid
+ eend $?
+}
+
diff --git a/net-p2p/freenet/files/update-freenet b/net-p2p/freenet/files/update-freenet
new file mode 100644
index 000000000000..a04833ab5eeb
--- /dev/null
+++ b/net-p2p/freenet/files/update-freenet
@@ -0,0 +1,17 @@
+#!/bin/bash
+
+echo "Upgrading Freenet-server..."
+cd /usr/lib/freenet
+rm -f freenet-latest.jar
+wget http://freenetproject.org/snapshots/freenet-latest.jar && \
+ mv -f freenet-latest.jar freenet.jar && \
+ echo "freenet.jar upgraded."
+
+echo "Updating seednodes..."
+cd /var/freenet
+rm -f seednodes.ref
+wget http://hawk.freenetproject.org/~freenet4/seednodes.ref && \
+ echo "seednodes.ref updated."
+
+echo "Restart Freenet to run the new version."
+
diff --git a/net-p2p/freenet/freenet-20020621.ebuild b/net-p2p/freenet/freenet-20020621.ebuild
new file mode 100644
index 000000000000..2e692c505bda
--- /dev/null
+++ b/net-p2p/freenet/freenet-20020621.ebuild
@@ -0,0 +1,70 @@
+# Copyright (c) 2002, Per Wigren <wigren@home.se>
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/freenet/freenet-20020621.ebuild,v 1.1 2002/06/25 10:26:11 bangert Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Freenet server"
+SRC_URI="http://freenetproject.org/snapshots/${P}.tgz"
+HOMEPAGE="http://freenetproject.org"
+DEPEND="virtual/jdk"
+RDEPEND="${DEPEND}"
+SLOT="0"
+
+src_compile () {
+ cd ${S}
+ # Set storeSize to a 3rd of the available space on /var
+ VARSZ=$(df -m /var|tail -n1|awk '{print $4}')
+ if [ $VARSZ -gt 2048 ]; then
+ STORSZ=1073741824
+ else
+ let STORSZ=($VARSZ/3)*1024*1024
+ fi
+
+ # Create a default freenet.conf
+ ( echo ipAddress=$(hostname)
+ echo listenPort=$(let PORT=($RANDOM%30000)+9000; echo $PORT)
+ echo seedFile=/var/freenet/seednodes.ref
+ echo storeFile=/var/freenet/store
+ echo storeSize=$STORSZ
+ echo nodeFile=/var/freenet/node
+ echo diagnosticsPath=/var/freenet/stats
+ echo logLevel=normal
+ echo logFile=/var/log/freenet.log
+ echo maxHopsToLive=25
+ echo fproxy.class=freenet.client.http.FproxyServlet
+ echo fproxy.port=8888
+ echo fproxy.insertHtl=25
+ echo fproxy.requestHtl=25
+ echo fproxy.params.filter=false
+ echo nodestatus.class=freenet.client.http.NodeStatusServlet
+ echo nodestatus.port=8889
+ echo logInboundContacts=true
+ echo logOutboundContacts=true
+ echo logInboundRequests=true
+ ) >freenet.conf
+}
+
+src_install () {
+
+ dodir /var/freenet/stats
+
+ insinto /usr/lib/freenet
+ doins lib/freenet.jar lib/freenet-ext.jar
+
+ insinto /etc
+ doins freenet.conf
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/freenet
+
+ dosbin ${FILESDIR}/update-freenet
+}
+
+pkg_postinstall () {
+
+ einfo "*********************************************************"
+ einfo "freenet is buil every night, but with the actually"
+ einfo "portage version we can't garantee the integrity of the"
+ einfo "files. So you can use the version of freenet for update"
+ einfo "it. Simply use the update-freenet script."
+ einfo "*********************************************************"
+}