summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author <luke-jr@gentoo.org>2003-08-22 13:56:32 +0000
committer <luke-jr@gentoo.org>2003-08-22 13:56:32 +0000
commit9e91e7e53d12b8f012a9ceeea2a82dbfdaf8cb74 (patch)
treeedfee2d6d391f72d34779f3a46834829438ce128 /net-p2p/bittorrent-theshadow
parentVersion bump (diff)
downloadhistorical-9e91e7e53d12b8f012a9ceeea2a82dbfdaf8cb74.tar.gz
historical-9e91e7e53d12b8f012a9ceeea2a82dbfdaf8cb74.tar.bz2
historical-9e91e7e53d12b8f012a9ceeea2a82dbfdaf8cb74.zip
Version bump
Diffstat (limited to 'net-p2p/bittorrent-theshadow')
-rw-r--r--net-p2p/bittorrent-theshadow/Manifest4
-rw-r--r--net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.7.ebuild63
-rw-r--r--net-p2p/bittorrent-theshadow/files/digest-bittorrent-theshadow-5.71
3 files changed, 66 insertions, 2 deletions
diff --git a/net-p2p/bittorrent-theshadow/Manifest b/net-p2p/bittorrent-theshadow/Manifest
index e905ce53e9c0..013e68470c80 100644
--- a/net-p2p/bittorrent-theshadow/Manifest
+++ b/net-p2p/bittorrent-theshadow/Manifest
@@ -1,7 +1,7 @@
MD5 581bc18ef47758b14f7bd1acf02c09fc bittorrent-theshadow-5.5.ebuild 1690
-MD5 90f07599ee29fdce9a5f7ad7c49f7b3b ChangeLog 665
+MD5 2ce2d3bf0a63d3113368528d5d67033b ChangeLog 799
MD5 92c737b564adbfe8fc67d60d72cfbe4e bittorrent-theshadow-5.6.1.ebuild 1692
-MD5 92c737b564adbfe8fc67d60d72cfbe4e bittorrent-theshadow-5.7.ebuild 1692
+MD5 cbcfec2a98876e0a7511a8abe4adee6e bittorrent-theshadow-5.7.ebuild 1690
MD5 15dbb7797424c6cf9f9a520f11e9a94d files/digest-bittorrent-theshadow-5.5 78
MD5 721c9c1924c39c8b9469e6f72d047265 files/digest-bittorrent-theshadow-5.6.1 80
MD5 8b336bc047ea1eb5dbc389a286410deb files/digest-bittorrent-theshadow-5.7 78
diff --git a/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.7.ebuild b/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.7.ebuild
new file mode 100644
index 000000000000..ecdb342e5bff
--- /dev/null
+++ b/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2000-2003 Gentoo Technologies, Inc. Okrain Genady (^Mafteah),
+# and Luke-Jr
+# Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.7.ebuild,v 1.1 2003/08/22 13:56:26 luke-jr Exp $
+inherit distutils
+
+S=${WORKDIR}/BitTorrent-CVS-shadowsclient
+DESCRIPTION="BitTorrent is a tool for distributing files via a distributed network of nodes"
+SRC_URI="http://home.elp.rr.com/tur/BitTorrent-experimental-S-${PV}.zip"
+HOMEPAGE="http://bt.degreez.net/"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxPython-2.2 )
+ >=dev-lang/python-2.1
+ !net-p2p/bittorrent
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
+
+PROVIDE="virtual/bittorrent"
+
+mydoc="FAQ.txt README.txt LICENSE.txt"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ for f in *.txt *.py; do
+ tr -d '\r' < "$f" > "$f".new
+ mv "$f".new "$f"
+ done
+}
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+}
+
diff --git a/net-p2p/bittorrent-theshadow/files/digest-bittorrent-theshadow-5.7 b/net-p2p/bittorrent-theshadow/files/digest-bittorrent-theshadow-5.7
new file mode 100644
index 000000000000..f7610a4d3b91
--- /dev/null
+++ b/net-p2p/bittorrent-theshadow/files/digest-bittorrent-theshadow-5.7
@@ -0,0 +1 @@
+MD5 7abc4c28ba210eb45692305fe5314a77 BitTorrent-experimental-S-5.7.zip 150435