summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-09-07 22:30:05 +0000
committerSven Wegener <swegener@gentoo.org>2004-09-07 22:30:05 +0000
commitd52416e048c4a3beb2a84dd4aa2bac85f408fd44 (patch)
treed878db819d96465f0738b30ddf938f04e807db82 /net-news/inn
parentversion bump (diff)
downloadhistorical-d52416e048c4a3beb2a84dd4aa2bac85f408fd44.tar.gz
historical-d52416e048c4a3beb2a84dd4aa2bac85f408fd44.tar.bz2
historical-d52416e048c4a3beb2a84dd4aa2bac85f408fd44.zip
Added support for BerkeleyDB via the USE flag berkdb. Added support for the local USE flags innkeywords and inntaggedhash that enable automatic keyword generation support and use a tagged hash table for history.
Diffstat (limited to 'net-news/inn')
-rw-r--r--net-news/inn/ChangeLog8
-rw-r--r--net-news/inn/Manifest13
-rw-r--r--net-news/inn/files/2.4.1-berkdb.patch32
-rw-r--r--net-news/inn/files/innd2
-rw-r--r--net-news/inn/inn-2.4.1.ebuild28
5 files changed, 63 insertions, 20 deletions
diff --git a/net-news/inn/ChangeLog b/net-news/inn/ChangeLog
index 41ca3d6a4114..86744b4c1262 100644
--- a/net-news/inn/ChangeLog
+++ b/net-news/inn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-news/inn
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/inn/ChangeLog,v 1.12 2004/09/07 04:05:07 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/inn/ChangeLog,v 1.13 2004/09/07 22:29:04 swegener Exp $
+
+ 08 Sep 2004; Sven Wegener <swegener@gentoo.org> +files/2.4.1-berkdb.patch,
+ files/innd, inn-2.4.1.ebuild:
+ Added support for BerkeleyDB via the USE flag berkdb. Added support for the
+ local USE flags innkeywords and inntaggedhash that enable automatic keyword
+ generation support and use a tagged hash table for history.
*inn-2.4.1 (07 Sep 2004)
diff --git a/net-news/inn/Manifest b/net-news/inn/Manifest
index 89cc23492dfb..a7eec2c4a0d8 100644
--- a/net-news/inn/Manifest
+++ b/net-news/inn/Manifest
@@ -1,17 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 7f0a5609c704120c46645852260306f2 ChangeLog 1624
MD5 65664ec8b14d6dc3eeb7e5cc82df7c9c inn-2.3.5.ebuild 3253
-MD5 f2797acdbe6c0013e16e25085b79c92b inn-2.4.1.ebuild 7329
+MD5 1756a991f54b14cfeaa016c105a9ebca inn-2.4.1.ebuild 7571
MD5 d4764f5c17f5e0b416f7ddf271c77d71 metadata.xml 161
+MD5 d7310425dc6b77081a01f4b2b28a1239 ChangeLog 1952
MD5 ce3c00651e354a874cc9c60ae4f0255e files/digest-inn-2.3.5 128
MD5 f31130931b3d55b9a8a2c89560c09199 files/digest-inn-2.4.1 62
-MD5 9e7c2242ff26084942ee02bb19eb3f95 files/innd 437
+MD5 9bfea7a0644e2f3adc2738d86bfa2254 files/innd 436
+MD5 7c3bcaa98344d126d7b0ba965344a25c files/2.4.1-berkdb.patch 1373
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBPU1hI1lqEGTUzyQRAin7AJ4+5W+kJGEhVCbItaEg3v90uzOsLQCfQSz8
-1orlhkYi7NygNHPtMGPQTLo=
-=0Pjy
+iD8DBQFBPjZyI1lqEGTUzyQRAq5AAJ4llsUGg6Vs+7rVKK11EhpAD+7EnwCfc6cn
+PN+1bNXotiQpLL6vzinmkG8=
+=lM8m
-----END PGP SIGNATURE-----
diff --git a/net-news/inn/files/2.4.1-berkdb.patch b/net-news/inn/files/2.4.1-berkdb.patch
new file mode 100644
index 000000000000..5982ed04af42
--- /dev/null
+++ b/net-news/inn/files/2.4.1-berkdb.patch
@@ -0,0 +1,32 @@
+diff -Nur inn-2.4.1.orig/configure.in inn-2.4.1/configure.in
+--- inn-2.4.1.orig/configure.in 2004-09-07 14:53:23.800246638 +0200
++++ inn-2.4.1/configure.in 2004-09-07 14:55:04.045893609 +0200
+@@ -375,20 +375,20 @@
+ done
+ fi
+ if test x"$BERKELEY_DB_DIR" = xyes ; then
+- for v in db41 db4 db3 db2 ; do
++ for v in 3 2 ; do
+- if test -d "/usr/local/include/$v" ; then
++ if test -d "/usr/local/include/db$v" ; then
+ BERKELEY_DB_LDFLAGS="-L/usr/local/lib"
+- BERKELEY_DB_CFLAGS="-I/usr/local/include/$v"
+- BERKELEY_DB_LIB="-l$v"
++ BERKELEY_DB_CFLAGS="-I/usr/local/include/db$v"
++ BERKELEY_DB_LIB="-ldb-$v"
+ AC_MSG_RESULT(FreeBSD locations)
+ break
+ fi
+ done
+ if test x"$BERKELEY_DB_LIB" = x ; then
+- for v in db41 db4 db3 db2 ; do
++ for v in 3 2 ; do
+- if test -d "/usr/include/$v" ; then
++ if test -d "/usr/include/db$v" ; then
+- BERKELEY_DB_CFLAGS="-I/usr/include/$v"
+- BERKELEY_DB_LIB="-l$v"
++ BERKELEY_DB_CFLAGS="-I/usr/include/db$v"
++ BERKELEY_DB_LIB="-ldb-$v"
+ AC_MSG_RESULT(Linux locations)
+ break
+ fi
diff --git a/net-news/inn/files/innd b/net-news/inn/files/innd
index b1705e645640..ebde8215e818 100644
--- a/net-news/inn/files/innd
+++ b/net-news/inn/files/innd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# /space/gentoo/cvsroot/gentoo-x86/net-misc/bind/files/named.rc6,v 1.4 2002/06/01 16:31:07 nitro Exp
+# $Header: /var/cvsroot/gentoo-x86/net-news/inn/files/innd,v 1.7 2004/09/07 22:29:04 swegener Exp $
depend() {
need net
diff --git a/net-news/inn/inn-2.4.1.ebuild b/net-news/inn/inn-2.4.1.ebuild
index 789db345b462..9369586c5810 100644
--- a/net-news/inn/inn-2.4.1.ebuild
+++ b/net-news/inn/inn-2.4.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/inn/inn-2.4.1.ebuild,v 1.3 2004/09/07 05:54:12 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/inn/inn-2.4.1.ebuild,v 1.4 2004/09/07 22:29:04 swegener Exp $
-inherit fixheadtails ssl-cert
+inherit fixheadtails ssl-cert eutils
DESCRIPTION="The Internet News daemon, fully featured NNTP server"
HOMEPAGE="http://www.isc.org/products/INN"
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.isc.org/isc/inn/${P}.tar.gz"
SLOT="0"
LICENSE="as-is BSD"
KEYWORDS="~x86"
-IUSE="ipv6 kerberos sasl ssl perl python tcltk"
+IUSE="ipv6 kerberos sasl ssl perl python tcltk berkdb inntaggedhash innkeywords"
RDEPEND="virtual/mta
kerberos? ( virtual/krb5 )
@@ -19,17 +19,22 @@ RDEPEND="virtual/mta
perl? ( dev-lang/perl )
python? ( dev-lang/python )
tcltk? ( dev-lang/tcl )
- app-arch/gzip"
-
+ berkdb? ( =sys-libs/db-3* )
+ virtual/gzip"
DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.13
- sys-devel/libtool"
+ sys-devel/libtool
+ >=sys-apps/sed-4"
src_unpack() {
unpack ${A}
cd ${S}
- ht_fix_file configure support/fixscript.in
+ epatch ${FILESDIR}/2.4.1-berkdb.patch
+ ht_fix_file configure.in support/fixscript.in
+
+ export WANT_AUTOCONF="2.1"
+ autoconf || die "autoconf failed"
sed -i \
-e "s/ -B .OLD//" \
@@ -39,11 +44,6 @@ src_unpack() {
}
src_compile() {
- export WANT_AUTOCONF="2.1"
-
- libtoolize --force || die "libtoolize failed"
- aclocal || die "aclocal failed"
-
econf \
--prefix=/usr/lib/news \
--mandir=/usr/share/man \
@@ -67,7 +67,11 @@ src_compile() {
$(use_with kerberos kerberos /usr) \
$(use_with sasl) \
$(use_with ssl openssl) \
+ $(use_with berkdb berkeleydb) \
$(use_enable ipv6) \
+ $(use_enable !inntaggedhash largefiles) \
+ $(use_enable inntaggedhash tagged-hash) \
+ $(use_enable innkeywords keywords) \
|| die "econf failed"
emake -j1 P="" || die "emake failed"
}