summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-07-11 03:09:43 +0000
committerDonny Davies <woodchip@gentoo.org>2003-07-11 03:09:43 +0000
commitebf64eb864cbe8562263e7947791324a10480b45 (patch)
treea6dbd3ca16f42bc947d016f0a93189b3924f38ba /net-nds/ypbind
parentcleanups from <ogunden@phauna.org> (diff)
downloadhistorical-ebf64eb864cbe8562263e7947791324a10480b45.tar.gz
historical-ebf64eb864cbe8562263e7947791324a10480b45.tar.bz2
historical-ebf64eb864cbe8562263e7947791324a10480b45.zip
cleanups from <ogunden@phauna.org>
Diffstat (limited to 'net-nds/ypbind')
-rw-r--r--net-nds/ypbind/Manifest5
-rw-r--r--net-nds/ypbind/files/digest-ypbind-1.121
-rw-r--r--net-nds/ypbind/files/ypbind.confd4
-rw-r--r--net-nds/ypbind/ypbind-1.12.ebuild37
4 files changed, 42 insertions, 5 deletions
diff --git a/net-nds/ypbind/Manifest b/net-nds/ypbind/Manifest
index c271e731fa05..21399c5f7a33 100644
--- a/net-nds/ypbind/Manifest
+++ b/net-nds/ypbind/Manifest
@@ -1,7 +1,6 @@
-MD5 2bac5d40067a0c4f0e9cd969e10e3399 ChangeLog 1727
+MD5 83ecbfa2fd51fa90b35c2370fb0e2550 ChangeLog 1902
MD5 7a865f4547a5ffc35fb05115f73ecaf2 ypbind-1.11-r1.ebuild 935
-MD5 45773dfce3f380e71f0cb3a30afb2d4b ypbind-1.12.ebuild 933
-MD5 56e4f7bea010a944b345a36f03616ff2 nohup.out 75374
+MD5 a450e6fe13b1ba5486e1bb2f71a4d4ae ypbind-1.12.ebuild 1044
MD5 07fdb01e99c0cb8ab5b3e770d83d7449 files/digest-ypbind-1.11-r1 67
MD5 f7d2018bc2060d296bc12767a9f5c58f files/ypbind.confd 117
MD5 872185d0cbdbf410af0eade7b3f0c1ba files/ypbind.rc5 1020
diff --git a/net-nds/ypbind/files/digest-ypbind-1.12 b/net-nds/ypbind/files/digest-ypbind-1.12
new file mode 100644
index 000000000000..4391a86b30eb
--- /dev/null
+++ b/net-nds/ypbind/files/digest-ypbind-1.12
@@ -0,0 +1 @@
+MD5 3a11b9f447c72fd6d18afe3b6f94b2c0 ypbind-mt-1.12.tar.bz2 143601
diff --git a/net-nds/ypbind/files/ypbind.confd b/net-nds/ypbind/files/ypbind.confd
index e049624808dd..4464137590e1 100644
--- a/net-nds/ypbind/files/ypbind.confd
+++ b/net-nds/ypbind/files/ypbind.confd
@@ -1,5 +1,5 @@
# Config file for /etc/init.d/ypbind
+# NIS domain (not necessarily the same as DNS domain)
-# NIS domain (not necessary the same as DNS domain)
-#YP_DOMAIN=myYPdomain
+#YP_DOMAIN=my.yp.domain
diff --git a/net-nds/ypbind/ypbind-1.12.ebuild b/net-nds/ypbind/ypbind-1.12.ebuild
new file mode 100644
index 000000000000..584e954a21e5
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.12.ebuild,v 1.1 2003/07/11 03:09:36 woodchip Exp $
+
+IUSE="nls"
+
+MY_P=${PN}-mt-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Multithreaded NIS bind service (ypbind-mt)"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~alpha"
+
+DEPEND="net-nds/yp-tools net-nds/portmap"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+ econf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog COPYING README THANKS TODO
+ insinto /etc ; doins etc/yp.conf
+ insinto /etc/conf.d ; newins ${FILESDIR}/ypbind.confd ypbind
+ exeinto /etc/init.d ; newexe ${FILESDIR}/ypbind.rc6 ypbind
+}
+
+pkg_postinst() {
+ einfo "To complete setup, you will need to edit /etc/conf.d/ypbind."
+}