summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-08-15 10:16:22 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-08-15 10:16:22 +0000
commitf5660629b64d59c18c450eba4c08f2ca7df79e06 (patch)
tree18eba889a88d9a11e3f3803d3f6ed224098cb114 /net-misc
parentVersion bump. Icecast is back. :) (diff)
downloadhistorical-f5660629b64d59c18c450eba4c08f2ca7df79e06.tar.gz
historical-f5660629b64d59c18c450eba4c08f2ca7df79e06.tar.bz2
historical-f5660629b64d59c18c450eba4c08f2ca7df79e06.zip
Version bump. Icecast is back. :)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/icecast/Manifest4
-rw-r--r--net-misc/icecast/files/digest-icecast-2.0_alpha21
-rw-r--r--net-misc/icecast/icecast-2.0_alpha2.ebuild46
3 files changed, 49 insertions, 2 deletions
diff --git a/net-misc/icecast/Manifest b/net-misc/icecast/Manifest
index cf5d48453256..4b9ce2f079aa 100644
--- a/net-misc/icecast/Manifest
+++ b/net-misc/icecast/Manifest
@@ -1,6 +1,6 @@
-MD5 b4ad9096b04c266eb23ff244e957fa0a icecast-2.0_alpha2.ebuild 1105
+MD5 f9101707e125962622c22dbdcf447516 icecast-2.0_alpha2.ebuild 1178
MD5 6dbedd1f09d89849bc31469c2e582217 icecast-1.3.12-r1.ebuild 1433
-MD5 adb36d36e07c95d9027dab5826eecaf0 ChangeLog 1791
+MD5 b72c9fcdbc970a17bfb272f82fb5e916 ChangeLog 1998
MD5 a5f4b4836da859fb3b50704c437e2ba9 files/1.3.12-errno.patch 1732
MD5 71055d2524f397ee40ccf8e86f7d291c files/digest-icecast-2.0_alpha2 80
MD5 ff47a23b447435b728c7fad3f55c2860 files/icecast-1.3.12-variables-gentoo.diff.bz2 825
diff --git a/net-misc/icecast/files/digest-icecast-2.0_alpha2 b/net-misc/icecast/files/digest-icecast-2.0_alpha2
new file mode 100644
index 000000000000..ff94b96d4d0b
--- /dev/null
+++ b/net-misc/icecast/files/digest-icecast-2.0_alpha2
@@ -0,0 +1 @@
+MD5 4ce5dfa26a121982fc89f72ecd1aadd7 icecast-2.0-alpha-2-20030815.tar.gz 572284
diff --git a/net-misc/icecast/icecast-2.0_alpha2.ebuild b/net-misc/icecast/icecast-2.0_alpha2.ebuild
new file mode 100644
index 000000000000..72e57f032718
--- /dev/null
+++ b/net-misc/icecast/icecast-2.0_alpha2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.0_alpha2.ebuild,v 1.1 2003/08/15 10:16:18 g2boojum Exp $
+
+IUSE="oggvorbis curl"
+
+inherit eutils
+
+DESCRIPTION="An opensource alternative to shoutcast that supports mp3 and ogg streaming"
+HOMEPAGE="http://www.icecast.org/"
+SRC_URI="http://www.xiph.org/~brendan/snapshots/icecast/icecast-2.0-alpha-2-20030815.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="virtual/glibc
+ dev-libs/libxml2
+ dev-libs/libxslt
+ oggvorbis? ( >=media-libs/libvorbis-1.0
+ >=media-libs/libogg-1.0 )
+ curl? ( net-ftp/curl )"
+
+S=${WORKDIR}/icecast-2.0-alpha-2
+
+src_compile() {
+ local myconf="--with-gnu-ld"
+
+ use oggvorbis || myconf="${myconf} --without-ogg --without-vorbis"
+
+ use curl || myconf="${myconf} --without-curl"
+
+ econf \
+ --sysconfdir=/etc/icecast2 \
+ ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc AUTHORS README TODO HACKING NEWS
+
+ rm -rf ${D}usr/share/doc/icecast
+}