summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-02-09 01:23:01 +0000
committerDonny Davies <woodchip@gentoo.org>2002-02-09 01:23:01 +0000
commitc3651915d82e6a0341a7c92adc7a9bc073f9ca4d (patch)
treec2eb65e6e9a49934f188ae970b50eca8d0689268 /net-misc
parent_really_ remove the older ebuilds/digests (diff)
downloadhistorical-c3651915d82e6a0341a7c92adc7a9bc073f9ca4d.tar.gz
historical-c3651915d82e6a0341a7c92adc7a9bc073f9ca4d.tar.bz2
historical-c3651915d82e6a0341a7c92adc7a9bc073f9ca4d.zip
Close #426, thanks to jo@our-own.net (Jo Ryden) for the submission.
No $DESTDIR in Makefile, manually install...
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rdesktop/ChangeLog11
-rw-r--r--net-misc/rdesktop/files/digest-rdesktop-1.1.01
-rw-r--r--net-misc/rdesktop/rdesktop-1.1.0.ebuild35
3 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/rdesktop/ChangeLog b/net-misc/rdesktop/ChangeLog
new file mode 100644
index 000000000000..62c62dd0db7c
--- /dev/null
+++ b/net-misc/rdesktop/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/rdesktop
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdesktop/ChangeLog,v 1.1 2002/02/09 01:23:01 woodchip Exp $
+
+*rdesktop-1.1.0 (8 Feb 2002)
+
+ 8 Feb 2002; Donny Davies <woodchip@gentoo.org> rdesktop-1.1.0.ebuild,
+ files/digest-rdesktop-1.1.0 :
+
+ Checkin new package, first version.
+
diff --git a/net-misc/rdesktop/files/digest-rdesktop-1.1.0 b/net-misc/rdesktop/files/digest-rdesktop-1.1.0
new file mode 100644
index 000000000000..30baa35df265
--- /dev/null
+++ b/net-misc/rdesktop/files/digest-rdesktop-1.1.0
@@ -0,0 +1 @@
+MD5 50cfa4cacd15c52eaa7a57470607acea rdesktop-1.1.0.tar.gz 80584
diff --git a/net-misc/rdesktop/rdesktop-1.1.0.ebuild b/net-misc/rdesktop/rdesktop-1.1.0.ebuild
new file mode 100644
index 000000000000..eb30a53306a2
--- /dev/null
+++ b/net-misc/rdesktop/rdesktop-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Jo Ryden <jo@our-own.net>
+# Maintainer: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdesktop/rdesktop-1.1.0.ebuild,v 1.1 2002/02/09 01:23:01 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A Remote Desktop Protocol Client"
+SRC_URI="http://prdownloads.sourceforge.net/${PN}/${P}.tar.gz"
+HOMEPAGE="http://rdesktop.sourceforge.net/"
+
+DEPEND="x11-base/xfree ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+src_compile() {
+ local myconf
+ use ssl && myconf="--with-openssl"
+ use ssl || myconf="--without-openssl"
+ [ "${DEBUG}" ] && myconf="${myconf} --with-debug"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man $myconf || die
+ use ssl && echo "CFLAGS += -I/usr/include/openssl" >> Makeconf
+ # Hold on tight folks, this ain't purdy
+ if [ ! -z "${CXXFLAGS}" ]; then
+ sed -e 's/-O2//g' Makefile > Makefile.tmp && mv Makefile.tmp Makefile
+ echo "CFLAGS += ${CXXFLAGS}" >> Makeconf
+ fi
+ emake || die "compile problem"
+}
+
+src_install () {
+ dobin rdesktop
+ doman rdesktop.1
+ dodoc COPYING
+}