summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-07-28 15:49:20 +0000
committerPeter Gavin <pete@gentoo.org>2001-07-28 15:49:20 +0000
commit60baf14c24fd458bc9a965a81ed7d3ebeb831262 (patch)
tree075007d8cef3f6a326d566ed10b8f8bf333dc2e5 /net-misc
parentapply a patch that makes it work better with autoconf 2.13 (diff)
downloadhistorical-60baf14c24fd458bc9a965a81ed7d3ebeb831262.tar.gz
historical-60baf14c24fd458bc9a965a81ed7d3ebeb831262.tar.bz2
historical-60baf14c24fd458bc9a965a81ed7d3ebeb831262.zip
bootcd fixups and additions. set USE=bootcd to build these packages
for the installation cd. autoiso.sh is the cd building automation script. (its not nearly complete though)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rsync/files/digest-rsync-2.4.6-r41
-rw-r--r--net-misc/rsync/rsync-2.4.6-r4.ebuild48
-rw-r--r--net-misc/wget/files/digest-wget-1.7-r12
-rw-r--r--net-misc/wget/wget-1.7-r1.ebuild58
4 files changed, 109 insertions, 0 deletions
diff --git a/net-misc/rsync/files/digest-rsync-2.4.6-r4 b/net-misc/rsync/files/digest-rsync-2.4.6-r4
new file mode 100644
index 000000000000..aba39e5e0aa3
--- /dev/null
+++ b/net-misc/rsync/files/digest-rsync-2.4.6-r4
@@ -0,0 +1 @@
+MD5 2ceb5e659f257c89569664c780b6fa6c rsync-2.4.6.tar.gz
diff --git a/net-misc/rsync/rsync-2.4.6-r4.ebuild b/net-misc/rsync/rsync-2.4.6-r4.ebuild
new file mode 100644
index 000000000000..9d5e0fa0b1aa
--- /dev/null
+++ b/net-misc/rsync/rsync-2.4.6-r4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.4.6-r4.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="File transfer program to keep remote files into sync"
+SRC_URI="http://rsync.samba.org/ftp/rsync/${A}"
+HOMEPAGE="http://rsync.samba.org"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+#change confdir to /etc/rsync rather than just /etc (the --sysconfdir configure option doesn't work
+ cp rsync.h rsync.h.orig
+ sed -e 's:RSYNCD_CONF "/etc/rsyncd.conf":RSYNCD_CONF "/etc/rsync/rsyncd.conf":g' rsync.h.orig > rsync.h
+#yes, updating the man page is very important.
+ cp rsyncd.conf.5 rsyncd.conf.5.orig
+ sed -e 's:/etc/rsyncd:/etc/rsync/rsyncd:g' rsyncd.conf.5.orig > rsyncd.conf.5
+}
+
+src_compile() {
+
+ try ./configure --prefix=/usr --host=${CHOST}
+ if [ "`use static`" ] ; then
+ try make LDFLAGS=\"-static\"
+ else
+ try make
+ fi
+
+}
+
+src_install () {
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ] ; then
+ try make prefix=${D}/usr mandir=${D}/usr/share/man install
+ dodir /etc/rsync
+ dodoc COPYING README
+ else
+ dobin rsync
+ fi
+
+}
+
+
diff --git a/net-misc/wget/files/digest-wget-1.7-r1 b/net-misc/wget/files/digest-wget-1.7-r1
new file mode 100644
index 000000000000..931659a99c55
--- /dev/null
+++ b/net-misc/wget/files/digest-wget-1.7-r1
@@ -0,0 +1,2 @@
+MD5 c911a6b937c0a18757d3211fb62831de wget-1.7.tar.gz
+MD5 89af3cfe1500f009abb40120c6b5edd6 wget-new-percentage-1.7-20010606.diff
diff --git a/net-misc/wget/wget-1.7-r1.ebuild b/net-misc/wget/wget-1.7-r1.ebuild
new file mode 100644
index 000000000000..629be84dfbcc
--- /dev/null
+++ b/net-misc/wget/wget-1.7-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.7-r1.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A="${P}.tar.gz wget-new-percentage-1.7-20010606.diff"
+S=${WORKDIR}/${P}
+DESCRIPTION="Network utility to retrieve files from the WWW"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/wget/${P}.tar.gz
+ ftp://prep.ai.mit.edu/gnu/wget/${P}.tar.gz
+ http://www.biscom.net/~cade/away/wget-new-percentage/wget-new-percentage-1.7-20010606.diff"
+HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
+
+DEPEND="virtual/glibc sys-devel/perl
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}/src
+ patch -p0 < ${DISTDIR}/wget-new-percentage-1.7-20010606.diff
+}
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+# if [ "`use ssl`" ] ; then
+# myconf="$myconf --with-ssl=/usr"
+# fi
+ if [ -z "$DEBUG" ] ; then
+ myconf="$myconf --disable-debug"
+ fi
+ try ./configure --prefix=/usr --sysconfdir=/etc/wget \
+ --infodir=/usr/share/info --mandir=usr/share/man $myconf
+ if [ "`use static`" ] ; then
+ try make -e LDFLAGS=\"--static\"
+ else
+ try make
+ fi
+}
+
+src_install() {
+
+ if [ "`use build`" ] || [ "`use bootcd`" ] ; then
+ dobin src/wget
+ else
+ try make prefix=${D}/usr sysconfdir=${D}/etc/wget \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+
+ dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ dodoc doc/sample.wgetrc
+ fi
+}
+
+