summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-09-03 21:47:39 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-09-03 21:47:39 +0000
commit537638e5a5d9f9f3af76b363cee60cfd47a2df69 (patch)
tree86d6f8832e143a8079377d6917bf8424871fc113 /net-misc
parentFixed ./configure for PAM missing in USE (needed --without-authpam (diff)
downloadhistorical-537638e5a5d9f9f3af76b363cee60cfd47a2df69.tar.gz
historical-537638e5a5d9f9f3af76b363cee60cfd47a2df69.tar.bz2
historical-537638e5a5d9f9f3af76b363cee60cfd47a2df69.zip
openssh fixums
Diffstat (limited to 'net-misc')
-rwxr-xr-xnet-misc/openssh/files/sshd14
-rw-r--r--[-rwxr-xr-x]net-misc/openssh/files/sshd.old (renamed from net-misc/openssh/files/openssh)0
-rw-r--r--net-misc/openssh/files/sshd.pam.old7
-rwxr-xr-xnet-misc/openssh/files/svc-openssh47
-rw-r--r--net-misc/openssh/openssh-2.9_p2-r1.ebuild55
-rw-r--r--net-misc/openssh/openssh-2.9_p2-r2.ebuild30
-rw-r--r--net-misc/openssh/openssh-2.9_p2.ebuild6
7 files changed, 29 insertions, 130 deletions
diff --git a/net-misc/openssh/files/sshd b/net-misc/openssh/files/sshd
index 43fe96207d4d..4c3e1d74fe8a 100755
--- a/net-misc/openssh/files/sshd
+++ b/net-misc/openssh/files/sshd
@@ -1,10 +1,9 @@
-#!/bin/sh
-SERVICE="OpenSSH"
+#!/sbin/runscript
+SERVICE="sshd"
PIDFILE=/var/run/sshd.pid
EXE=/usr/sbin/sshd
gen_keys() {
-
if [ ! -e /etc/ssh/ssh_host_key ] ; then
einfo "Generating Hostkey..."
/usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N ''
@@ -19,26 +18,17 @@ gen_keys() {
einfo "Generating RSA-Hostkey..."
/usr/bin/ssh-keygen -t rsa -f /etc/ssh/ssh_host_rsa_key -N ''
fi
-
}
start() {
gen_keys
-
ebegin "Starting $SERVICE"
start-stop-daemon --start --quiet --exec $EXE
eend $? "Started $SERVICE." "Error starting $SERVICE."
}
stop() {
-
ebegin "Stopping $SERVICE"
start-stop-daemon --stop --quiet --pidfile $PIDFILE --exec $EXE
eend $? "Stopped $SERVICE." "Error stopping $SERVICE."
}
-
-restart() {
- stop
- start
-}
-
diff --git a/net-misc/openssh/files/openssh b/net-misc/openssh/files/sshd.old
index 9c01fcf05fd3..9c01fcf05fd3 100755..100644
--- a/net-misc/openssh/files/openssh
+++ b/net-misc/openssh/files/sshd.old
diff --git a/net-misc/openssh/files/sshd.pam.old b/net-misc/openssh/files/sshd.pam.old
new file mode 100644
index 000000000000..7d308cb13a2b
--- /dev/null
+++ b/net-misc/openssh/files/sshd.pam.old
@@ -0,0 +1,7 @@
+auth required pam_pwdb.so nullok
+auth required pam_nologin.so
+auth required pam_env.so
+account required pam_pwdb.so
+password required pam_pwdb.so shadow
+session required pam_pwdb.so
+session required pam_limits.so
diff --git a/net-misc/openssh/files/svc-openssh b/net-misc/openssh/files/svc-openssh
deleted file mode 100755
index 764487d26cab..000000000000
--- a/net-misc/openssh/files/svc-openssh
+++ /dev/null
@@ -1,47 +0,0 @@
-#!/bin/sh
-#RCUPDATE:2 3 4:75:This line is required for script management
-
-. /etc/rc.d/config/functions
-
-SERVICE="sshd"
-opts="start stop"
-
-gen_keys() {
- if [ ! -e /etc/ssh/ssh_host_key ] ; then
- einfo "Generating Hostkey..."
- /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N ''
- fi
- if [ ! -e /etc/ssh/ssh_host_dsa_key ] ; then
- einfo "Generating DSA-Hostkey..."
- /usr/bin/ssh-keygen -d -f /etc/ssh/ssh_host_dsa_key -N ''
- fi
- if [ ! -e /etc/ssh/ssh_host_rsa_key ]
- then
- einfo "Generating RSA-Hostkey..."
- /usr/bin/ssh-keygen -t rsa -f /etc/ssh/ssh_host_rsa_key -N ''
- fi
-}
-
-start() {
- gen_keys
- ebegin "Starting $SERVICE"
- ln -sf ../services/${SERVICE} ${SVCDIR}/control/${SERVICE}
- eend $?
-}
-
-stop() {
- ebegin "Stopping $SERVICE"
- if [ -e ${SVCDIR}/control/${SERVICE} ]
- then
- /usr/bin/svc -dx ${SVCDIR}/control/${SERVICE}
- rm ${SVCDIR}/control/${SERVICE}
- fi
- eend $?
-}
-
-doservice ${@}
-
-
-
-
-
diff --git a/net-misc/openssh/openssh-2.9_p2-r1.ebuild b/net-misc/openssh/openssh-2.9_p2-r1.ebuild
deleted file mode 100644
index 60895541a980..000000000000
--- a/net-misc/openssh/openssh-2.9_p2-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-2.9_p2-r1.ebuild,v 1.2 2001/06/27 03:52:56 achim Exp $
-
-P=openssh-2.9p2
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Port of OpenBSD's free SSH release"
-SRC_URI="ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/"${A}
-HOMEPAGE="http://www.openssh.com/"
-
-DEPEND="virtual/glibc sys-devel/perl sys-apps/groff
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- pam? ( >=sys-libs/pam-0.73 )
- >=dev-libs/openssl-0.9.6"
-
-RDEPEND="virtual/glibc
- pam? ( >=sys-libs/pam-0.73 )
- >=dev-libs/openssl-0.9.6"
-
-src_compile() {
- local myconf
- if [ "`use tcpd`" ]
- then
- myconf="--with-tcp-wrappers"
- else
- myconf="--without-tcp-wrappers"
- fi
- if [ "`use pam`" ]
- then
- myconf="${myconf} --with-pam"
- else
- myconf="${myconf} --without-pam"
- fi
-
- try ./configure --prefix=/usr --sysconfdir=/etc/ssh \
- --libexecdir=/usr/lib/misc --mandir=/usr/share/man \
- --with-ipv4-default --disable-suid-ssh --host=${CHOST} ${myconf}
- try make
-}
-
-src_install() {
-
- try make install-files DESTDIR=${D}
- dodoc ChangeLog CREDITS OVERVIEW README* TODO
- insinto /etc/pam.d
- donewins ${FILESDIR}/sshd.pam sshd
- exeinto /etc/rc.d/init.d
- newexe ${FILESDIR}/openssh sshd
- newexe ${FILESDIR}/svc-openssh svc-sshd
- exeinto /var/lib/supervise/services/sshd
- newexe ${FILESDIR}/sshd-run run
-}
-
diff --git a/net-misc/openssh/openssh-2.9_p2-r2.ebuild b/net-misc/openssh/openssh-2.9_p2-r2.ebuild
index 6d600a9ac565..f6ffb0b59afd 100644
--- a/net-misc/openssh/openssh-2.9_p2-r2.ebuild
+++ b/net-misc/openssh/openssh-2.9_p2-r2.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-2.9_p2-r2.ebuild,v 1.2 2001/08/24 06:04:59 chadh Exp $
+# Team: System Team <system@gentoo.org>
+# Author: Achim Gottinger <achim@gentoo.org>, Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-2.9_p2-r2.ebuild,v 1.3 2001/09/03 21:47:39 drobbins Exp $
-P=openssh-2.9p2
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Port of OpenBSD's free SSH release"
-SRC_URI="ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/"${A}
+SRC_URI="ftp://ftp.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/openssh-2.9p2.tar.gz"
HOMEPAGE="http://www.openssh.com/"
DEPEND="virtual/glibc sys-devel/perl sys-apps/groff
@@ -34,18 +33,23 @@ src_compile() {
myconf="${myconf} --without-pam"
fi
- try ./configure --prefix=/usr --sysconfdir=/etc/ssh \
+ ./configure --prefix=/usr --sysconfdir=/etc/ssh \
--libexecdir=/usr/lib/misc --mandir=/usr/share/man \
- --with-ipv4-default --disable-suid-ssh --host=${CHOST} ${myconf}
- try make
+ --with-ipv4-default --disable-suid-ssh --host=${CHOST} ${myconf} || die
+ make || die
}
src_install() {
-
- try make install-files DESTDIR=${D}
+ make install-files DESTDIR=${D} || die
dodoc ChangeLog CREDITS OVERVIEW README* TODO
insinto /etc/pam.d
donewins ${FILESDIR}/sshd.pam sshd
- exeinto /etc/rc.d/init.d
- newexe ${FILESDIR}/sshd sshd
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/openssh sshd
+}
+
+pkg_postinst() {
+ # Make ssh start at boot
+ rc-update add sshd default
}
+
diff --git a/net-misc/openssh/openssh-2.9_p2.ebuild b/net-misc/openssh/openssh-2.9_p2.ebuild
index c65b48fbf760..96d001eba816 100644
--- a/net-misc/openssh/openssh-2.9_p2.ebuild
+++ b/net-misc/openssh/openssh-2.9_p2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-2.9_p2.ebuild,v 1.1 2001/06/21 15:52:58 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-2.9_p2.ebuild,v 1.2 2001/09/03 21:47:39 drobbins Exp $
P=openssh-2.9p2
A=${P}.tar.gz
@@ -45,9 +45,9 @@ src_install() {
try make install-files DESTDIR=${D}
dodoc ChangeLog CREDITS OVERVIEW README* TODO
insinto /etc/pam.d
- donewins ${FILESDIR}/sshd.pam sshd
+ newins ${FILESDIR}/sshd.pam.old sshd
exeinto /etc/rc.d/init.d
- newexe ${FILESDIR}/openssh sshd
+ newexe ${FILESDIR}/sshd.old sshd
newexe ${FILESDIR}/svc-openssh svc-sshd
exeinto /var/lib/supervise/services/sshd
newexe ${FILESDIR}/sshd-run run