summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2000-12-22 20:59:27 +0000
committerDaniel Robbins <drobbins@gentoo.org>2000-12-22 20:59:27 +0000
commit52d8e1dde433417c7938fa26ceca2754f38b89f9 (patch)
treef1c1808da5086345ea513ca6cca1fa7600748373 /net-misc
parentOops, just committed the version with the typo. (diff)
downloadhistorical-52d8e1dde433417c7938fa26ceca2754f38b89f9.tar.gz
historical-52d8e1dde433417c7938fa26ceca2754f38b89f9.tar.bz2
historical-52d8e1dde433417c7938fa26ceca2754f38b89f9.zip
some important fixes
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/bind/bind-9.0.1-r1.ebuild45
1 files changed, 30 insertions, 15 deletions
diff --git a/net-misc/bind/bind-9.0.1-r1.ebuild b/net-misc/bind/bind-9.0.1-r1.ebuild
index 51e3375767bd..72c21209df80 100644
--- a/net-misc/bind/bind-9.0.1-r1.ebuild
+++ b/net-misc/bind/bind-9.0.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bind/bind-9.0.1-r1.ebuild,v 1.1 2000/12/20 20:50:02 jerry Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bind/bind-9.0.1-r1.ebuild,v 1.2 2000/12/22 20:59:27 drobbins Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -13,26 +13,41 @@ DEPEND=">=sys-apps/bash-2.04
>=sys-devel/libtool-1.3.5
>=sys-libs/glibc-2.1.3"
+#this service should be upgraded to offer optional supervise support
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/doc/man
+ #fix man pages to reflect Gentoo Linux file locations (drobbins)
+ local x
+ for x in */*
+ do
+ cp ${x} ${x}.orig
+ sed -e 's:/etc/named.conf:/etc/bind/named.conf:g' -e 's:/etc/rndc.conf:/etc/bind/rndc.conf:g' ${x}.orig > ${x}
+ rm ${x}.orig
+ done
+}
+
src_compile() {
- try ./configure --prefix=/usr --host=${CHOST} \
- --sysconfdir=/etc/bind --localstatedir=/var --with-libtool
+ try ./configure --prefix=/usr --host=${CHOST} --sysconfdir=/etc/bind --localstatedir=/var --with-libtool
try make all
}
-
src_install() {
- dodir /usr/bin
- try make DESTDIR=${D} install
-
+ dodir /usr/bin
+ try make DESTDIR=${D} install
doman doc/man/*/*.[1-8]
-
dodir /etc/rc.d/init.d
- cp ${O}/files/named ${D}/etc/rc.d/init.d
- cp ${O}/files/named.conf ${D}/etc/bind/named.conf
+ cp ${FILESDIR}/named ${D}/etc/rc.d/init.d
+ dodir /etc/bind
+ cp ${FILESDIR}/named.conf ${D}/etc/bind/named.conf
+ cd ${S}/doc/arm
+ dodoc *.html
}
-pkg_config() {
- . ${ROOT}/etc/rc.d/config/functions
-
- echo "BIND enabled."
-}
+#bind needs config files set up correctly before it should be enabled.
+#pkg_config() {
+# . ${ROOT}/etc/rc.d/config/functions
+#
+# echo "BIND enabled."
+#}