summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-01-31 22:48:40 +0000
committerTod Neidt <tod@gentoo.org>2002-01-31 22:48:40 +0000
commite9d97289b41427d21790327a6cb6c09314fe198e (patch)
treef9cc11bb5c4662841f12771878fa45531817190b /net-misc/ytalk/ytalk-3.1.1.ebuild
parentfix problem with dumping the base files; basically errors in texmf, or it sti... (diff)
downloadhistorical-e9d97289b41427d21790327a6cb6c09314fe198e.tar.gz
historical-e9d97289b41427d21790327a6cb6c09314fe198e.tar.bz2
historical-e9d97289b41427d21790327a6cb6c09314fe198e.zip
User contributed ebuild, initial commit (Thanks Chris Giorgi!)
Diffstat (limited to 'net-misc/ytalk/ytalk-3.1.1.ebuild')
-rw-r--r--net-misc/ytalk/ytalk-3.1.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/ytalk/ytalk-3.1.1.ebuild b/net-misc/ytalk/ytalk-3.1.1.ebuild
new file mode 100644
index 000000000000..1ec1f826e303
--- /dev/null
+++ b/net-misc/ytalk/ytalk-3.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Chris Giorgi <chrisgio@virtualscape.net>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ytalk/ytalk-3.1.1.ebuild,v 1.1 2002/01/31 22:48:40 tod Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Multi-user replacement for UNIX talk"
+
+SRC_URI="http://www.iagora.com/~espel/ytalk/${P}.tar.gz"
+
+HOMEPAGE="http://www.iagora.com/~espel/ytalk/ytalk.html"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ X? ( virtual/x11 )"
+
+src_compile() {
+
+ local myconf=""
+ use X || myconf="$myconf --without-x" #default enabled
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die "Installation Failed"
+
+ dodoc BUGS ChangeLog INSTALL README README.old
+
+}
+
+