summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-03-21 01:56:47 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-03-21 01:56:47 +0000
commite83bcf00d7b5ae5c1ffba37f17e81cb206f46f6c (patch)
treeb2357ded4cf55b08ee589fab6e5a67d4d46e9ba9 /net-misc/yate
parentAdded local use-flags for yate (diff)
downloadhistorical-e83bcf00d7b5ae5c1ffba37f17e81cb206f46f6c.tar.gz
historical-e83bcf00d7b5ae5c1ffba37f17e81cb206f46f6c.tar.bz2
historical-e83bcf00d7b5ae5c1ffba37f17e81cb206f46f6c.zip
Initial import.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-misc/yate')
-rw-r--r--net-misc/yate/ChangeLog10
-rw-r--r--net-misc/yate/Manifest4
-rw-r--r--net-misc/yate/files/digest-yate-0.8.71
-rw-r--r--net-misc/yate/metadata.xml9
-rw-r--r--net-misc/yate/yate-0.8.7.ebuild85
5 files changed, 109 insertions, 0 deletions
diff --git a/net-misc/yate/ChangeLog b/net-misc/yate/ChangeLog
new file mode 100644
index 000000000000..88014e14bbe3
--- /dev/null
+++ b/net-misc/yate/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/yate
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/yate/ChangeLog,v 1.1 2005/03/21 01:56:47 stkn Exp $
+
+*yate-0.8.7 (21 Mar 2005)
+
+ 21 Mar 2005; Stefan Knoblich <stkn@gentoo.org> +metadata.xml,
+ +yate-0.8.7.ebuild:
+ Initial import. Ebuild submitted by chetan on irc.
+
diff --git a/net-misc/yate/Manifest b/net-misc/yate/Manifest
new file mode 100644
index 000000000000..fa5243088b7b
--- /dev/null
+++ b/net-misc/yate/Manifest
@@ -0,0 +1,4 @@
+MD5 aaa59eed2e51b579fc71194ee5c51fe2 yate-0.8.7.ebuild 2003
+MD5 44cf247f04cc83413fcb40ed59d0847a metadata.xml 248
+MD5 1dbfa8151a0c079009cfb1880697e10a ChangeLog 364
+MD5 9b480e9a4409cd15839e2a7338714ccf files/digest-yate-0.8.7 62
diff --git a/net-misc/yate/files/digest-yate-0.8.7 b/net-misc/yate/files/digest-yate-0.8.7
new file mode 100644
index 000000000000..3465768ecee9
--- /dev/null
+++ b/net-misc/yate/files/digest-yate-0.8.7
@@ -0,0 +1 @@
+MD5 96e2e915a3485fe5f4621c80586569d4 yate-0.8.7.tar.gz 309077
diff --git a/net-misc/yate/metadata.xml b/net-misc/yate/metadata.xml
new file mode 100644
index 000000000000..10f27dc5e06a
--- /dev/null
+++ b/net-misc/yate/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>voip</herd>
+<maintainer>
+ <email>stkn@gentoo.org</email>
+ <name>Stefan Knoblich</name>
+</maintainer>
+</pkgmetadata>
diff --git a/net-misc/yate/yate-0.8.7.ebuild b/net-misc/yate/yate-0.8.7.ebuild
new file mode 100644
index 000000000000..2ed2aa271487
--- /dev/null
+++ b/net-misc/yate/yate-0.8.7.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/yate/yate-0.8.7.ebuild,v 1.1 2005/03/21 01:56:47 stkn Exp $
+
+IUSE="h323 postgres zaptel fax qt gtk gsm ortp"
+
+inherit eutils
+
+DESCRIPTION="YATE - Yet Another Telephony Engine"
+HOMEPAGE="http://yate.null.ro/"
+SRC_URI="http://voip.null.ro/tarballs/${P}.tar.gz"
+
+S=${WORKDIR}/${PN}
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="media-sound/sox
+ postgres? ( dev-db/postgresql )
+ zaptel? ( >=net-libs/libpri-1.0.0
+ >=net-misc/zaptel-1.0.0 )
+ h323? ( >=net-libs/openh323-1.13.0 )
+ fax? ( >=media-libs/spandsp )
+ qt? ( x11-libs/qt )
+ gtk? ( <x11-libs/gtk+-2.0.0 )
+ gsm? ( media-sound/gsm )
+ ortp? ( net-libs/ortp )"
+
+
+src_compile() {
+ local myconf
+
+ use postgres \
+ && myconf="${myconf} --with-libpq=/usr" \
+ || myconf="${myconf} --without-libpq"
+
+ use fax \
+ && myconf="${myconf} --with-spandsp=/usr" \
+ || myconf="${myconf} --without-spandsp"
+
+ use qt \
+ && myconf="${myconf} --with-libqt=${QTDIR}" \
+ || myconf="${myconf} --without-libqt"
+
+ use gtk \
+ && myconf="${myconf} --with-libgtk" \
+ || myconf="${myconf} --without-libgtk"
+
+ use h323 \
+ && myconf="${myconf} --with-openh323=/usr --with-pwlib=/usr" \
+ || myconf="${myconf} --without-openh323 --without-pwlib"
+
+ use zaptel \
+ && myconf="${myconf} --with-libpri" \
+ || myconf="${myconf} --without-libpri"
+
+ use gsm \
+ && myconf="${myconf} --with-libgsm" \
+ || myconf="${myconf} --without-libgsm"
+
+ use ortp \
+ && myconf="${myconf} --with-libortp=/usr" \
+ || myconf="${myconf} --without-libortp"
+
+ econf ${myconf} || die "Configure failed"
+ emake everything || die "Make failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "Make install failed"
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/yate.rc6 yate
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/yate.confd yate
+
+ # install standard docs...
+ dodoc README ChangeLog
+ dodoc docs/*
+
+ docinto scripts
+ dodoc scripts/*
+}