summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-11-03 23:54:36 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-11-03 23:54:36 +0000
commita1baeaa9b85528c1d56c31fdc005df175bc73943 (patch)
tree7ec2ce8e337beedd5f5075d796769a09792b54ba /net-misc/wget
parentipv6+ipv4 both worky now (diff)
downloadhistorical-a1baeaa9b85528c1d56c31fdc005df175bc73943.tar.gz
historical-a1baeaa9b85528c1d56c31fdc005df175bc73943.tar.bz2
historical-a1baeaa9b85528c1d56c31fdc005df175bc73943.zip
ipv6+ipv4 both worky now
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/Manifest4
-rw-r--r--net-misc/wget/files/digest-wget-1.9-r12
-rw-r--r--net-misc/wget/wget-1.9-r1.ebuild64
3 files changed, 68 insertions, 2 deletions
diff --git a/net-misc/wget/Manifest b/net-misc/wget/Manifest
index d5f00aa0371a..490c2b83ca13 100644
--- a/net-misc/wget/Manifest
+++ b/net-misc/wget/Manifest
@@ -1,8 +1,8 @@
-MD5 783adcacb5736faf2bbf7b6643f300d9 wget-1.9-r1.ebuild 1511
+MD5 2b173c7a1e9e4a4a1aa7a6541b8c7316 wget-1.9-r1.ebuild 1587
MD5 11961cb8da0a697d08440e6f562a805a wget-1.8.2-r3.ebuild 1856
MD5 11a2d154392f421f59c74d6aee578868 wget-1.9.ebuild 1570
MD5 faedc243c4a25749bfd24b3783fb53bf wget-1.8.2-r2.ebuild 1809
-MD5 f5579c706beca8c4bf36c477fdbd8d40 ChangeLog 3542
+MD5 eb7b3ebc6ec63e6667bb68a1b864e5e5 ChangeLog 3877
MD5 48b772b0df559de2f74806e618687ccb files/digest-wget-1.9 144
MD5 37da667ed578ec42044b54637f46a3ae files/digest-wget-1.9-r1 127
MD5 987b30c931a50d2dc02a905c29f84821 files/wget-1.8.2-gentoo.diff 1549
diff --git a/net-misc/wget/files/digest-wget-1.9-r1 b/net-misc/wget/files/digest-wget-1.9-r1
new file mode 100644
index 000000000000..8b24ce0890fd
--- /dev/null
+++ b/net-misc/wget/files/digest-wget-1.9-r1
@@ -0,0 +1,2 @@
+MD5 18ac093db70801b210152dd69b4ef08a wget-1.9.tar.gz 1315995
+MD5 736cf284b5bbd861e403cfeb2a843465 wget-1.9+ipvmisc.patch 25623
diff --git a/net-misc/wget/wget-1.9-r1.ebuild b/net-misc/wget/wget-1.9-r1.ebuild
new file mode 100644
index 000000000000..1fa4cbe4ba40
--- /dev/null
+++ b/net-misc/wget/wget-1.9-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.9-r1.ebuild,v 1.1 2003/11/03 23:54:35 seemant Exp $
+
+inherit gnuconfig
+
+IUSE="ssl nls static ipv6 debug socks5"
+
+NPVER=20031022
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
+SRC_URI="mirror://gnu/wget/${P}.tar.gz
+ http://www.episec.com/people/edelkind/patches/wget/${P}+ipvmisc.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~arm ~mips ~amd64 ~ia64"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ epatch ${DISTDIR}/${P}+ipvmisc.patch
+}
+
+src_compile() {
+ # Make wget use up-to-date configure scripts
+ gnuconfig_update
+
+ local myconf
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
+
+ use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
+
+ econf \
+ --sysconfdir=/etc/wget \
+ `use_enable ipv6` \
+ `use_enable nls` \
+ `use_enable debug` \
+ `use_with socks5 socks` \
+ ${myconf} || die
+
+ if use static; then
+ emake LDFLAGS="--static" || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ if use build; then
+ insinto /usr
+ dobin ${S}/src/wget
+ return
+ fi
+ make prefix=${D}/usr sysconfdir=${D}/etc/wget \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
+ dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ dodoc doc/sample.wgetrc
+}