summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-03-24 16:41:25 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-03-24 16:41:25 +0000
commit66fd86992e630f35f106d2532b67c92713a0cba5 (patch)
treec0d3ccaf0d93fdf6e7bf7e66a7de16793d58de37 /net-misc/udpcast/udpcast-20050226.ebuild
parentppc64 hvc device support, bug #86433 (diff)
downloadhistorical-66fd86992e630f35f106d2532b67c92713a0cba5.tar.gz
historical-66fd86992e630f35f106d2532b67c92713a0cba5.tar.bz2
historical-66fd86992e630f35f106d2532b67c92713a0cba5.zip
version bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-misc/udpcast/udpcast-20050226.ebuild')
-rw-r--r--net-misc/udpcast/udpcast-20050226.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/udpcast/udpcast-20050226.ebuild b/net-misc/udpcast/udpcast-20050226.ebuild
new file mode 100644
index 000000000000..c6abc2da7877
--- /dev/null
+++ b/net-misc/udpcast/udpcast-20050226.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/udpcast/udpcast-20050226.ebuild,v 1.1 2005/03/24 16:41:25 vanquirius Exp $
+
+IUSE=""
+DESCRIPTION="Multicast file transfer tool"
+HOMEPAGE="http://udpcast.linux.lu/"
+SRC_URI="http://udpcast.linux.lu/current/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="virtual/libc
+ dev-lang/perl"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # sed the manpages to only depend on one because the rule that
+ # builds them makes them both ... however, if we build in parallel,
+ # the command may be run twice thus clobbering each other
+ sed -i \
+ -e 's:/sbin:/bin:' \
+ -e "/^CFLAGS =/s:$: ${CFLAGS}:" \
+ -e 's:udp-receiver\.1 udp-sender\.1:udp-receiver.1:' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc Changelog.txt
+}