summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-08-18 00:34:19 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-08-18 00:34:19 +0000
commit057995316b58718294d6f112f7f0780d95df7418 (patch)
treef32c9f5b9dede8b5b7feb8e4f9d47267e8e63d89 /net-misc/tightvnc
parentReverted mailsubdir change as it may break many client installs. (diff)
downloadhistorical-057995316b58718294d6f112f7f0780d95df7418.tar.gz
historical-057995316b58718294d6f112f7f0780d95df7418.tar.bz2
historical-057995316b58718294d6f112f7f0780d95df7418.zip
new version
Diffstat (limited to 'net-misc/tightvnc')
-rw-r--r--net-misc/tightvnc/ChangeLog6
-rw-r--r--net-misc/tightvnc/files/digest-tightvnc-1.2.51
-rw-r--r--net-misc/tightvnc/tightvnc-1.2.5.ebuild47
3 files changed, 53 insertions, 1 deletions
diff --git a/net-misc/tightvnc/ChangeLog b/net-misc/tightvnc/ChangeLog
index 6825120b766a..5e5ec441e6d4 100644
--- a/net-misc/tightvnc/ChangeLog
+++ b/net-misc/tightvnc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/tightvnc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.6 2002/07/12 20:40:42 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.7 2002/08/18 00:34:19 verwilst Exp $
+
+*tightvnc-1.2.5 (18 Aug 2002)
+
+ New version
*tightvnc-1.2.3-r2 (12 Jul 2002)
diff --git a/net-misc/tightvnc/files/digest-tightvnc-1.2.5 b/net-misc/tightvnc/files/digest-tightvnc-1.2.5
new file mode 100644
index 000000000000..f6df76668abe
--- /dev/null
+++ b/net-misc/tightvnc/files/digest-tightvnc-1.2.5
@@ -0,0 +1 @@
+MD5 039b4bca1ba81f57f9f564a6d86aad0c tightvnc-1.2.5_unixsrc.tar.bz2 1710193
diff --git a/net-misc/tightvnc/tightvnc-1.2.5.ebuild b/net-misc/tightvnc/tightvnc-1.2.5.ebuild
new file mode 100644
index 000000000000..aa187cc72222
--- /dev/null
+++ b/net-misc/tightvnc/tightvnc-1.2.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $ Header: $
+
+S="${WORKDIR}/vnc_unixsrc"
+DESCRIPTION="A great client/server software package allowing remote network access to graphical desktops."
+SRC_URI="mirror://sourceforge/vnc-tight/${P}_unixsrc.tar.bz2"
+HOMEPAGE="http://www.tightvnc.com"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND="virtual/glibc
+ >=x11-base/xfree-4.1.0
+ >=sys-devel/perl-5.6.1
+ ~media-libs/jpeg-6b
+ >=sys-libs/zlib-1.1.4"
+
+RDEPEND=$DEPEND
+
+src_compile() {
+
+ cd ${S}
+ xmkmf || die
+ make World || die
+ cd Xvnc
+ ./configure || die
+ make || die
+
+}
+
+src_install() {
+
+ cd ${S}
+ mkdir -p ${D}/usr/man
+ mkdir -p ${D}/usr/man/man1
+ mkdir -p ${D}/usr/bin
+
+ # fix the web based interface, it needs the java class files
+ mkdir -p ${D}/usr/share/tightvnc
+ mkdir -p ${D}/usr/share/tightvnc/classes
+ insinto /usr/share/tightvnc/classes ; doins classes/*
+
+ # and then patch vncserver to point to /usr/share/tightvnc/classes
+ patch -p0 < ${FILESDIR}/tightvnc-gentoo.diff || die
+
+ ./vncinstall ${D}/usr/bin ${D}/usr/man || die
+}