summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2006-06-18 17:16:39 +0000
committerGustavo Felisberto <humpback@gentoo.org>2006-06-18 17:16:39 +0000
commit01b98a12964ddcfe1dae9c4da798c1e2ba9bcb99 (patch)
tree4515a1ce532e190294e473094c225d53ffb21497 /net-misc/sobby/sobby-0.4.0_rc1.ebuild
parentuncomment dirmngr RDEPEND, bug 131039 (diff)
downloadhistorical-01b98a12964ddcfe1dae9c4da798c1e2ba9bcb99.tar.gz
historical-01b98a12964ddcfe1dae9c4da798c1e2ba9bcb99.tar.bz2
historical-01b98a12964ddcfe1dae9c4da798c1e2ba9bcb99.zip
added rc version that works with other obby rc's
Package-Manager: portage-2.1.1_pre1
Diffstat (limited to 'net-misc/sobby/sobby-0.4.0_rc1.ebuild')
-rw-r--r--net-misc/sobby/sobby-0.4.0_rc1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/sobby/sobby-0.4.0_rc1.ebuild b/net-misc/sobby/sobby-0.4.0_rc1.ebuild
new file mode 100644
index 000000000000..0dc1119c581e
--- /dev/null
+++ b/net-misc/sobby/sobby-0.4.0_rc1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sobby/sobby-0.4.0_rc1.ebuild,v 1.1 2006/06/18 17:16:39 humpback Exp $
+
+inherit eutils
+
+#MY_P=${P/_rc/rc}
+#S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Standalone Obby server"
+HOMEPAGE="http://darcs.0x539.de/gobby"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+SRC_URI="http://releases.0x539.de/${PN}/${P/_/}.tar.gz"
+
+DEPEND=">=dev-cpp/glibmm-2.6
+ >=dev-libs/libsigc++-2.0
+ >=dev-libs/gmp-4.1.4
+ >=net-libs/obby-0.4.0_rc2"
+
+RDEPEND=""
+
+S=${WORKDIR}/${P/_/}
+
+src_compile() {
+ econf || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ insinto /etc/conf.d/
+ newins ${FILESDIR}/sobby-conf-0.2.0 sobby
+
+ exeinto /etc/init.d/
+ newexe ${FILESDIR}/sobby-init-0.2.0 sobby
+}
+
+pkg_postinst() {
+ if built_with_use net-libs/obby howl
+ then
+ einfo "Zeroconf support has been enabled for sobby"
+ else
+ einfo "net-libs/obby was not build with zeroconf support,"
+ einfo "thus zeroconf is not enabled for ${PN}."
+ einfo ""
+ einfo "To get zeroconf support, rebuild net-libs/obby"
+ einfo "with \"howl\" in your USE flags."
+ einfo "Try USE=\"howl\" emerge net-libs/obby net-misc/sobby,"
+ einfo "or add \"howl\" to your USE string in /etc/make.conf and"
+ einfo "emerge net-libs/obby"
+ fi
+
+ echo
+ einfo "To start sobby, you can use the init script:"
+ einfo " /etc/init.d/sobby start"
+ einfo ""
+ einfo "Please check the configuration in /etc/conf.d/sobby"
+ einfo "before you start sobby"
+}
+