summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-06-24 14:41:36 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-06-24 14:41:36 +0000
commit55bb5ceb70a56ae8913be5b4ce983c238c677952 (patch)
tree05bea55d67dec70eb0ac51426727b550bdf5546f /net-misc/remmina-plugins
parentalpha/ia64/sparc stable wrt #370961 (diff)
downloadhistorical-55bb5ceb70a56ae8913be5b4ce983c238c677952.tar.gz
historical-55bb5ceb70a56ae8913be5b4ce983c238c677952.tar.bz2
historical-55bb5ceb70a56ae8913be5b4ce983c238c677952.zip
Live ebuild thanks to Dan Weeks <dan@danweeks.net>. Bug #372443
Package-Manager: portage-2.1.9.49/cvs/Linux x86_64
Diffstat (limited to 'net-misc/remmina-plugins')
-rw-r--r--net-misc/remmina-plugins/ChangeLog8
-rw-r--r--net-misc/remmina-plugins/remmina-plugins-9999.ebuild80
2 files changed, 87 insertions, 1 deletions
diff --git a/net-misc/remmina-plugins/ChangeLog b/net-misc/remmina-plugins/ChangeLog
index cc7d7a90ac86..083064c43411 100644
--- a/net-misc/remmina-plugins/ChangeLog
+++ b/net-misc/remmina-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/remmina-plugins
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/remmina-plugins/ChangeLog,v 1.2 2011/06/23 11:58:36 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/remmina-plugins/ChangeLog,v 1.3 2011/06/24 14:40:55 hwoarang Exp $
+
+*remmina-plugins-9999 (24 Jun 2011)
+
+ 24 Jun 2011; Markos Chandras <hwoarang@gentoo.org>
+ +remmina-plugins-9999.ebuild:
+ Live ebuild thanks to Dan Weeks <dan@danweeks.net>. Bug #372443
*remmina-plugins-0.9.2-r1 (23 Jun 2011)
diff --git a/net-misc/remmina-plugins/remmina-plugins-9999.ebuild b/net-misc/remmina-plugins/remmina-plugins-9999.ebuild
new file mode 100644
index 000000000000..5f83e94c25c2
--- /dev/null
+++ b/net-misc/remmina-plugins/remmina-plugins-9999.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/remmina-plugins/remmina-plugins-9999.ebuild,v 1.1 2011/06/24 14:40:55 hwoarang Exp $
+
+EAPI=2
+EGIT_REPO_URI="git://remmina.git.sourceforge.net/gitroot/remmina/remmina"
+EGIT_PROJECT="remmina"
+EGIT_SOURCEDIR="${WORKDIR}"
+
+inherit autotools git-2 gnome2-utils
+
+DESCRIPTION="Set of plugins for Remmina GTK+ RDP, VNC, XDMCP and SSH client"
+HOMEPAGE="http://remmina.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls nx rdesktop ssh telepathy vnc xdmcp"
+
+RDEPEND=">=net-misc/remmina-0.8.0
+ nls? ( virtual/libintl )
+ nx? ( net-misc/nx )
+ rdesktop? ( =net-misc/freerdp-9999 )
+ xdmcp? ( x11-base/xorg-server[kdrive] )
+ ssh? ( net-libs/libssh[sftp] )
+ vnc? ( net-libs/libvncserver )"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+ telepathy? ( >=net-libs/telepathy-glib-0.9.0 ) "
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ intltoolize --force --copy --automake
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="--disable-dependency-tracking"
+ if use nx; then
+ if ! use ssh; then
+ myconf="${myconf} --disable-nx"
+ ewarn "nx support requires ssh."
+ ewarn "nx support will not be included."
+ else
+ myconf="${myconf} --enable-nx"
+ fi
+ else
+ myconf="${myconf} --disable-nx"
+ fi
+
+ econf \
+ ${myconf} \
+ $(use_enable nls) \
+ $(use_enable rdesktop rdp) \
+ $(use_enable ssh) \
+ $(use_enable telepathy) \
+ $(use_enable vnc ) \
+ $(use_enable xdmcp)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}