summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-11-13 10:38:19 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-11-13 10:38:19 +0000
commite6c81df3087f0da971470b1c0b262fc00ce50aea (patch)
tree7d63d9ba90989e56a96e2c84f82911470d188a96 /net-misc/rdate/rdate-1.4-r2.ebuild
parentMarked ppc stable for bug #154165. (diff)
downloadhistorical-e6c81df3087f0da971470b1c0b262fc00ce50aea.tar.gz
historical-e6c81df3087f0da971470b1c0b262fc00ce50aea.tar.bz2
historical-e6c81df3087f0da971470b1c0b262fc00ce50aea.zip
Bug #153235, fix param handling in init.d script.
Package-Manager: portage-2.1.2_rc1-r5
Diffstat (limited to 'net-misc/rdate/rdate-1.4-r2.ebuild')
-rw-r--r--net-misc/rdate/rdate-1.4-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/rdate/rdate-1.4-r2.ebuild b/net-misc/rdate/rdate-1.4-r2.ebuild
new file mode 100644
index 000000000000..39a41de8f782
--- /dev/null
+++ b/net-misc/rdate/rdate-1.4-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdate/rdate-1.4-r2.ebuild,v 1.1 2006/11/13 10:38:19 robbat2 Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="use TCP or UDP to retrieve the current time of another machine"
+HOMEPAGE="http://www.freshmeat.net/projects/rdate/"
+SRC_URI="ftp://people.redhat.com/sopwith/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ use ipv6 && append-flags "-DINET6"
+ emake RCFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install(){
+ make prefix="${D}/usr" install || die "make install failed"
+ newinitd ${FILESDIR}/rdate-initd-1.4-r2 rdate
+ newconfd ${FILESDIR}/rdate-confd rdate
+}