summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2005-04-05 21:09:36 +0000
committerDaniel Drake <dsd@gentoo.org>2005-04-05 21:09:36 +0000
commit028b7bb9dadd158cf2fe8ea716380c380615bfe1 (patch)
treef0e1f92b83be62611cb348e82675a0ff452e14b4 /net-misc/pavuk
parentStable on sparc (diff)
downloadhistorical-028b7bb9dadd158cf2fe8ea716380c380615bfe1.tar.gz
historical-028b7bb9dadd158cf2fe8ea716380c380615bfe1.tar.bz2
historical-028b7bb9dadd158cf2fe8ea716380c380615bfe1.zip
Version bump to fix bug 88028
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-misc/pavuk')
-rw-r--r--net-misc/pavuk/ChangeLog7
-rw-r--r--net-misc/pavuk/Manifest14
-rw-r--r--net-misc/pavuk/files/digest-pavuk-0.9.321
-rw-r--r--net-misc/pavuk/pavuk-0.9.32.ebuild55
4 files changed, 75 insertions, 2 deletions
diff --git a/net-misc/pavuk/ChangeLog b/net-misc/pavuk/ChangeLog
index cbcb65fbdde5..efcbe84de460 100644
--- a/net-misc/pavuk/ChangeLog
+++ b/net-misc/pavuk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/pavuk
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/ChangeLog,v 1.17 2005/03/23 16:18:53 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/ChangeLog,v 1.18 2005/04/05 21:09:36 dsd Exp $
+
+*pavuk-0.9.32 (05 Apr 2005)
+
+ 05 Apr 2005; Daniel Drake <dsd@gentoo.org> +pavuk-0.9.32.ebuild:
+ Version bump to fix bug 88028
23 Mar 2005; Seemant Kulleen <seemant@gentoo.org> pavuk-0.9.31.ebuild:
change dep from net-www/mozilla to www-client/mozilla
diff --git a/net-misc/pavuk/Manifest b/net-misc/pavuk/Manifest
index a0cec30f1242..8e531afabf49 100644
--- a/net-misc/pavuk/Manifest
+++ b/net-misc/pavuk/Manifest
@@ -1,4 +1,16 @@
-MD5 3c5e2e3b4eb661076b18e75b5f1b14be ChangeLog 2838
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 cce1034eaaa94e849e9b603d9f0945b7 pavuk-0.9.32.ebuild 1423
+MD5 491c2232358f9c31e85e97ec029dd080 ChangeLog 2963
MD5 a1457284faaa66902037dcd2eaeab292 metadata.xml 245
MD5 af5ba7d3c10514dc10923b250eee99c9 pavuk-0.9.31.ebuild 1424
MD5 0ecaaa14f3190993e307fea1f2d880d3 files/digest-pavuk-0.9.31 65
+MD5 452e79ff147b4c40cfee016d4c88c3bc files/digest-pavuk-0.9.32 65
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCUv6ziJcSIUGNthERAnAbAJ9Cmlj6nyYU3g2VpD9rnLoMMJSxFACeNgZQ
+hB6YzlbQ2YjBQSQgUxfkiEs=
+=5wjj
+-----END PGP SIGNATURE-----
diff --git a/net-misc/pavuk/files/digest-pavuk-0.9.32 b/net-misc/pavuk/files/digest-pavuk-0.9.32
new file mode 100644
index 000000000000..6ec345146de0
--- /dev/null
+++ b/net-misc/pavuk/files/digest-pavuk-0.9.32
@@ -0,0 +1 @@
+MD5 c5872ffe4f7df4c90b50935c0637c0ad pavuk-0.9.32.tar.bz2 645028
diff --git a/net-misc/pavuk/pavuk-0.9.32.ebuild b/net-misc/pavuk/pavuk-0.9.32.ebuild
new file mode 100644
index 000000000000..06f63110fcf3
--- /dev/null
+++ b/net-misc/pavuk/pavuk-0.9.32.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/pavuk-0.9.32.ebuild,v 1.1 2005/04/05 21:09:36 dsd Exp $
+
+inherit eutils
+
+DESCRIPTION="Web spider and website mirroring tool"
+HOMEPAGE="http://www.pavuk.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="ssl X gnome mozilla socks5 nls"
+
+DEPEND=">=sys-apps/sed-4
+ sys-devel/gettext
+ sys-libs/zlib
+ ssl? ( dev-libs/openssl )
+ X? ( virtual/x11 )
+ gnome? ( gnome-base/gnome-libs )
+ mozilla? ( www-client/mozilla )
+ socks5? ( net-misc/tsocks )"
+
+src_compile() {
+ econf \
+ --enable-threads \
+ --with-regex=auto \
+ --disable-gtk \
+ $(use_with X x) \
+ $(use_enable ssl) \
+ $(use_enable gnome) \
+ $(use_enable mozilla js) \
+ $(use_enable socks5 socks) \
+ $(use_enable nls) \
+ || die "econf failed"
+
+ emake || die
+}
+
+src_install() {
+ # fix sandbox violation for gnome .desktop and icon, and gnome menu entry
+ if use gnome
+ then
+ sed -i 's:GNOME_PREFIX = /usr:GNOME_PREFIX = ${D}usr:' Makefile
+ sed -i 's:GNOME_PREFIX = /usr:GNOME_PREFIX = ${D}usr:' icons/Makefile
+ sed -i 's:Type=Internet:Type=Application:' pavuk.desktop
+ fi
+
+ einstall || die
+
+ dodoc README CREDITS FAQ NEWS AUTHORS BUGS \
+ TODO MAILINGLIST ChangeLog wget-pavuk.HOWTO jsbind.txt \
+ pavuk_authinfo.sample pavukrc.sample
+}