summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Andreetta <satya@gentoo.org>2004-09-20 11:20:04 +0000
committerChristian Andreetta <satya@gentoo.org>2004-09-20 11:20:04 +0000
commitf7a5e31bb4d99fc44413a698b6718cbd730f5180 (patch)
tree642b3c14d40aa51ac3f6f389c0056912ad5b4bbf /net-misc/pam_smb/pam_smb-2.0.0_rc6.ebuild
parentadded missing / (diff)
downloadhistorical-f7a5e31bb4d99fc44413a698b6718cbd730f5180.tar.gz
historical-f7a5e31bb4d99fc44413a698b6718cbd730f5180.tar.bz2
historical-f7a5e31bb4d99fc44413a698b6718cbd730f5180.zip
version bump
Diffstat (limited to 'net-misc/pam_smb/pam_smb-2.0.0_rc6.ebuild')
-rw-r--r--net-misc/pam_smb/pam_smb-2.0.0_rc6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/pam_smb/pam_smb-2.0.0_rc6.ebuild b/net-misc/pam_smb/pam_smb-2.0.0_rc6.ebuild
new file mode 100644
index 000000000000..6e63d924c95d
--- /dev/null
+++ b/net-misc/pam_smb/pam_smb-2.0.0_rc6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pam_smb/pam_smb-2.0.0_rc6.ebuild,v 1.1 2004/09/20 11:20:04 satya Exp $
+
+DESCRIPTION="The PAM SMB module, which allows authentication against a SMB (such as the Win_x families) server."
+HOMEPAGE="http://www.csn.ul.ie/~airlied/pam_smb/"
+
+MY_P=${P/_rc/-rc}
+
+S=${WORKDIR}/${MY_P}
+SRC_URI="mirror://samba/pam_smb/v2/${MY_P}.tar.gz
+ http://www.csn.ul.ie/~airlied/pam_smb/v2/${MY_P}.tar.gz"
+
+DEPEND=">=sys-libs/pam-0.75"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_compile() {
+ econf --disable-root-only || die
+ emake || die
+}
+
+src_install() {
+ exeinto /lib/security
+ doexe pamsmbm/pam_smb_auth.so
+ exeinto /usr/sbin
+ doexe pamsmbd/pamsmbd
+
+ dodoc BUGS CHANGES COPYING README TODO INSTALL \
+ faq/{pam_smb_faq.sgml,additions.txt}
+ docinto pam.d
+ dodoc pam_smb.conf*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pamsmbd-init pamsmbd
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You must create /etc/pam_smb.conf yourself, containing"
+ einfo "your domainname, PDC and BDC. See example files in docdir."
+ einfo
+}