summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-08-30 20:20:13 +0000
committerStuart Herbert <stuart@gentoo.org>2004-08-30 20:20:13 +0000
commitb30a2f8ad8ae2380a66de589cf27fcadcd9150ec (patch)
tree6def7d8205cb595c38859f6e3c914a2c03a61178 /net-misc/nxssh
parentInitial version (diff)
downloadhistorical-b30a2f8ad8ae2380a66de589cf27fcadcd9150ec.tar.gz
historical-b30a2f8ad8ae2380a66de589cf27fcadcd9150ec.tar.bz2
historical-b30a2f8ad8ae2380a66de589cf27fcadcd9150ec.zip
Version bump
Diffstat (limited to 'net-misc/nxssh')
-rw-r--r--net-misc/nxssh/ChangeLog7
-rw-r--r--net-misc/nxssh/files/digest-nxssh-1.4.01
-rw-r--r--net-misc/nxssh/nxssh-1.4.0.ebuild51
3 files changed, 58 insertions, 1 deletions
diff --git a/net-misc/nxssh/ChangeLog b/net-misc/nxssh/ChangeLog
index 96189d516b54..c85b9ac2974e 100644
--- a/net-misc/nxssh/ChangeLog
+++ b/net-misc/nxssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/nxssh
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxssh/ChangeLog,v 1.9 2004/06/25 00:02:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxssh/ChangeLog,v 1.10 2004/08/30 20:20:13 stuart Exp $
+
+*nxssh-1.4.0 (30 Aug 2004)
+
+ 30 Aug 2004; Stuart Herbert <stuart@gentoo.org> +nxssh-1.4.0.ebuild:
+ Version bump; required for freenx.
*nxssh-1.3.2 (13 May 2004)
diff --git a/net-misc/nxssh/files/digest-nxssh-1.4.0 b/net-misc/nxssh/files/digest-nxssh-1.4.0
new file mode 100644
index 000000000000..e908e074a3f8
--- /dev/null
+++ b/net-misc/nxssh/files/digest-nxssh-1.4.0
@@ -0,0 +1 @@
+MD5 08025d674354a83d5f355f1c22a39fef nxssh-1.4.0-15.tar.gz 859179
diff --git a/net-misc/nxssh/nxssh-1.4.0.ebuild b/net-misc/nxssh/nxssh-1.4.0.ebuild
new file mode 100644
index 000000000000..63d5435e9833
--- /dev/null
+++ b/net-misc/nxssh/nxssh-1.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxssh/nxssh-1.4.0.ebuild,v 1.1 2004/08/30 20:20:13 stuart Exp $
+
+MY_P="${PN}-${PV}-15"
+DESCRIPTION="Modified openssh client, used by nxclient"
+HOMEPAGE="http://www.nomachine.com/"
+SRC_URI="http://www.nomachine.com/download/snapshot/nxsources/${MY_P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc -sparc -mips -alpha"
+DEPEND=">=dev-libs/openssl-0.9.7d-r1
+ >=sys-libs/glibc-2.3.3.20040420-r1
+ >=sys-libs/zlib-1.2.1-r2"
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+IUSE="ipv6 kerberos pam tcpd"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ local myconf
+
+ use tcpd || myconf="${myconf} --without-tcp-wrappers"
+ use tcpd && myconf="${myconf} --with-tcp-wrappers"
+ use pam || myconf="${myconf} --without-pam"
+ use pam && myconf="${myconf} --with-pam"
+ use ipv6 || myconf="${myconf} --with-ipv4-default"
+
+ # app-crypt/mit-krb5
+ use kerberos && myconf="${myconf} --with-kerberos5"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/ssh \
+ --mandir=/usr/share/man \
+ --libexecdir=/usr/lib/misc \
+ --datadir=/usr/share/openssh \
+ --disable-suid-ssh \
+ --with-privsep-path=/var/empty \
+ --with-privsep-user=sshd \
+ --with-md5-passwords \
+ --host=${CHOST} ${myconf} || die "bad configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/NX/bin
+ doexe nxssh
+}