summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPreston A. Elder <prez@gentoo.org>2003-04-28 14:51:08 +0000
committerPreston A. Elder <prez@gentoo.org>2003-04-28 14:51:08 +0000
commit52a14ca5c18a9b58491e5b1d529f666bdb2a2cdd (patch)
tree4ebfd689866eb3a26da2b517de426f1b306cadcb /net-misc/nut
parentinitial import, closing bug 6659 (diff)
downloadhistorical-52a14ca5c18a9b58491e5b1d529f666bdb2a2cdd.tar.gz
historical-52a14ca5c18a9b58491e5b1d529f666bdb2a2cdd.tar.bz2
historical-52a14ca5c18a9b58491e5b1d529f666bdb2a2cdd.zip
Unmasked for x86, and made it detect apache
Diffstat (limited to 'net-misc/nut')
-rw-r--r--net-misc/nut/ChangeLog5
-rw-r--r--net-misc/nut/nut-1.2.2.ebuild31
2 files changed, 22 insertions, 14 deletions
diff --git a/net-misc/nut/ChangeLog b/net-misc/nut/ChangeLog
index 0a88cb4a2de3..2cd5e980eece 100644
--- a/net-misc/nut/ChangeLog
+++ b/net-misc/nut/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for net-misc/nut
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/ChangeLog,v 1.13 2003/04/21 03:32:55 prez Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/ChangeLog,v 1.14 2003/04/28 14:50:54 prez Exp $
*nut-1.2.2 (20 Apr 2003)
+ 28 Apr 2003; Preston A. Elder <prez@gentoo.org> nut-1.2.2.ebuild :
+ Used better way to add cgi-bin depenancy, and unmasked.
+
20 Apr 2003; Preston A. Elder <prez@gentoo.org> nut-1.2.2.ebuild :
New stable version
diff --git a/net-misc/nut/nut-1.2.2.ebuild b/net-misc/nut/nut-1.2.2.ebuild
index 81053a944815..66531dd40569 100644
--- a/net-misc/nut/nut-1.2.2.ebuild
+++ b/net-misc/nut/nut-1.2.2.ebuild
@@ -1,23 +1,28 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/nut-1.2.2.ebuild,v 1.1 2003/04/21 03:32:55 prez Exp $
-
-IUSE="png"
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/nut-1.2.2.ebuild,v 1.2 2003/04/28 14:51:08 prez Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Network-UPS Tools"
SRC_URI="http://www.exploits.org/nut/release/${PV%.*}/${P}.tar.gz"
HOMEPAGE="http://www.exploits.org/nut/"
-KEYWORDS="~x86 ~sparc"
+KEYWORDS="x86 sparc"
LICENSE="GPL-2"
SLOT="0"
-# -- [ FIXME ] --
-# a better idea would be to have virtual/httpd dependencies and
-# USE cgi-bin support. USE png and apache are used for now :\
+DEPEND=""
+RDEPEND=">=sys-apps/baselayout-1.8.2"
+
+APACHE="`which apache`"
+if [ -z "${APACHE}" -a -x /usr/sbin/apache ]; then
+ APACHE=/usr/sbin/apache
+fi
-DEPEND="png? ( =sys-libs/zlib-1* =media-libs/libgd-1* =media-libs/libpng-1.2* )"
-RDEPEND="${DEPEND} png? ( net-www/apache ) >=sys-apps/baselayout-1.8.2"
+if [ -n "${APACHE}" ]; then
+ DEPEND="${DEPEND} =sys-libs/zlib-1* =media-libs/libgd-1* =media-libs/libpng-1.2*"
+ RDEPEND="${RDEPEND} net-www/apache"
+fi
+RDEPEND="${RDEPEND} ${DEPEND}"
src_unpack() {
unpack ${A} || die
@@ -30,8 +35,8 @@ src_unpack() {
src_compile() {
local myconf
- use png && myconf="--with-cgi --with-cgipath=/home/httpd/cgi-bin"
- use png || myconf="--without-cgi"
+ [ -n "${APACHE}" ] && myconf="--with-cgi --with-cgipath=/home/httpd/cgi-bin"
+ [ -n "${APACHE}" ] || myconf="--without-cgi"
#default is to build all drivers; but the following is common:
#--with-drivers=apcsmart,hidups
@@ -59,7 +64,7 @@ src_compile() {
emake || die
- if [ -n "`use png`" ]
+ if [ -n "${APACHE}" ]
then
emake cgi || die
fi
@@ -71,7 +76,7 @@ src_install() {
# up in pkg_postinst().
make DESTDIR=${D} RUNUID=root RUNGID=root install || die
- if [ -n "`use png`" ]
+ if [ -n "${APACHE}" ]
then
make DESTDIR=${D} install-cgi || die
fi