summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-06-04 12:26:44 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-06-04 12:26:44 +0000
commitef911eef7672a0129336d30acdd87912cdf115d5 (patch)
tree6c4b860a940568fb6445b119e7a91fe224208315 /net-misc/netkit-bootpd/netkit-bootpd-2.4.ebuild
parentMark stable (diff)
downloadhistorical-ef911eef7672a0129336d30acdd87912cdf115d5.tar.gz
historical-ef911eef7672a0129336d30acdd87912cdf115d5.tar.bz2
historical-ef911eef7672a0129336d30acdd87912cdf115d5.zip
version bump as per bug #124510 thanks to Gonzalo Aguilar Delgado
Package-Manager: portage-2.1_rc4
Diffstat (limited to 'net-misc/netkit-bootpd/netkit-bootpd-2.4.ebuild')
-rw-r--r--net-misc/netkit-bootpd/netkit-bootpd-2.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/netkit-bootpd/netkit-bootpd-2.4.ebuild b/net-misc/netkit-bootpd/netkit-bootpd-2.4.ebuild
new file mode 100644
index 000000000000..41577f25c2db
--- /dev/null
+++ b/net-misc/netkit-bootpd/netkit-bootpd-2.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-bootpd/netkit-bootpd-2.4.ebuild,v 1.1 2006/06/04 12:26:44 dragonheart Exp $
+
+inherit eutils
+
+
+MY_P=${P/netkit-/}
+DESCRIPTION="Netkit - bootp"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netboot/"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netboot/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-misc.patch
+}
+
+src_compile() {
+ emake linux || die "Error compilando"
+}
+
+src_install() {
+ into /usr
+ dosbin bootpd bootpef bootpgw bootptest
+ dosym dosbin /usr/sbin/in.dosbin
+ dosym bootpd /usr/sbin/in.bootpd
+ dosym bootpef /usr/sbin/in.bootpef
+ dosym bootpgw /usr/sbin/in.bootpgw
+ dosym bootptest /usr/sbin/in.bootptest
+ doman bootpd.8
+ doman bootpef.8
+ doman bootptest.8
+ dodoc README README-linux
+# newdoc rpc.bootparamd/README README.bootparamd
+}