summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2003-09-27 20:54:57 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2003-09-27 20:54:57 +0000
commit0c553995b902458c60579c562dc3c9169f7d345d (patch)
tree07cf44287733ae69db2f48463132364ab90dacf0 /net-misc/neon/neon-0.24.2.ebuild
parentVersion bump for subversion's sake (diff)
downloadhistorical-0c553995b902458c60579c562dc3c9169f7d345d.tar.gz
historical-0c553995b902458c60579c562dc3c9169f7d345d.tar.bz2
historical-0c553995b902458c60579c562dc3c9169f7d345d.zip
Version bump for subversion's sake
Diffstat (limited to 'net-misc/neon/neon-0.24.2.ebuild')
-rw-r--r--net-misc/neon/neon-0.24.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/neon/neon-0.24.2.ebuild b/net-misc/neon/neon-0.24.2.ebuild
new file mode 100644
index 000000000000..64d7aed3a59b
--- /dev/null
+++ b/net-misc/neon/neon-0.24.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.24.2.ebuild,v 1.1 2003/09/27 20:54:52 pauldv Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="HTTP and WebDAV client library"
+SRC_URI="http://www.webdav.org/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.webdav.org/neon"
+DEPEND="dev-libs/libxml2
+ ssl? ( >=dev-libs/openssl-0.9.6f )"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="ssl"
+
+src_compile() {
+ local myc='--enable-shared'
+
+ use ssl && myc="$myc --with-ssl"
+ use zlib && myc="$myc --with-zlib" || myc="$myc --without-zlib"
+
+ econf $myc
+ emake
+}
+
+src_install () {
+ einstall
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*
+}