summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-28 17:49:46 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-28 17:49:46 +0000
commit5091f462bcd189df8eff648a0bd62cbf92257db7 (patch)
tree1c54f1783639c62c355ff1bed55a4739167a236d /net-misc/jwhois
parentversion bump to 1.2.1_pre1 due to security flaw in neon (diff)
downloadhistorical-5091f462bcd189df8eff648a0bd62cbf92257db7.tar.gz
historical-5091f462bcd189df8eff648a0bd62cbf92257db7.tar.bz2
historical-5091f462bcd189df8eff648a0bd62cbf92257db7.zip
arm KEYWORDS
Diffstat (limited to 'net-misc/jwhois')
-rw-r--r--net-misc/jwhois/jwhois-3.2.2.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/net-misc/jwhois/jwhois-3.2.2.ebuild b/net-misc/jwhois/jwhois-3.2.2.ebuild
index b5edf2c6d23e..bc82ed51e602 100644
--- a/net-misc/jwhois/jwhois-3.2.2.ebuild
+++ b/net-misc/jwhois/jwhois-3.2.2.ebuild
@@ -1,29 +1,25 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/jwhois/jwhois-3.2.2.ebuild,v 1.6 2004/04/26 12:34:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jwhois/jwhois-3.2.2.ebuild,v 1.7 2004/05/28 17:49:46 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Advanced Internet Whois client capable of recursive queries"
HOMEPAGE="http://www.gnu.org/software/jwhois/"
-LICENSE="GPL-2"
-IUSE="nls"
-KEYWORDS="~x86 ~mips ~sparc amd64 alpha ia64"
SRC_URI="mirror://gentoo/${P}.tar.gz
ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 ~sparc ~mips alpha amd64 ia64"
+IUSE="nls"
DEPEND="virtual/glibc"
src_compile() {
- local myconf
-
- use nls \
- && myconf="--enable-nls" \
- || myconf="--disable-nls"
-
- myconf="${myconf} --sysconfdir=/etc --localstatedir=/var/cache/ --without-cache"
-
- econf $myconf || die "econf failed"
+ econf \
+ --localstatedir=/var/cache \
+ --without-cache \
+ `use_enable nls` \
+ || die "econf failed"
emake || die
}