summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-01-12 22:47:13 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-01-12 22:47:13 +0000
commitfa03e3a414b1da246658df3de6836d75dcdcfea6 (patch)
treefcfdb3a6c2b76882dd7c000994a3586fd6182064 /net-misc/icecast
parentNew version of slrn, removed old version (diff)
downloadhistorical-fa03e3a414b1da246658df3de6836d75dcdcfea6.tar.gz
historical-fa03e3a414b1da246658df3de6836d75dcdcfea6.tar.bz2
historical-fa03e3a414b1da246658df3de6836d75dcdcfea6.zip
icecast, initial ebuild
Diffstat (limited to 'net-misc/icecast')
-rw-r--r--net-misc/icecast/files/digest-icecast-1.3.111
-rw-r--r--net-misc/icecast/icecast-1.3.11.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/icecast/files/digest-icecast-1.3.11 b/net-misc/icecast/files/digest-icecast-1.3.11
new file mode 100644
index 000000000000..4844485523ec
--- /dev/null
+++ b/net-misc/icecast/files/digest-icecast-1.3.11
@@ -0,0 +1 @@
+MD5 20d3b21829bc450c19607ee39ccb0e6c icecast-1.3.11.tar.gz 270336
diff --git a/net-misc/icecast/icecast-1.3.11.ebuild b/net-misc/icecast/icecast-1.3.11.ebuild
new file mode 100644
index 000000000000..3aec85836c8a
--- /dev/null
+++ b/net-misc/icecast/icecast-1.3.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Chris Arndt <arndtc@mailandnews.com>
+# $Header $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Icecast is an Internet based broadcasting system based on the Mpeg Layer III streaming technology."
+SRC_URI="http://www.icecast.org/releases/${P}.tar.gz"
+HOMEPAGE="http://www.icecast.org"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ ./configure --with-libwrap \
+ --with-crypt \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --host=${CHOST} || die
+
+ emake || die
+}
+
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS CHANGES COPYING FAQ INSTALL README TESTED TODO
+
+}