summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-28 07:54:27 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-28 07:54:27 +0000
commitf72f53e6d018362b310439c6efa418912758fe0b (patch)
treee901665bbc7eaa5f2e363b7726a095e5d6343507 /net-misc/dhcpv6/dhcpv6-0.10_pre20060828.ebuild
parentUnmask rhide now that the problems are fixed (diff)
downloadhistorical-f72f53e6d018362b310439c6efa418912758fe0b.tar.gz
historical-f72f53e6d018362b310439c6efa418912758fe0b.tar.bz2
historical-f72f53e6d018362b310439c6efa418912758fe0b.zip
Version bump #64839 by Peter Tiggerdine.
Package-Manager: portage-2.1.1_rc1
Diffstat (limited to 'net-misc/dhcpv6/dhcpv6-0.10_pre20060828.ebuild')
-rw-r--r--net-misc/dhcpv6/dhcpv6-0.10_pre20060828.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/dhcpv6/dhcpv6-0.10_pre20060828.ebuild b/net-misc/dhcpv6/dhcpv6-0.10_pre20060828.ebuild
new file mode 100644
index 000000000000..a4a3b7a853eb
--- /dev/null
+++ b/net-misc/dhcpv6/dhcpv6-0.10_pre20060828.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpv6/dhcpv6-0.10_pre20060828.ebuild,v 1.1 2006/08/28 07:54:27 vapier Exp $
+
+inherit flag-o-matic
+
+MY_P="dhcp-${PV/_pre*}"
+SNAP=${PV/*_pre}
+DESCRIPTION="Server and client for DHCPv6"
+HOMEPAGE="http://sourceforge.net/projects/dhcpv6/"
+SRC_URI="mirror://sourceforge/dhcpv6/${MY_P}.tgz
+ mirror://gentoo/${PN}-cvs${SNAP}.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="static"
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${PN}-cvs${SNAP}.patch
+}
+
+src_compile() {
+ econf || die
+ use static && append-ldflags -static
+ emake -j1 || die
+}
+
+src_install() {
+ einstall || die
+ dodoc Install ReadMe docs/*.txt *.conf
+ dodir /var/lib/dhcpv6
+ newinitd "${FILESDIR}"/dhcp6s.rc dhcp6s || die
+}