summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2014-03-23 01:35:52 +0000
committerWilliam Hubbs <williamh@gentoo.org>2014-03-23 01:35:52 +0000
commit89547dd80cfe0705cc21423c7519a00f1d6ed1e8 (patch)
tree17f108f2019170290e927aced694882860302313 /net-misc/dhcpcd/dhcpcd-9999.ebuild
parentVersion bump, remove older unstables (diff)
downloadhistorical-89547dd80cfe0705cc21423c7519a00f1d6ed1e8.tar.gz
historical-89547dd80cfe0705cc21423c7519a00f1d6ed1e8.tar.bz2
historical-89547dd80cfe0705cc21423c7519a00f1d6ed1e8.zip
convert live ebuild to use fossil for bug #505126, thanks to Mike Gilbert.
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x8568F528
Diffstat (limited to 'net-misc/dhcpcd/dhcpcd-9999.ebuild')
-rw-r--r--net-misc/dhcpcd/dhcpcd-9999.ebuild28
1 files changed, 25 insertions, 3 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-9999.ebuild b/net-misc/dhcpcd/dhcpcd-9999.ebuild
index bd6cb7335826..47a48dd2b0a9 100644
--- a/net-misc/dhcpcd/dhcpcd-9999.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-9999.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-9999.ebuild,v 1.12 2014/03/20 03:52:09 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-9999.ebuild,v 1.13 2014/03/23 01:35:50 williamh Exp $
EAPI=5
if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="git://roy.marples.name/${PN}.git"
- inherit git-r3
+ FOSSIL_URI="http://roy.marples.name/projects/dhcpcd"
else
MY_P="${P/_alpha/-alpha}"
MY_P="${MY_P/_beta/-beta}"
@@ -28,6 +27,29 @@ COMMON_DEPEND="udev? ( virtual/udev )"
DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"
+if [[ ${PV} == "9999" ]]; then
+ DEPEND+=" dev-vcs/fossil"
+
+ src_unpack()
+ {
+ local distdir=${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}
+ local repo=${distdir}/fossil/${PN}.fossil
+
+ addwrite "${distdir}"
+
+ if [[ -e "${repo}" ]]; then
+ fossil pull "${FOSSIL_URI}" -R "${repo}" || die
+ else
+ mkdir -p "${distdir}/fossil" || die
+ fossil clone "${FOSSIL_URI}" "${repo}" || die
+ fi
+
+ mkdir -p "${S}" || die
+ cd "${S}" || die
+ fossil open "${repo}" || die
+ }
+fi
+
src_prepare()
{
epatch_user