summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-09-09 09:09:08 +0000
committerDonny Davies <woodchip@gentoo.org>2001-09-09 09:09:08 +0000
commit1b839b176a0fcc404b986934b0ce731a130d8de2 (patch)
tree8cd17b843a7d887fcc757d7beed36f78a8a78e71 /net-misc/dhcp
parentdhcp rc5/rc6 support (diff)
downloadhistorical-1b839b176a0fcc404b986934b0ce731a130d8de2.tar.gz
historical-1b839b176a0fcc404b986934b0ce731a130d8de2.tar.bz2
historical-1b839b176a0fcc404b986934b0ce731a130d8de2.zip
updated to newest available version, which is 3.0_rc12 as of now. also made the package support rc5 and rc6 systems. :)
Diffstat (limited to 'net-misc/dhcp')
-rw-r--r--net-misc/dhcp/dhcp-3.0_rc12-r6.ebuild89
-rw-r--r--net-misc/dhcp/dhcp-3.0_rc12.ebuild89
-rw-r--r--[-rwxr-xr-x]net-misc/dhcp/files/dhcp.rc5 (renamed from net-misc/dhcp/files/dhcp)0
-rw-r--r--net-misc/dhcp/files/dhcp.rc626
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0_beta02241
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0_rc101
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0_rc10001
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0_rc121
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0_rc12-r61
9 files changed, 206 insertions, 3 deletions
diff --git a/net-misc/dhcp/dhcp-3.0_rc12-r6.ebuild b/net-misc/dhcp/dhcp-3.0_rc12-r6.ebuild
new file mode 100644
index 000000000000..145e45fb1615
--- /dev/null
+++ b/net-misc/dhcp/dhcp-3.0_rc12-r6.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0_rc12-r6.ebuild,v 1.1 2001/09/09 09:09:08 woodchip Exp $
+
+P=dhcp-3.0rc12
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="ISC Dynamic Host Configuration Protocol"
+SRC_URI="ftp://ftp.isc.org/isc/dhcp/${A}"
+HOMEPAGE="http://www.isc.org/products/DHCP"
+
+DEPEND="virtual/glibc sys-apps/groff"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}/includes
+ cat <<- END >> site.h
+ #define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
+ #define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
+ #define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
+ END
+}
+
+src_compile() {
+
+ cat <<- END > site.conf
+ CC = gcc ${CFLAGS}
+ ETC = /etc/dhcp
+ VARDB = /var/lib/dhcp
+ ADMMANDIR = /usr/share/man/man8
+ FFMANDIR = /usr/share/man/man5
+ LIBMANDIR = /usr/share/man/man3
+ END
+
+ ./configure --with-nsupdate || die
+ make || die
+}
+
+src_install2() {
+
+ # hmm is this misbehaving outside of the tempdir?
+ try make DESTDIR=${D} install
+}
+
+src_install() {
+
+ dodir /var/lib/dhcp
+
+ cd ${S}/work.linux-2.2/client
+ into / ; dosbin dhclient
+ into /usr ; doman *.5 *.8
+
+ cd ../dhcpctl ; dolib libdhcpctl.a ; doman *.3
+ insinto /usr/include ; doins dhcpctl.h
+
+ cd ../omapip ; dolib libomapi.a ; doman *.3
+ cd ../relay ; dosbin dhcrelay ; doman *.8
+ cd ../common ; doman *.5
+ cd ../server ; dosbin dhcpd ; doman *.5 *.8
+
+ cd ${S}/client
+ # admins might wanna edit dhclient-script, so /etc is proper for it.
+ dosed "s:/etc/dhclient-script:/etc/dhcp/dhclient-script:" dhclient.conf
+ insinto /etc/dhcp ; newins dhclient.conf dhclient.conf.sample
+ exeinto /etc/dhcp ; newexe scripts/linux dhclient-script.sample
+
+ cd ${S}/server
+ insinto /etc/dhcp ; newins dhcpd.conf dhcpd.conf.sample
+
+ cd ${S}/includes/omapip
+ insinto /usr/include/omapip ; doins alloc.h buffer.h omapip.h
+
+ cd ${S}/includes/isc-dhcp
+ insinto /usr/include/isc-dhcp
+ doins boolean.h dst.h int.h lang.h list.h result.h types.h
+
+ cd ${S}
+ dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES
+ newdoc client/dhclient.conf dhclient.conf.sample
+ newdoc client/scripts/linux dhclient-script.sample
+ newdoc server/dhcpd.conf dhcpd.conf.sample
+ docinto doc ; dodoc doc/*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dhcp.rc6 dhcp
+}
diff --git a/net-misc/dhcp/dhcp-3.0_rc12.ebuild b/net-misc/dhcp/dhcp-3.0_rc12.ebuild
new file mode 100644
index 000000000000..0d23a5b9f4d7
--- /dev/null
+++ b/net-misc/dhcp/dhcp-3.0_rc12.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0_rc12.ebuild,v 1.1 2001/09/09 09:09:08 woodchip Exp $
+
+P=dhcp-3.0rc12
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="ISC Dynamic Host Configuration Protocol"
+SRC_URI="ftp://ftp.isc.org/isc/dhcp/${A}"
+HOMEPAGE="http://www.isc.org/products/DHCP"
+
+DEPEND="virtual/glibc sys-apps/groff"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}/includes
+ cat <<- END >> site.h
+ #define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
+ #define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
+ #define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
+ END
+}
+
+src_compile() {
+
+ cat <<- END > site.conf
+ CC = gcc ${CFLAGS}
+ ETC = /etc/dhcp
+ VARDB = /var/lib/dhcp
+ ADMMANDIR = /usr/share/man/man8
+ FFMANDIR = /usr/share/man/man5
+ LIBMANDIR = /usr/share/man/man3
+ END
+
+ ./configure --with-nsupdate || die
+ make || die
+}
+
+src_install2() {
+
+ # hmm is this misbehaving outside of the tempdir?
+ try make DESTDIR=${D} install
+}
+
+src_install() {
+
+ dodir /var/lib/dhcp
+
+ cd ${S}/work.linux-2.2/client
+ into / ; dosbin dhclient
+ into /usr ; doman *.5 *.8
+
+ cd ../dhcpctl ; dolib libdhcpctl.a ; doman *.3
+ insinto /usr/include ; doins dhcpctl.h
+
+ cd ../omapip ; dolib libomapi.a ; doman *.3
+ cd ../relay ; dosbin dhcrelay ; doman *.8
+ cd ../common ; doman *.5
+ cd ../server ; dosbin dhcpd ; doman *.5 *.8
+
+ cd ${S}/client
+ # admins might wanna edit dhclient-script, so /etc is proper for it.
+ dosed "s:/etc/dhclient-script:/etc/dhcp/dhclient-script:" dhclient.conf
+ insinto /etc/dhcp ; newins dhclient.conf dhclient.conf.sample
+ exeinto /etc/dhcp ; newexe scripts/linux dhclient-script.sample
+
+ cd ${S}/server
+ insinto /etc/dhcp ; newins dhcpd.conf dhcpd.conf.sample
+
+ cd ${S}/includes/omapip
+ insinto /usr/include/omapip ; doins alloc.h buffer.h omapip.h
+
+ cd ${S}/includes/isc-dhcp
+ insinto /usr/include/isc-dhcp
+ doins boolean.h dst.h int.h lang.h list.h result.h types.h
+
+ cd ${S}
+ dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES
+ newdoc client/dhclient.conf dhclient.conf.sample
+ newdoc client/scripts/linux dhclient-script.sample
+ newdoc server/dhcpd.conf dhcpd.conf.sample
+ docinto doc ; dodoc doc/*
+
+ exeinto /etc/rc.d/init.d
+ newexe ${FILESDIR}/dhcp.rc5 dhcp
+}
diff --git a/net-misc/dhcp/files/dhcp b/net-misc/dhcp/files/dhcp.rc5
index b23298be6cb2..b23298be6cb2 100755..100644
--- a/net-misc/dhcp/files/dhcp
+++ b/net-misc/dhcp/files/dhcp.rc5
diff --git a/net-misc/dhcp/files/dhcp.rc6 b/net-misc/dhcp/files/dhcp.rc6
new file mode 100644
index 000000000000..6ca4fc057f3a
--- /dev/null
+++ b/net-misc/dhcp/files/dhcp.rc6
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /etc/dhcp/dhcpd.conf ] ; then
+ eerror "You need an /etc/dhcp/dhcpd.conf file to run dhcpd"
+ eerror "There is a sample conf file in /usr/share/doc/dhcp"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting dhcpd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/dhcpd -- eth0
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping dhcpd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/dhcpd
+ eend $?
+}
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0_beta0224 b/net-misc/dhcp/files/digest-dhcp-3.0_beta0224
deleted file mode 100644
index 0933c3a6c4b2..000000000000
--- a/net-misc/dhcp/files/digest-dhcp-3.0_beta0224
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ea48b791cb2be15c6d3458f5f55de8ca dhcp-3.0b2pl24.tar.gz
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0_rc10 b/net-misc/dhcp/files/digest-dhcp-3.0_rc10
deleted file mode 100644
index f6c0f566ff30..000000000000
--- a/net-misc/dhcp/files/digest-dhcp-3.0_rc10
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a5b043e0cb80d3ccadc54f07cb95dd5f dhcp-3.0rc10.tar.gz
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0_rc1000 b/net-misc/dhcp/files/digest-dhcp-3.0_rc1000
deleted file mode 100644
index f6c0f566ff30..000000000000
--- a/net-misc/dhcp/files/digest-dhcp-3.0_rc1000
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a5b043e0cb80d3ccadc54f07cb95dd5f dhcp-3.0rc10.tar.gz
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0_rc12 b/net-misc/dhcp/files/digest-dhcp-3.0_rc12
new file mode 100644
index 000000000000..b92bbe627cdc
--- /dev/null
+++ b/net-misc/dhcp/files/digest-dhcp-3.0_rc12
@@ -0,0 +1 @@
+MD5 7aa34ef3cd4a24f0c6857283d5261003 dhcp-3.0rc12.tar.gz
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0_rc12-r6 b/net-misc/dhcp/files/digest-dhcp-3.0_rc12-r6
new file mode 100644
index 000000000000..b92bbe627cdc
--- /dev/null
+++ b/net-misc/dhcp/files/digest-dhcp-3.0_rc12-r6
@@ -0,0 +1 @@
+MD5 7aa34ef3cd4a24f0c6857283d5261003 dhcp-3.0rc12.tar.gz