summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-04-06 07:28:16 +0000
committerJon Nelson <jnelson@gentoo.org>2002-04-06 07:28:16 +0000
commit7c43486e20e5ac493845f3fdf639d85722f4ddb9 (patch)
tree13d9767aeff117579ca19f9a56d4bdbbc1102f80 /net-misc/bk2site/bk2site-1.1.8-r1.ebuild
parentfix boot partition stuff (diff)
downloadhistorical-7c43486e20e5ac493845f3fdf639d85722f4ddb9.tar.gz
historical-7c43486e20e5ac493845f3fdf639d85722f4ddb9.tar.bz2
historical-7c43486e20e5ac493845f3fdf639d85722f4ddb9.zip
add -r1 which patches Makefile.in and Makefile.am to accept CXXFLAGS
Diffstat (limited to 'net-misc/bk2site/bk2site-1.1.8-r1.ebuild')
-rw-r--r--net-misc/bk2site/bk2site-1.1.8-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/bk2site/bk2site-1.1.8-r1.ebuild b/net-misc/bk2site/bk2site-1.1.8-r1.ebuild
new file mode 100644
index 000000000000..a757c09fa968
--- /dev/null
+++ b/net-misc/bk2site/bk2site-1.1.8-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Jon Nelson <jnelson@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bk2site/bk2site-1.1.8-r1.ebuild,v 1.1 2002/04/06 07:28:16 jnelson Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="bk2site will transform your Netscape bookmarks file into a yahoo-like website with slashdot-like news."
+SRC_URI="http://prdownloads.sourceforge.net/bk2site/${P}.tar.gz"
+HOMEPAGE="http://bk2site.sourceforge.net/"
+
+DEPEND=""
+#RDEPEND=""
+
+
+src_unpack() {
+ unpack $A
+ # Apply any patches available for this version
+ local patches=`echo ${FILESDIR}/${PV}.[0-9][0-9][0-9]`
+ case "$patches" in
+ *\])
+ ;; # globbing didn't work; no patches available
+ *)
+ cd $S
+ for a in $patches; do
+ patch -p0 < $a
+ done
+ ;;
+ esac
+ patch -f -p0 < ${FILESDIR}/ebuild.patch
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+ #make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ insinto /etc/bk2site
+ doins indexbase.html newbase.html otherbase.html searchbase.html
+ dodoc bk2site.html *.gif
+ dodoc README COPYING AUTHORS ChangeLog INSTALL NEWS TODO
+ exeinto /home/httpd/cgi-bin/bk2site
+ doexe *.pl
+}