summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-07-01 21:09:20 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-07-01 21:09:20 +0000
commit1f9ab2a66a41bac4648f6d648802418f849eb173 (patch)
tree95bcf17ba82979d2944832f62b5f7b6ed55800c6 /net-misc/asterisk-cdr_shell
parentFix more KEYWORDS-issues. (diff)
downloadhistorical-1f9ab2a66a41bac4648f6d648802418f849eb173.tar.gz
historical-1f9ab2a66a41bac4648f6d648802418f849eb173.tar.bz2
historical-1f9ab2a66a41bac4648f6d648802418f849eb173.zip
New ebuild
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'net-misc/asterisk-cdr_shell')
-rw-r--r--net-misc/asterisk-cdr_shell/ChangeLog11
-rw-r--r--net-misc/asterisk-cdr_shell/Manifest4
-rw-r--r--net-misc/asterisk-cdr_shell/asterisk-cdr_shell-20050626.ebuild45
-rw-r--r--net-misc/asterisk-cdr_shell/files/cdr.conf6
-rw-r--r--net-misc/asterisk-cdr_shell/files/cdr_shell-20050626-astcfg.diff31
-rw-r--r--net-misc/asterisk-cdr_shell/files/cdr_shell-20050626-stable.diff29
-rw-r--r--net-misc/asterisk-cdr_shell/files/digest-asterisk-cdr_shell-200506261
-rw-r--r--net-misc/asterisk-cdr_shell/metadata.xml8
8 files changed, 135 insertions, 0 deletions
diff --git a/net-misc/asterisk-cdr_shell/ChangeLog b/net-misc/asterisk-cdr_shell/ChangeLog
new file mode 100644
index 000000000000..fca3eb4886b0
--- /dev/null
+++ b/net-misc/asterisk-cdr_shell/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/asterisk-cdr_shell
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-cdr_shell/ChangeLog,v 1.1 2005/07/01 21:09:20 stkn Exp $
+
+*asterisk-cdr_shell-20050626 (01 Jul 2005)
+
+ 01 Jul 2005; Stefan Knoblich <stkn@gentoo.org> +metadata.xml,
+ +files/cdr.conf, +files/cdr_shell-20050626-astcfg.diff,
+ +files/cdr_shell-20050626-stable.diff, +asterisk-cdr_shell-20050626.ebuild:
+ Initial import.
+
diff --git a/net-misc/asterisk-cdr_shell/Manifest b/net-misc/asterisk-cdr_shell/Manifest
new file mode 100644
index 000000000000..f59b55da6150
--- /dev/null
+++ b/net-misc/asterisk-cdr_shell/Manifest
@@ -0,0 +1,4 @@
+MD5 42598ddb2a55fddd4adfd452e25585d7 asterisk-cdr_shell-20050626.ebuild 708
+MD5 a259df19a6815f1d560ef5128719df41 files/cdr_shell-20050626-stable.diff 746
+MD5 c7f98ec712b829b32b590ea718a8ea8d files/digest-asterisk-cdr_shell-20050626 78
+MD5 45326ecd0899ea3dfdabea2a556934d8 files/cdr_shell-20050626-astcfg.diff 697
diff --git a/net-misc/asterisk-cdr_shell/asterisk-cdr_shell-20050626.ebuild b/net-misc/asterisk-cdr_shell/asterisk-cdr_shell-20050626.ebuild
new file mode 100644
index 000000000000..21f447cb2549
--- /dev/null
+++ b/net-misc/asterisk-cdr_shell/asterisk-cdr_shell-20050626.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-cdr_shell/asterisk-cdr_shell-20050626.ebuild,v 1.1 2005/07/01 21:09:20 stkn Exp $
+
+inherit eutils
+
+MY_PN="cdr_shell"
+
+DESCRIPTION="Asterisk plugin to use an external shell script for cdr handling"
+HOMEPAGE="http://www.pbxfreeware.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=net-misc/asterisk-1.0.7-r1"
+
+S=${WORKDIR}/${MY_PN}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # use asterisk-config...
+ epatch ${FILESDIR}/${MY_PN}-${PV}-astcfg.diff
+
+ # patch for asterisk stable
+ epatch ${FILESDIR}/${MY_PN}-${PV}-stable.diff
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ insinto /etc/asterisk
+ doins ${FILESDIR}/cdr.conf
+
+ # fix permissions
+ chown -R root:asterisk ${D}etc/asterisk
+ chmod -R u=rwX,g=rX,o= ${D}etc/asterisk
+}
diff --git a/net-misc/asterisk-cdr_shell/files/cdr.conf b/net-misc/asterisk-cdr_shell/files/cdr.conf
new file mode 100644
index 000000000000..1f9252bf6723
--- /dev/null
+++ b/net-misc/asterisk-cdr_shell/files/cdr.conf
@@ -0,0 +1,6 @@
+[cdr_shell]
+;example configuration entry
+;cdr data is passed in $1..$18
+;multiple path entries are supported
+
+;path => /usr/local/bin/asterisk_cdr.sh
diff --git a/net-misc/asterisk-cdr_shell/files/cdr_shell-20050626-astcfg.diff b/net-misc/asterisk-cdr_shell/files/cdr_shell-20050626-astcfg.diff
new file mode 100644
index 000000000000..d99e3818c7da
--- /dev/null
+++ b/net-misc/asterisk-cdr_shell/files/cdr_shell-20050626-astcfg.diff
@@ -0,0 +1,31 @@
+--- Makefile.orig 1970-01-01 00:00:00.000000000 +0000
++++ Makefile 2005-01-26 20:30:27.009331696 +0000
+@@ -0,0 +1,28 @@
++
++CC?=gcc
++ASTCONFIG?=/usr/bin/asterisk-config
++
++CFLAGS=$(shell $(ASTCONFIG) --cflags) -fPIC -DPIC
++SOLINK=$(shell $(ASTCONFIG) --solink)
++LIBS=
++
++ASTMODDIR=$(shell $(ASTCONFIG) --modulesdir)
++
++all: .depend cdr_shell.so
++
++.depend:
++ @if [ ! -x $(ASTCONFIG) ]; then \
++ echo "$(ASTCONFIG) not found!"; \
++ exit 255; \
++ fi
++
++.c.o:
++ $(CC) -c $(CFLAGS) -o $@ $<
++
++cdr_shell.so: cdr_shell.o
++ $(CC) $(SOLINK) -o $@ $< $(LIBS)
++
++install:
++ if [ ! -d $(DESTDIR)$(ASTMODDIR) ]; then mkdir -p $(DESTDIR)$(ASTMODDIR); fi
++ install -m755 cdr_shell.so $(DESTDIR)$(ASTMODDIR)
++
diff --git a/net-misc/asterisk-cdr_shell/files/cdr_shell-20050626-stable.diff b/net-misc/asterisk-cdr_shell/files/cdr_shell-20050626-stable.diff
new file mode 100644
index 000000000000..11d23398ecd3
--- /dev/null
+++ b/net-misc/asterisk-cdr_shell/files/cdr_shell-20050626-stable.diff
@@ -0,0 +1,29 @@
+--- cdr_shell/cdr_shell.c 2005-06-26 17:01:46.000000000 +0200
++++ cdr_shell.c.new 2005-07-01 01:21:12.000000000 +0200
+@@ -20,7 +20,7 @@
+ #include <asterisk/logger.h>
+ #include <asterisk/cli.h>
+ #include <asterisk/config.h>
+-#include <asterisk.h>
++#include <asterisk/astconf.h>
+
+
+ #include <stdio.h>
+@@ -175,7 +175,7 @@
+ struct ast_config *cfg;
+ struct ast_variable *var;
+
+- if ((cfg = ast_config_load("cdr.conf"))) {
++ if ((cfg = ast_load("cdr.conf"))) {
+ for (var = ast_variable_browse(cfg, "cdr_shell"); var; var = var->next) {
+ if (!strcasecmp(var->name, "path")) {
+ if (is_executable(var->value)) {
+@@ -189,7 +189,7 @@
+ }
+ active = x;
+ }
+- ast_config_destroy(cfg);
++ ast_destroy(cfg);
+ }
+
+ if (!active) {
diff --git a/net-misc/asterisk-cdr_shell/files/digest-asterisk-cdr_shell-20050626 b/net-misc/asterisk-cdr_shell/files/digest-asterisk-cdr_shell-20050626
new file mode 100644
index 000000000000..39c48e71ac38
--- /dev/null
+++ b/net-misc/asterisk-cdr_shell/files/digest-asterisk-cdr_shell-20050626
@@ -0,0 +1 @@
+MD5 98a327d774b60f49b7c823279206dcc1 asterisk-cdr_shell-20050626.tar.bz2 2505
diff --git a/net-misc/asterisk-cdr_shell/metadata.xml b/net-misc/asterisk-cdr_shell/metadata.xml
new file mode 100644
index 000000000000..a3cddc42f9cc
--- /dev/null
+++ b/net-misc/asterisk-cdr_shell/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>voip</herd>
+<maintainer>
+ <email>stkn@gentoo.org</email>
+</maintainer>
+</pkgmetadata>