summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-09-05 13:35:16 +0000
committerJim Ramsay <lack@gentoo.org>2008-09-05 13:35:16 +0000
commitad8f59af522286ebff43a385df9ece05f59e0443 (patch)
treeae5a6c51acc94c21815a372430a438dc00a24870 /net-misc/amazonmp3
parentIUSE (diff)
downloadhistorical-ad8f59af522286ebff43a385df9ece05f59e0443.tar.gz
historical-ad8f59af522286ebff43a385df9ece05f59e0443.tar.bz2
historical-ad8f59af522286ebff43a385df9ece05f59e0443.zip
New package - AmazonMp3 downloader utility
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.23-gentoo-r5 i686
Diffstat (limited to 'net-misc/amazonmp3')
-rw-r--r--net-misc/amazonmp3/ChangeLog10
-rw-r--r--net-misc/amazonmp3/Manifest4
-rw-r--r--net-misc/amazonmp3/amazonmp3-1.0.3.ebuild76
-rw-r--r--net-misc/amazonmp3/metadata.xml9
4 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/amazonmp3/ChangeLog b/net-misc/amazonmp3/ChangeLog
new file mode 100644
index 000000000000..45d19186c13c
--- /dev/null
+++ b/net-misc/amazonmp3/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/amazonmp3
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/amazonmp3/ChangeLog,v 1.1 2008/09/05 13:35:16 lack Exp $
+
+*amazonmp3-1.0.3 (03 Sep 2008)
+
+ 03 Sep 2008; Jim Ramsay <lack@gentoo.org> +metadata.xml,
+ +amazonmp3-1.0.3.ebuild:
+ New package - AmazonMp3 downloader utility
+
diff --git a/net-misc/amazonmp3/Manifest b/net-misc/amazonmp3/Manifest
new file mode 100644
index 000000000000..ad617d94957f
--- /dev/null
+++ b/net-misc/amazonmp3/Manifest
@@ -0,0 +1,4 @@
+DIST amazonmp3.rpm 263118 RMD160 bbab77a662be7ff45ba1126c83955c4e087e61c4 SHA1 8ad87e8f9c391b72e23fcc0bcd5409124a05dbcc SHA256 d71b07646d6063cae35198eb77af481c159c87e6f38bceed204f9919676788c9
+EBUILD amazonmp3-1.0.3.ebuild 2293 RMD160 d3e107c781937690bb685b1e2a3728f6927ec918 SHA1 2ae6b1493e60f32f2866f890524c8cdef21db12c SHA256 bfc6d8e4906a8487882f796832a55d28f2e44ce4388f756951eff7342091d717
+MISC ChangeLog 371 RMD160 170902afa0c1862cc1941b76323d5efb86ef61fe SHA1 49071aa6a25976037df601a5fbc0d045a40ae1b5 SHA256 fc39fccab2e0d42af19213b6c7a7104821e031f1205e8cfb7e4e4fd574c7115c
+MISC metadata.xml 254 RMD160 1f5a6322e4956b30592a1e0caf7edc67613ecc43 SHA1 f0813ac26740fae9e0f0899b5dad74b5a6fd5b3c SHA256 740784d71bef88214e4d8508e351a376d8908f4c4b6175d98b6b77e107799f12
diff --git a/net-misc/amazonmp3/amazonmp3-1.0.3.ebuild b/net-misc/amazonmp3/amazonmp3-1.0.3.ebuild
new file mode 100644
index 000000000000..17be41a4442f
--- /dev/null
+++ b/net-misc/amazonmp3/amazonmp3-1.0.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/amazonmp3/amazonmp3-1.0.3.ebuild,v 1.1 2008/09/05 13:35:16 lack Exp $
+
+EAPI="1"
+
+inherit rpm fdo-mime multilib
+
+DESCRIPTION="AmazonMp3 is a download manager which interfaces with the http://mp3.amazon.com music store"
+HOMEPAGE="http://www.amazon.com/gp/dmusic/help/amd.html/"
+SRC_URI="amazonmp3.rpm"
+RESTRICT="fetch"
+
+LICENSE="amazonmp3"
+SLOT="0"
+KEYWORDS="~x86 -*"
+IUSE=""
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ net-misc/curl
+ dev-libs/openssl
+ dev-libs/boost"
+DEPEND=""
+
+S="${WORKDIR}/usr/"
+
+pkg_nofetch() {
+ einfo "Due to licensing restrictions, you must download this software from"
+ einfo "amazon.com manually:"
+ einfo " - Visit ${HOMEPAGE}"
+ einfo " - Agree to the Terms of Service, click the agreement box, and"
+ einfo " download the version for 'Fedora 8'. It will be called"
+ einfo " 'amazonmp3.rpm'"
+ einfo " - Optionally, check that the version is correct. Run:"
+ einfo " file amazonmp3.rpm"
+ einfo " and ensure that it lists 'RPM v3 bin i386 amazonmp3-1.0.3-1'"
+ einfo " - Copy 'amazonmp3.rpm' into ${DISTDIR}"
+ einfo " - Run 'ebuild amazonmp3' again."
+ einfo "If the version does not match or if you get any errors about the"
+ einfo "rpm you just downloaded, file a bug at http://bugs.gentoo.org"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ # Their binary, compiled for Fedora 8, needs some odd library names, so we
+ # symlink them:
+ dosym libboost_date_time.so /usr/$(get_libdir)/libboost_date_time.so.3
+ dosym libboost_iostreams.so /usr/$(get_libdir)/libboost_iostreams.so.3
+ dosym libboost_signals.so /usr/$(get_libdir)/libboost_signals.so.3
+ dosym libboost_thread-mt.so /usr/$(get_libdir)/libboost_thread-mt.so.3
+ dosym libcrypto.so /usr/$(get_libdir)/libcrypto.so.6
+ dosym libssl.so /usr/$(get_libdir)/libssl.so.6
+
+ dobin bin/amazonmp3
+
+ for dir in applications pixmaps mime/packages mime-info mimelnk/audio; do
+ insinto "/usr/share/${dir}"
+ doins "share/${dir}/"*
+ done
+
+ dodoc share/doc/amazonmp3/releasenotes
+ dohtml share/doc/amazonmp3/*.html
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/net-misc/amazonmp3/metadata.xml b/net-misc/amazonmp3/metadata.xml
new file mode 100644
index 000000000000..24f1e9f83097
--- /dev/null
+++ b/net-misc/amazonmp3/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>lack@gentoo.org</email>
+ <name>Jim Ramsay</name>
+ </maintainer>
+</pkgmetadata>