summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-19 23:53:45 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-19 23:53:45 +0000
commitb19e4c31e80bcdfccc3050dc46eaca822f47742d (patch)
tree5b3621af70e04ae73eadd08bf55f745d7e1cb983 /net-mail
parentstable on x86 as per bug #123039 (diff)
downloadhistorical-b19e4c31e80bcdfccc3050dc46eaca822f47742d.tar.gz
historical-b19e4c31e80bcdfccc3050dc46eaca822f47742d.tar.bz2
historical-b19e4c31e80bcdfccc3050dc46eaca822f47742d.zip
s390/sh stable
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/checkpassword/checkpassword-0.90-r2.ebuild18
-rw-r--r--net-mail/queue-fix/queue-fix-1.4-r2.ebuild8
2 files changed, 12 insertions, 14 deletions
diff --git a/net-mail/checkpassword/checkpassword-0.90-r2.ebuild b/net-mail/checkpassword/checkpassword-0.90-r2.ebuild
index 47efa544261a..bab5a1ef35eb 100644
--- a/net-mail/checkpassword/checkpassword-0.90-r2.ebuild
+++ b/net-mail/checkpassword/checkpassword-0.90-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/checkpassword-0.90-r2.ebuild,v 1.1 2005/12/13 04:53:13 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/checkpassword-0.90-r2.ebuild,v 1.2 2006/02/19 23:53:45 vapier Exp $
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs flag-o-matic
DESCRIPTION="A uniform password checking interface for root applications"
HOMEPAGE="http://cr.yp.to/checkpwd.html"
@@ -10,18 +10,16 @@ SRC_URI="http://cr.yp.to/checkpwd/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k mips ppc ~s390 ~sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc s390 sh sparc x86"
IUSE="static"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-errno.patch
- epatch ${FILESDIR}/${PV}-head-1.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-errno.patch
+ epatch "${FILESDIR}"/${PV}-head-1.patch
- # the -s is from the original build
- LDFLAGS="${LDFLAGS} -s"
- use static && LDFLAGS="${LDFLAGS} -static"
+ use static && append-ldflags -static
echo "$(tc-getCC) ${CFLAGS}" > conf-cc
echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
}
diff --git a/net-mail/queue-fix/queue-fix-1.4-r2.ebuild b/net-mail/queue-fix/queue-fix-1.4-r2.ebuild
index c7bf8073a86b..0b6c1e095f01 100644
--- a/net-mail/queue-fix/queue-fix-1.4-r2.ebuild
+++ b/net-mail/queue-fix/queue-fix-1.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/queue-fix/queue-fix-1.4-r2.ebuild,v 1.15 2006/02/14 03:40:23 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/queue-fix/queue-fix-1.4-r2.ebuild,v 1.16 2006/02/19 23:51:14 vapier Exp $
inherit eutils toolchain-funcs fixheadtails
@@ -11,7 +11,7 @@ SRC_URI="http://www.netmeridian.com/e-huss/${P}.tar.gz
LICENSE="as-is"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k mips ppc ~s390 ~sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc s390 sh sparc x86"
IUSE=""
DEPEND="virtual/libc"
@@ -25,9 +25,9 @@ PDEPEND="
src_unpack() {
unpack ${P}.tar.gz
- epatch ${DISTDIR}/queue-fix-todo.patch
+ epatch "${DISTDIR}"/queue-fix-todo.patch
sed -i 's/^extern int errno;/#include <errno.h>/' ${S}/error.h
- ht_fix_file ${S}/Makefile*
+ ht_fix_file "${S}"/Makefile*
}
src_compile() {