summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-11-11 03:54:56 +0000
committerMax Kalika <max@gentoo.org>2003-11-11 03:54:56 +0000
commit66953577c032f7f120448f840007e9b9a1914f57 (patch)
treec53382b77acf3645cfa9015c47829a608be4e728 /net-mail
parentversion dependency fix0rs (diff)
downloadhistorical-66953577c032f7f120448f840007e9b9a1914f57.tar.gz
historical-66953577c032f7f120448f840007e9b9a1914f57.tar.bz2
historical-66953577c032f7f120448f840007e9b9a1914f57.zip
Put back keepdirs for the spool directories. Allows clean unmerge. This should be ready to go stable.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/postfix/ChangeLog5
-rw-r--r--net-mail/postfix/Manifest4
-rw-r--r--net-mail/postfix/postfix-2.0.16-r1.ebuild29
3 files changed, 21 insertions, 17 deletions
diff --git a/net-mail/postfix/ChangeLog b/net-mail/postfix/ChangeLog
index 91aef915114c..4237b594cc72 100644
--- a/net-mail/postfix/ChangeLog
+++ b/net-mail/postfix/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/postfix
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/ChangeLog,v 1.96 2003/11/10 18:48:35 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/ChangeLog,v 1.97 2003/11/11 03:54:55 max Exp $
+
+ 10 Nov 2003; <max@gentoo.org> postfix-2.0.16-r1.ebuild:
+ Put back keepdirs for the spool directories. Allows clean unmerge.
10 Nov 2003; <max@gentoo.org> postfix-2.0.16-r1.ebuild:
Properly fix spool permissions after merge, take 2.
diff --git a/net-mail/postfix/Manifest b/net-mail/postfix/Manifest
index 186f97352650..679a7b932305 100644
--- a/net-mail/postfix/Manifest
+++ b/net-mail/postfix/Manifest
@@ -2,11 +2,11 @@ MD5 7b7d8734e7bc6ee63b2a4091764a89f5 postfix-2.0.10-r1.ebuild 6165
MD5 c12766a3a53ca35ee6ce96df52d4c304 postfix-2.0.13-r1.ebuild 6350
MD5 f7902206b1ea1c3894f86f798f2eb0bd postfix-2.0.9.ebuild 6241
MD5 ef533edc3256c24f6ef2a04444b71404 postfix-1.1.11.20020917-r1.ebuild 4598
-MD5 fd5fc12cdb4a1572658640973cffa219 postfix-2.0.16-r1.ebuild 6522
+MD5 4b29aa1f5bc33e0fdeeae2ddc70fc18b postfix-2.0.16-r1.ebuild 6664
MD5 017fd96b86cea185de4708cf233f4e54 postfix-2.0.12-r1.ebuild 6032
MD5 b61085a605c41f64b6afb513fca4643c postfix-2.0.14.ebuild 6384
MD5 60523f236fe252023ae5860b6d39b5e8 postfix-2.0.15-r1.ebuild 6388
-MD5 2a1c6a254f9db4976836e689a50e2209 ChangeLog 19714
+MD5 1e99577e96140d6aaa8b8c8d4bc1f03b ChangeLog 19843
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 e111650f4a8f3c0405c9eb007cc74f31 postfix-2.0.11.ebuild 6036
MD5 3b74d1f1c47c8d5630d8f356adb2e28b postfix-1.1.11.20020917.ebuild 4578
diff --git a/net-mail/postfix/postfix-2.0.16-r1.ebuild b/net-mail/postfix/postfix-2.0.16-r1.ebuild
index e94582ca9a4a..668254bd00f9 100644
--- a/net-mail/postfix/postfix-2.0.16-r1.ebuild
+++ b/net-mail/postfix/postfix-2.0.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-2.0.16-r1.ebuild,v 1.8 2003/11/10 18:48:35 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-2.0.16-r1.ebuild,v 1.9 2003/11/11 03:54:55 max Exp $
inherit eutils ssl-cert
@@ -39,26 +39,26 @@ RDEPEND="${DEPEND}
pkg_setup() {
# Prevent mangling the smtpd.conf file
- if [ ! -L ${ROOT}/usr/lib/sasl2/smtpd.conf ] ; then
- if [ -f ${ROOT}/usr/lib/sasl2/smtpd.conf ] ; then
+ if [ ! -L "${ROOT}/usr/lib/sasl2/smtpd.conf" ] ; then
+ if [ -f "${ROOT}/usr/lib/sasl2/smtpd.conf" ] ; then
ebegin "Protecting your smtpd.conf file"
- if [ ! -d ${ROOT}/etc/sasl2 ] ; then
- mkdir -p ${ROOT}/etc/sasl2
+ if [ ! -d "${ROOT}/etc/sasl2" ] ; then
+ mkdir -p "${ROOT}/etc/sasl2"
fi
# This shouldn't be necessary, but apparently
# without it things can still get messy.
- if [ -L ${ROOT}/etc/sasl2/smtpd.conf ] ; then
- rm ${ROOT}/etc/sasl2/smtpd.conf
+ if [ -L "${ROOT}/etc/sasl2/smtpd.conf" ] ; then
+ rm "${ROOT}/etc/sasl2/smtpd.conf"
fi
# If both files exist, make sure that we preserve
# a copy of each with the ._cfg system
- if [ -f ${ROOT}/etc/sasl2/smtpd.conf ] ; then
- mv ${ROOT}/etc/sasl2/smtpd.conf \
- ${ROOT}/etc/sasl2/._cfg0000_smtpd.conf
+ if [ -f "${ROOT}/etc/sasl2/smtpd.conf" ] ; then
+ mv "${ROOT}/etc/sasl2/smtpd.conf" \
+ "${ROOT}/etc/sasl2/._cfg0000_smtpd.conf"
fi
- mv ${ROOT}/usr/lib/sasl2/smtpd.conf ${ROOT}/etc/sasl2
+ mv "${ROOT}/usr/lib/sasl2/smtpd.conf" "${ROOT}/etc/sasl2"
eend
fi
fi
@@ -144,10 +144,10 @@ src_install () {
mail_owner="postfix" \
setgid_group="postdrop" || die "postfix-install failed"
- # Install an rmail for UUCP, closing bug #19127
+ # Install an rmail for UUCP, closing bug #19127.
dobin auxiliary/rmail/rmail
- # Set proper permissions on required files/directories
+ # Set proper permissions on required files/directories.
fowners root:postdrop /usr/sbin/post{drop,queue}
fperms 02711 /usr/sbin/post{drop,queue}
@@ -192,7 +192,8 @@ src_install () {
dosym /etc/sasl2/smtpd.conf /usr/lib/sasl2/smtpd.conf
fi
- keepdir /var/spool/postfix
+ keepdir /var/spool/postfix/{active,bounce,corrupt,defer,deferred,flush}
+ keepdir /var/spool/postfix/{hold,incomming,maildrop,pid,private,public}
}
pkg_postinst() {