summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-13 10:53:01 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-13 10:53:01 +0000
commit51a880ca4563962530e848dc07977d53878aa3f6 (patch)
tree386b0ef4b71798a81597755a9f3cbbbd5f706201 /net-mail
parentwhoops... didn't check in the whole thing (diff)
downloadhistorical-51a880ca4563962530e848dc07977d53878aa3f6.tar.gz
historical-51a880ca4563962530e848dc07977d53878aa3f6.tar.bz2
historical-51a880ca4563962530e848dc07977d53878aa3f6.zip
adding dependency on dev-util/gob should solve a bug
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/evolution/ChangeLog7
-rw-r--r--net-mail/evolution/evolution-1.0.3-r4.ebuild171
-rw-r--r--net-mail/evolution/files/digest-evolution-1.0.3-r42
3 files changed, 179 insertions, 1 deletions
diff --git a/net-mail/evolution/ChangeLog b/net-mail/evolution/ChangeLog
index 2dc1677fd0b1..84cde6a6d85a 100644
--- a/net-mail/evolution/ChangeLog
+++ b/net-mail/evolution/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/evolution
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.9 2002/04/09 19:24:09 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.10 2002/04/13 10:53:01 spider Exp $
+
+*evolution-1.0.3-r4 (13 Apr 2002)
+ 13 Apr 2002; Spider <spider@gentoo.org> evolution-1.0.3-r4.ebuild :
+ Adding a dependency on gob in a futile attempt to solve bug #1674
+
*evolution-1.0.3-r3 (9 April 2002)
diff --git a/net-mail/evolution/evolution-1.0.3-r4.ebuild b/net-mail/evolution/evolution-1.0.3-r4.ebuild
new file mode 100644
index 000000000000..268d1083b1fe
--- /dev/null
+++ b/net-mail/evolution/evolution-1.0.3-r4.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Mikael Hallendal <hallski@gentoo.org>, Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0.3-r4.ebuild,v 1.1 2002/04/13 10:53:01 spider Exp $
+
+#provide Xmake and Xemake
+. /usr/portage/eclass/inherit.eclass
+inherit virtualx
+
+DB3=db-3.1.17
+S=${WORKDIR}/${P}
+DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${P}.tar.gz
+ ftp://ftp.ximian.com/pub/source/${PN}/${P}.tar.gz
+ http://people.codefactory.se/~micke/${PN}/${P}.tar.gz
+ http://www.sleepycat.com/update/3.1.17/${DB3}.tar.gz"
+HOMEPAGE="http://www.ximian.com"
+
+RDEPEND=">=gnome-extra/bonobo-conf-0.14
+ >=gnome-base/bonobo-1.0.18
+ >=gnome-extra/gal-0.19
+ >=gnome-base/gconf-1.0.7
+ >=gnome-extra/gtkhtml-1.0.1
+ >=gnome-base/oaf-0.6.7
+ >=gnome-base/ORBit-0.5.12
+ >=gnome-base/libglade-0.17-r1
+ >=media-libs/gdk-pixbuf-0.14.0
+ >=dev-libs/libxml-1.8.16
+ >=gnome-base/gnome-vfs-1.0.2-r1
+ >=gnome-base/gnome-print-0.34
+ >=app-text/scrollkeeper-0.2
+ dev-util/gob
+ ssl? ( >=net-www/mozilla-0.9.9 )
+ ldap? ( >=net-nds/openldap-2.0 )
+ mozilla? ( >=net-www/mozilla-0.9.9 )
+ pda? ( >=gnome-extra/gnome-pilot-0.1.61-r2 )
+ spell? ( >=app-text/gnome-spell-0.4.1-r1 )"
+
+# Added dependency on "dev-util/gob" this should fix a configure bug
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.4.1-r1
+ perl? ( dev-util/gtk-doc )
+ nls? ( >=dev-util/intltool-0.11
+ sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Fix the filter crash. This is actually a problem in the add and
+ # edit code. Mikael Hallendal originally fixed the bug in the add
+ # code. I added the fixes for the edit code.
+ #
+ # Martin Schlemmer (02 April 2002)
+ patch -p0 < ${FILESDIR}/evolution-1.0.3-filter-crash.patch || die
+ # add mandrake patches
+ # fix KDE detection
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-kde.patch || die
+ # call pilot conduit applet (not pilot link applet)
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-conduit.patch || die
+ # Patch from Preston A. Elder to resolve bug #1355
+ # fix a problem with literal strings and sertain IMAP servers
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-imapfix.diff || die
+}
+
+src_compile() {
+
+ libtoolize --copy --force
+
+ cd ${WORKDIR}/${DB3}/build_unix
+ ../dist/configure --prefix=${WORKDIR}/db3 || die
+
+ make || die
+ make prefix=${WORKDIR}/db3 install || die
+
+ cd ${S}
+
+ local myconf=""
+
+ MOZILLA=$MOZILLA_FIVE_HOME
+
+ if [ -n "`use pda`" ] ; then
+ myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
+ else
+ myconf="${myconf} --enable-pilot-conduits=no"
+ fi
+
+ if [ -n "`use ldap`" ] ; then
+ myconf="${myconf} --with-openldap=yes"
+ else
+ myconf="${myconf} --with-openldap=no"
+ fi
+
+ if [ -n "`use mozilla`" ] ; then
+ myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nspr-libs --without-nspr-includes"
+ fi
+
+ if [ -n "`use ssl`" ] ; then
+ myconf="${myconf} --with-nss-includes=${MOZILLA}/include/nss \
+ --with-nss-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nss-libs --without-nss-includes"
+ fi
+
+ # SSL needs NSPR libs ...
+ if [ -n "`use ssl`" ] && [ -z "`use mozilla`" ] ; then
+ myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA}"
+ fi
+
+ if [ -n "`use perl`" ] ; then
+ myconf="${myconf} --enable-gtk-doc"
+ else
+ myconf="${myconf} --disable-gtk-doc"
+ fi
+
+ if [ -z "`use nls`" ] ; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} -I/usr/include/libpisock"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-db3=${WORKDIR}/db3 \
+ --disable-python-bindings \
+ ${myconf} || die
+
+ #needs to be able to connect to X display to build.
+ Xemake || Xmake || die
+}
+
+src_install() {
+ cd omf-install
+ cp Makefile Makefile.old
+ sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
+ rm Makefile.old
+ cd ${S}
+
+ # Don't use DESTDIR it violates sandbox // Hallski
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ datadir=${D}/usr/share \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ KDE_APPLNK_DIR=${D}/usr/share/applnk \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog HACKING MAINTAINERS
+ dodoc NEWS README
+}
+
+pkg_postinst() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
+pkg_postrm() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
diff --git a/net-mail/evolution/files/digest-evolution-1.0.3-r4 b/net-mail/evolution/files/digest-evolution-1.0.3-r4
new file mode 100644
index 000000000000..c04a2f7454ba
--- /dev/null
+++ b/net-mail/evolution/files/digest-evolution-1.0.3-r4
@@ -0,0 +1,2 @@
+MD5 28ffb3911f46a591466a78f5c805c0aa evolution-1.0.3.tar.gz 12908768
+MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1954117