summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-07 21:10:33 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-07 21:10:33 +0000
commit2542b64143e87017fb7f885bd07a87c39de1d9cc (patch)
treede527241e119509af82c22317fa1d11559bb82f6 /net-mail
parentFixed digest. (diff)
downloadhistorical-2542b64143e87017fb7f885bd07a87c39de1d9cc.tar.gz
historical-2542b64143e87017fb7f885bd07a87c39de1d9cc.tar.bz2
historical-2542b64143e87017fb7f885bd07a87c39de1d9cc.zip
*** empty log message ***
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/evolution/evolution-0.10.ebuild26
1 files changed, 19 insertions, 7 deletions
diff --git a/net-mail/evolution/evolution-0.10.ebuild b/net-mail/evolution/evolution-0.10.ebuild
index 55f51f8be782..426c35b4c2a3 100644
--- a/net-mail/evolution/evolution-0.10.ebuild
+++ b/net-mail/evolution/evolution-0.10.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-0.10.ebuild,v 1.3 2001/05/29 00:21:12 blutgens Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-0.10.ebuild,v 1.4 2001/06/07 21:10:33 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,12 +9,16 @@ DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}"
HOMEPAGE="http://www.helixcode.com"
-DEPEND=">=gnome-base/gnome-core-1.2.4
- >=gnome-base/libunicode-0.4-r1
- >=gnome-base/gal-0.7
+DEPEND="=gnome-base/gal-0.7 nls? ( sys-devel/gettext )
>=gnome-base/gtkhtml-0.8.3
- >=gnome-libs/libxml2-2.3.5
- ldap? ( >=net-nds/openldap-1.2 )"
+ >=dev-util/xml-i18n-tools-0.8.4"
+ #mozilla? ( >=net-www/mozilla-0.9 )"
+ #ldap? ( >=net-nds/openldap-1.2 )"
+
+RDEPEND="=gnome-base/gal-0.7
+ >=gnome-base/gtkhtml-0.8.3"
+ #mozilla? ( >=net-www/mozilla-0.9 )"
+ #ldap? ( >=net-nds/openldap-1.2 )"
src_compile() {
@@ -24,6 +28,15 @@ src_compile() {
# else
myconf="--enable-ldap=no"
# fi
+if [ "`use mozilla`" ]
+ then
+ # mozilla does not really work cuz of a missing libnss
+ MOZILLA=/opt/mozilla
+ #myconf="${myconf} --with-nspr-libs=$MOZILLA \
+ # --with-nspr-includes=$MOZILLA/include/nspr"
+ #export MOZILLA_FIVE_HOME=$MOZILLA
+ #export LD_LIBRARY_PATH=$MOZILLA_FIVE_HOME
+ fi
try ./configure --prefix=/opt/gnome --host=${CHOST} --enable-file-locking=no $myconf
try make
@@ -31,7 +44,6 @@ src_compile() {
src_install () {
- cd ${S}
try make DESTDIR=${D} install
dodoc AUTHORS COPYING ChangeLog HACKING MAINTAINERS
dodoc NEWS README