summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-08-11 09:05:28 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-08-11 09:05:28 +0000
commit7ab54e64a578e33c33a0a17a26e1310783278245 (patch)
treed5684efb354b957637382d127e429e350c10c3e8 /net-mail/uw-imap
parentfix bug #18529 and ensure uw-imap is built with -fPIC where appropriate (diff)
downloadhistorical-7ab54e64a578e33c33a0a17a26e1310783278245.tar.gz
historical-7ab54e64a578e33c33a0a17a26e1310783278245.tar.bz2
historical-7ab54e64a578e33c33a0a17a26e1310783278245.zip
fix bug #18529 and ensure uw-imap is built with -fPIC where appropriate
Diffstat (limited to 'net-mail/uw-imap')
-rw-r--r--net-mail/uw-imap/Manifest6
-rw-r--r--net-mail/uw-imap/files/digest-uw-imap-2002d-r11
-rw-r--r--net-mail/uw-imap/uw-imap-2002d-r1.ebuild115
3 files changed, 118 insertions, 4 deletions
diff --git a/net-mail/uw-imap/Manifest b/net-mail/uw-imap/Manifest
index 2002c6a25cbc..13ca75b8d59c 100644
--- a/net-mail/uw-imap/Manifest
+++ b/net-mail/uw-imap/Manifest
@@ -1,7 +1,5 @@
-MD5 8a640adc37a43d220f5490120895123d patch 765
-MD5 d932f8f81c44c739cc77b4396604b8f6 uw-imap-2002d-r1.ebuild 2977
-MD5 1abd55244bf6a350fc2f869a32a1952c attachment.cgi?id=10061&action=view 2700
-MD5 d47c2bb39b30e63a38f4acfceb406448 ChangeLog 3789
+MD5 958cd06dce2ead6724ba99d12ac51221 uw-imap-2002d-r1.ebuild 2987
+MD5 52061268c011f7564e1b30ece4dd78e0 ChangeLog 3975
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 edb8d9532ef792abc3e4009e06e74a24 uw-imap-2002d.ebuild 2635
MD5 506e7347cac698714cf5cd60eca761ba files/uw-ipop2.xinetd 563
diff --git a/net-mail/uw-imap/files/digest-uw-imap-2002d-r1 b/net-mail/uw-imap/files/digest-uw-imap-2002d-r1
new file mode 100644
index 000000000000..7e0aec37a891
--- /dev/null
+++ b/net-mail/uw-imap/files/digest-uw-imap-2002d-r1
@@ -0,0 +1 @@
+MD5 64e82a195d21481fc4c54c4ed9fe0527 imap-2002d.tar.Z 2155224
diff --git a/net-mail/uw-imap/uw-imap-2002d-r1.ebuild b/net-mail/uw-imap/uw-imap-2002d-r1.ebuild
new file mode 100644
index 000000000000..d5d768bdcf8a
--- /dev/null
+++ b/net-mail/uw-imap/uw-imap-2002d-r1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/uw-imap-2002d-r1.ebuild,v 1.1 2003/08/11 09:05:23 robbat2 Exp $
+
+MY_P=imap-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="UW server daemons for IMAP and POP network mail protocols."
+SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
+HOMEPAGE="http://www.washington.edu/imap/"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc hppa ~alpha"
+IUSE="ssl mbox pic"
+
+PROVIDE="virtual/imapd"
+PROVIDE="${PROVIDE} virtual/imap-c-client"
+DEPEND="!net-mail/vimap
+ !virtual/imap-c-client
+ virtual/glibc
+ >=sys-libs/pam-0.72
+ ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ unpack ${A}
+ # Tarball packed with bad file perms
+ chmod -R ug+w ${S}
+
+ use pic || use alpha && append-flags -fPIC
+
+ cd ${S}/src/osdep/unix/
+ cp Makefile Makefile.orig
+ sed \
+ -e 's,-g -fno-omit-frame-pointer -O6,${CFLAGS},g' \
+ -e 's,SSLDIR=/usr/local/ssl,SSLDIR=/usr,g' \
+ -e 's,SSLCERTS=$(SSLDIR)/certs,SSLCERTS=/etc/ssl/certs,g' \
+ < Makefile.orig > Makefile
+
+ # Uncomment this for MBX support
+ #cp Makefile Makefile.orig2
+ #sed \
+ # -e "s:CREATEPROTO=unixproto:CREATEPROTO=mbxproto:" \
+ # -e "s:EMPTYPROTO=unixproto:EMPTYPROTO=mbxproto:" \
+ # < Makefile.orig2 > Makefile
+ cd ${S}
+}
+
+src_compile() {
+ if use ssl; then
+ cd ${S}
+ yes | make lnp SSLTYPE=unix || die
+
+ local i
+ for i in imapd ipop3d; do
+ umask 077
+ PEM1=`/bin/mktemp ${T}/openssl.XXXXXX`
+ PEM2=`/bin/mktemp ${T}/openssl.XXXXXX`
+ /usr/bin/openssl req -newkey rsa:1024 -keyout $$PEM1 \
+ -nodes -x509 -days 365 -out $$PEM2 << EOF
+--
+SomeState
+SomeCity
+SomeOrganization
+SomeOrganizationalUnit
+localhost.localdomain
+root@localhost.localdomain
+EOF
+
+ cat $$PEM1 > ${i}.pem
+ echo "" >> ${i}.pem
+ cat $$PEM2 >> ${i}.pem
+ rm $$PEM1 $$PEM2
+ umask 022
+ done
+ else
+ yes | make lnp SSLTYPE=none || die
+ fi
+}
+
+src_install() {
+ into /usr
+ dosbin imapd/imapd ipopd/ipop?d dmail/dmail tmail/tmail
+ dobin mailutil/mailutil mlock/mlock mtest/mtest
+
+ if use ssl; then
+ dodir /etc/ssl/certs
+ mv imapd.pem ${D}/etc/ssl/certs
+ mv ipop3d.pem ${D}/etc/ssl/certs
+ fi
+
+ insinto /usr/include/imap
+ doins c-client/{c-client,mail,imap4r1,rfc822,linkage,misc,smtp,nntp}.h
+ doins c-client/{osdep,env_unix,env,fs,ftl,nl,tcp}.h
+ dolib.a c-client/c-client.a
+ dosym /usr/lib/c-client.a /usr/lib/libc-client.a
+
+ doman src/ipopd/ipopd.8c src/imapd/imapd.8c
+
+ dodoc CPYRIGHT README docs/*.txt docs/CONFIG docs/RELNOTES
+
+ docinto rfc
+ dodoc docs/rfc/*.txt
+
+ # gentoo config stuff
+ insinto /etc/pam.d
+ newins ${FILESDIR}/uw-imap.pam-system-auth imap
+ newins ${FILESDIR}/uw-imap.pam-system-auth pop
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/uw-imap.xinetd imap
+ newins ${FILESDIR}/uw-ipop2.xinetd ipop2
+ newins ${FILESDIR}/uw-ipop3.xinetd ipop3
+ newins ${FILESDIR}/uw-ipop3s.xinetd ipop3s
+ newins ${FILESDIR}/uw-imaps.xinetd imaps
+}