summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-03-03 09:57:42 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-03-03 09:57:42 +0000
commit77fa0701653742e89775fa5fac979e872105fc5b (patch)
tree9957baa94357c929204bc8cb03def2cae8358a75 /net-mail/uw-imap
parentRemoved xvid useflag (diff)
downloadhistorical-77fa0701653742e89775fa5fac979e872105fc5b.tar.gz
historical-77fa0701653742e89775fa5fac979e872105fc5b.tar.bz2
historical-77fa0701653742e89775fa5fac979e872105fc5b.zip
Take ssl flag into account for clearpasswd. Bug #83797.
Package-Manager: portage-2.0.51.17
Diffstat (limited to 'net-mail/uw-imap')
-rw-r--r--net-mail/uw-imap/ChangeLog5
-rw-r--r--net-mail/uw-imap/Manifest10
-rw-r--r--net-mail/uw-imap/uw-imap-2004c-r3.ebuild19
3 files changed, 21 insertions, 13 deletions
diff --git a/net-mail/uw-imap/ChangeLog b/net-mail/uw-imap/ChangeLog
index 3ad38fb80703..4ba4b01b5994 100644
--- a/net-mail/uw-imap/ChangeLog
+++ b/net-mail/uw-imap/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/uw-imap
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/ChangeLog,v 1.59 2005/03/03 02:39:53 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/ChangeLog,v 1.60 2005/03/03 09:57:42 ticho Exp $
+
+ 03 Mar 2005; Andrej Kacian <ticho@gentoo.org> uw-imap-2004c-r3.ebuild:
+ Take ssl flag into account for clearpasswd.
*uw-imap-2004c-r3 (03 Mar 2005)
diff --git a/net-mail/uw-imap/Manifest b/net-mail/uw-imap/Manifest
index e140181c6621..3e021ebc5599 100644
--- a/net-mail/uw-imap/Manifest
+++ b/net-mail/uw-imap/Manifest
@@ -1,9 +1,9 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 c74e8cf7628b9173c2bfb3cbd85793cb ChangeLog 9023
+MD5 c99fb8d18d69185de7ee1af225691879 ChangeLog 9143
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
-MD5 a14ea7126d518af3c3c125b693415b17 uw-imap-2004c-r3.ebuild 5168
+MD5 77d2e6073551956dcacea56d5324a395 uw-imap-2004c-r3.ebuild 5448
MD5 2a95a847286c5b23cb291f923f75c6e0 uw-imap-2004c-r2.ebuild 4648
MD5 f86653fdd59e2727644fc31305b236c2 uw-imap-2004c-r1.ebuild 4127
MD5 f8341ad011ccea95c157f34f869a0a69 uw-imap-2004c.ebuild 3296
@@ -24,7 +24,7 @@ MD5 464e6baf7e9bdb0bebb80f0810515962 files/digest-uw-imap-2004c-r2 63
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFCJnkCQlM6RnzZP+IRAuWrAJ451oftT6T9Yyw939pqcQ9MHByTzwCcDuj/
-C+QH44udoc+PiIN4L9M688s=
-=dDVX
+iD8DBQFCJt+fQlM6RnzZP+IRAgMIAJ9jcJB8KI8fnZIxWyESnilRYq4zSgCeMNLY
+lOYGq0Hd/d5YoBgLu0r60sk=
+=w0C2
-----END PGP SIGNATURE-----
diff --git a/net-mail/uw-imap/uw-imap-2004c-r3.ebuild b/net-mail/uw-imap/uw-imap-2004c-r3.ebuild
index eda6bba506b7..d8edf2162453 100644
--- a/net-mail/uw-imap/uw-imap-2004c-r3.ebuild
+++ b/net-mail/uw-imap/uw-imap-2004c-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/uw-imap-2004c-r3.ebuild,v 1.1 2005/03/03 02:39:53 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/uw-imap-2004c-r3.ebuild,v 1.2 2005/03/03 09:57:42 ticho Exp $
inherit eutils flag-o-matic
@@ -27,17 +27,22 @@ DEPEND="!net-mail/vimap
kerberos? ( virtual/krb5 )"
pkg_setup() {
+ echo
if use clearpasswd; then
- echo
ewarn "Building uw-imap with cleartext LOGIN allowed. Disable \"clearpasswd\" USE"
ewarn "flag to restrict cleartext LOGIN to SSL/TLS sessions only."
- echo
else
- echo
- ewarn "Building uw-imap with cleartext LOGIN restricted to SSL/TLS sessions only."
- ewarn "Enable \"clearpasswd\" flag to allow unrestricted cleartext LOGIN."
- echo
+ if use ssl; then
+ ewarn "Building uw-imap with cleartext LOGIN restricted to SSL/TLS sessions only."
+ ewarn "Enable \"clearpasswd\" flag to allow unrestricted cleartext LOGIN."
+ else
+ ewarn "You have disabled SSL for uw-imap, but want cleartext passwords restricted to"
+ ewarn "SSL/TLS sessions only. Either enable \"ssl\" USE flag, or disable"
+ ewarn "\"clearpasswd\" USE flag."
+ die "Impossible USE flag combination, see above message"
+ fi
fi
+ echo
# ewarn people not using pam with this file
if ! built_with_use net-mail/mailbase pam;
then