summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJerry Alexandratos <jerry@gentoo.org>2000-12-20 21:03:08 +0000
committerJerry Alexandratos <jerry@gentoo.org>2000-12-20 21:03:08 +0000
commit8d3987db6a5dcf40859a765fdc287dbcfcd10804 (patch)
treefbfdddd82d1f564c4ec63cc886e96fa99084e627 /net-mail/postfix
parentCleaned up the location of the symlinks for sendmail. (diff)
downloadhistorical-8d3987db6a5dcf40859a765fdc287dbcfcd10804.tar.gz
historical-8d3987db6a5dcf40859a765fdc287dbcfcd10804.tar.bz2
historical-8d3987db6a5dcf40859a765fdc287dbcfcd10804.zip
Imported latest version/snapshot of Postfix into the portage tree.
Diffstat (limited to 'net-mail/postfix')
-rw-r--r--net-mail/postfix/files/digest-postfix-200012171
-rw-r--r--net-mail/postfix/postfix-20001217.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/net-mail/postfix/files/digest-postfix-20001217 b/net-mail/postfix/files/digest-postfix-20001217
new file mode 100644
index 000000000000..7d4a382e46d3
--- /dev/null
+++ b/net-mail/postfix/files/digest-postfix-20001217
@@ -0,0 +1 @@
+MD5 b6ef69548b58b23001dd9d3c56896aba snapshot-20001217.tar.gz
diff --git a/net-mail/postfix/postfix-20001217.ebuild b/net-mail/postfix/postfix-20001217.ebuild
new file mode 100644
index 000000000000..74e4e888e8f7
--- /dev/null
+++ b/net-mail/postfix/postfix-20001217.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-20001217.ebuild,v 1.1 2000/12/20 21:03:08 jerry Exp $
+
+P=snapshot-${PV}
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A fast and secure drop-in replacement for sendmail"
+SRC_URI="ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/${A}"
+HOMEPAGE="http://www.postfix.org/"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+PROVIDE="virtual/mta"
+
+src_compile() {
+ cd ${S}
+ make makefiles CC="cc ${CFLAGS}"
+ try make
+}
+
+src_install () {
+ cd ${S}/bin
+ insopts -o root -g root -m 755
+ insinto /usr/sbin
+ doins post* sendmail
+
+ dodir /usr/bin /usr/sbin /usr/lib
+ dosym /usr/sbin/sendmail /usr/bin/mail
+ dosym /usr/sbin/sendmail /usr/bin/mailq
+ dosym /usr/sbin/sendmail /usr/bin/newaliases
+ dosym /usr/sbin/sendmail /usr/lib/sendmail
+
+ cd ${S}/libexec
+ dodir /usr/libexec/postfix
+ insopts -o root -g root -m 755
+ insinto /usr/libexec/postfix
+ doins *
+
+ cd ${S}/conf
+ dodir /etc/postfix
+ insopts -o root -g root -m 644
+ insinto /etc/postfix
+ doins *
+ fperms 755 /etc/postfix/postfix-script*
+
+ cd ${S}/man
+ for i in man*
+ do
+ doman $i/*
+ done
+
+ cd ${S}
+ dodoc *README BEWARE COMPATIBILITY HISTORY LICENSE PORTING \
+ RELEASE_NOTES RESTRICTION_CLASS TODO
+
+ cd ${S}/html
+ docinto html
+ dodoc *
+
+ dodir /var/spool/postfix
+ fperms 755 /var/spool/postfix
+ fowners postfix.root /var/spool/postfix
+
+ dodir /var/spool/postfix/maildrop
+ fperms 1733 /var/spool/postfix/maildrop
+ fowners postfix.root /var/spool/postfix/maildrop
+
+ insopts -m 755
+ insinto /etc/rc.d/init.d
+ doins ${FILESDIR}/postfix
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/rc-update add postfix
+}