summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-05-16 10:08:22 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-05-16 10:08:22 +0000
commit6e106d23c687345a1d34dae2bebca76ce253d5a8 (patch)
tree5ac398f7b50edb9f65e0bdc31d0e433907b598f6 /net-mail/mailfront
parentVersion bump, closes bug #92581. (diff)
downloadhistorical-6e106d23c687345a1d34dae2bebca76ce253d5a8.tar.gz
historical-6e106d23c687345a1d34dae2bebca76ce253d5a8.tar.bz2
historical-6e106d23c687345a1d34dae2bebca76ce253d5a8.zip
Inherit toolchain-funcs.eclass instead of gcc.eclass. Bug #92745.
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'net-mail/mailfront')
-rw-r--r--net-mail/mailfront/ChangeLog6
-rw-r--r--net-mail/mailfront/mailfront-0.88.ebuild8
-rw-r--r--net-mail/mailfront/mailfront-0.92.ebuild8
3 files changed, 13 insertions, 9 deletions
diff --git a/net-mail/mailfront/ChangeLog b/net-mail/mailfront/ChangeLog
index 76019990d13c..6288151990c1 100644
--- a/net-mail/mailfront/ChangeLog
+++ b/net-mail/mailfront/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/mailfront
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/ChangeLog,v 1.16 2005/04/28 21:02:25 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/ChangeLog,v 1.17 2005/05/16 10:08:22 ticho Exp $
+
+ 16 May 2005; Andrej Kacian <ticho@gentoo.org> mailfront-0.88.ebuild,
+ mailfront-0.92.ebuild:
+ Inherit toolchain-funcs.eclass instead of gcc.eclass. Bug #92745.
*mailfront-0.93 (28 Apr 2005)
diff --git a/net-mail/mailfront/mailfront-0.88.ebuild b/net-mail/mailfront/mailfront-0.88.ebuild
index 84422f834237..01779dbadfef 100644
--- a/net-mail/mailfront/mailfront-0.88.ebuild
+++ b/net-mail/mailfront/mailfront-0.88.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-0.88.ebuild,v 1.7 2005/02/13 06:37:26 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-0.88.ebuild,v 1.8 2005/05/16 10:08:22 ticho Exp $
-inherit fixheadtails gcc
+inherit fixheadtails toolchain-funcs
DESCRIPTION="Mail server network protocol front-ends"
HOMEPAGE="http://untroubled.org/mailfront/"
@@ -27,8 +27,8 @@ src_compile() {
echo "/usr/lib/bglibs/include" > conf-bgincs
echo "/usr/lib/bglibs/lib" > conf-bglibs
echo "/var/qmail/bin" > conf-bin
- echo "$(gcc-getCC) ${CFLAGS}" > conf-cc
- echo "$(gcc-getCC) -s" > conf-ld
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) -s" > conf-ld
emake || die
}
diff --git a/net-mail/mailfront/mailfront-0.92.ebuild b/net-mail/mailfront/mailfront-0.92.ebuild
index 25f6fd71d13d..82bdea91dcf7 100644
--- a/net-mail/mailfront/mailfront-0.92.ebuild
+++ b/net-mail/mailfront/mailfront-0.92.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-0.92.ebuild,v 1.1 2005/02/13 06:37:26 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailfront/mailfront-0.92.ebuild,v 1.2 2005/05/16 10:08:22 ticho Exp $
-inherit fixheadtails gcc
+inherit fixheadtails toolchain-funcs
DESCRIPTION="Mail server network protocol front-ends"
HOMEPAGE="http://untroubled.org/mailfront/"
@@ -30,8 +30,8 @@ src_compile() {
echo "/usr/lib/bglibs/lib" > conf-bglibs
echo "/var/qmail/bin" > conf-bin
echo "/var/qmail" > conf-qmail
- echo "$(gcc-getCC) ${CFLAGS}" > conf-cc
- echo "$(gcc-getCC) -s" > conf-ld
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) -s" > conf-ld
emake || die
}