summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-02-15 05:02:04 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-02-15 05:02:04 +0000
commit5cac155ce70880b702127de85bd41fdf6e18b590 (patch)
tree4e2ebde7f873be86c61dc119bf45e0332dabc8fc /net-mail/fetchmail
parentfix symlink (diff)
downloadhistorical-5cac155ce70880b702127de85bd41fdf6e18b590.tar.gz
historical-5cac155ce70880b702127de85bd41fdf6e18b590.tar.bz2
historical-5cac155ce70880b702127de85bd41fdf6e18b590.zip
Updated to version 5.9.7. This closes bug 693.
Rewrote the ebuild a bit: - Avoid error message that contrib/RCS is a directory. - Make use of 'dohtml' to install html docs. Adopted idea by Tod M. Neidt (see bug 292) to warn the user if fetchmailconf cannot be used because of missing python with tkinter support.
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/ChangeLog9
-rw-r--r--net-mail/fetchmail/fetchmail-5.9.7.ebuild61
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-5.9.71
3 files changed, 70 insertions, 1 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index ba6710f8da2c..0b8fbd81fd0e 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/fetchmail
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.1 2002/02/01 21:53:34 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.2 2002/02/15 05:02:04 agenkin Exp $
+
+*fetchmail-5.9.7 (14 Feb 2002)
+
+ 14 Feb 2002; Arcady Genkin <agenkin@thpoon.com> fetchmail-5.9.7.ebuild :
+
+ Updated to 5.9.7 version.
+ Warns the user if fetchmailconf cannot be run due to missing python+tkinter.
*fetchmail-5.9.6 (1 Feb 2002)
diff --git a/net-mail/fetchmail/fetchmail-5.9.7.ebuild b/net-mail/fetchmail/fetchmail-5.9.7.ebuild
new file mode 100644
index 000000000000..eeabfc06b812
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-5.9.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Parag Mehta <pm@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-5.9.7.ebuild,v 1.1 2002/02/15 05:02:04 agenkin Exp $
+
+DESCRIPTION="Fetchmail is a full-featured remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.tuxedo.org/~esr/fetchmail/"
+SRC_URI="http://www.tuxedo.org/~esr/fetchmail/${P}.tar.gz"
+S="${WORKDIR}/${P}"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use ssl && myconf="${myconf} --with-ssl=/usr"
+ use nls || myconf="${myconf} --disable-nls"
+ # This needs inet6-apps, which we don't have
+ #use ipv6 && myconf="{myconf} --enable-inet6"
+
+ ./configure --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host="${CHOST}" \
+ ${myconf} \
+ || die "Configuration failed."
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dohtml *.html
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING MANIFEST
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ if python -c "import tkinter" >/dev/null 2>&1
+ then
+ true
+ else
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-5.9.7 b/net-mail/fetchmail/files/digest-fetchmail-5.9.7
new file mode 100644
index 000000000000..f6b4284a41d9
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-5.9.7
@@ -0,0 +1 @@
+MD5 51b1d24c0894a2b9c456770babd95357 fetchmail-5.9.7.tar.gz 898361