summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-05-03 18:54:18 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-05-03 18:54:18 +0000
commit0d0d894c2c1d39d5db84d96f634e839cc8ef3010 (patch)
tree3422aee4e34bb5447ff69337caf6b8fd41dd0663 /net-libs
parentMasked topal use flag since it needs gnat/ada (diff)
downloadhistorical-0d0d894c2c1d39d5db84d96f634e839cc8ef3010.tar.gz
historical-0d0d894c2c1d39d5db84d96f634e839cc8ef3010.tar.bz2
historical-0d0d894c2c1d39d5db84d96f634e839cc8ef3010.zip
New version for GNOME 2.26. Split library into libsoup and libsoup-gnome, use libproxy for handling proxy specifics, ...
Package-Manager: portage-2.2_rc31/cvs/Linux x86_64
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libsoup/ChangeLog9
-rw-r--r--net-libs/libsoup/libsoup-2.26.1.ebuild40
-rw-r--r--net-libs/libsoup/libsoup-2.4.1.ebuild26
3 files changed, 48 insertions, 27 deletions
diff --git a/net-libs/libsoup/ChangeLog b/net-libs/libsoup/ChangeLog
index 82286c59e531..6ff6761bce71 100644
--- a/net-libs/libsoup/ChangeLog
+++ b/net-libs/libsoup/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libsoup
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.175 2009/04/28 14:31:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.176 2009/05/03 18:54:18 eva Exp $
+
+*libsoup-2.26.1 (03 May 2009)
+
+ 03 May 2009; Gilles Dartiguelongue <eva@gentoo.org> -libsoup-2.4.1.ebuild,
+ +libsoup-2.26.1.ebuild:
+ New version for GNOME 2.26. Split library into libsoup and libsoup-gnome,
+ use libproxy for handling proxy specifics, ...
28 Apr 2009; Raúl Porcel <armin76@gentoo.org> libsoup-2.24.3.ebuild:
arm/sh stable
diff --git a/net-libs/libsoup/libsoup-2.26.1.ebuild b/net-libs/libsoup/libsoup-2.26.1.ebuild
new file mode 100644
index 000000000000..4becdd22e547
--- /dev/null
+++ b/net-libs/libsoup/libsoup-2.26.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.26.1.ebuild,v 1.1 2009/05/03 18:54:18 eva Exp $
+
+EAPI="2"
+
+inherit gnome2
+
+DESCRIPTION="An HTTP library implementation in C"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="2.4"
+KEYWORDS="~amd64 ~x86"
+# Do NOT build with --disable-debug/--enable-debug=no - gnome2.eclass takes care of that
+IUSE="debug doc gnome ssl"
+
+RDEPEND=">=dev-libs/glib-2.15.3
+ >=dev-libs/libxml2-2
+ gnome? (
+ net-libs/libproxy
+ >=gnome-base/gconf-2
+ dev-db/sqlite:3 )
+ ssl? ( >=net-libs/gnutls-1 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+# test? (
+# www-servers/apache
+# dev-lang/php
+# net-misc/curl )
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_with gnome)
+ $(use_enable ssl)"
+}
diff --git a/net-libs/libsoup/libsoup-2.4.1.ebuild b/net-libs/libsoup/libsoup-2.4.1.ebuild
deleted file mode 100644
index 3025892e7fc7..000000000000
--- a/net-libs/libsoup/libsoup-2.4.1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.4.1.ebuild,v 1.9 2008/11/04 03:39:04 vapier Exp $
-
-inherit gnome2
-
-DESCRIPTION="An HTTP library implementation in C"
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="LGPL-2"
-SLOT="2.4"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="doc ssl"
-
-RDEPEND=">=dev-libs/glib-2.15.3
- >=dev-libs/libxml2-2
- ssl? ( >=net-libs/gnutls-1 )"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.9
- doc? ( >=dev-util/gtk-doc-1 )"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-pkg_setup() {
- G2CONF="${G2CONF} $(use_enable ssl)"
-}