summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-03-15 16:49:40 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-03-15 16:49:40 +0000
commitcb0c0c6a483faf1c4c90af5d7b0ab5b477f0d970 (patch)
tree5ba6a3346564eeca193828b352db91eb155128e6 /net-libs/rb_libtorrent/rb_libtorrent-0.16.12.ebuild
parentSet plugins dir to right libdir #504666 by Sergey Popov. (diff)
downloadhistorical-cb0c0c6a483faf1c4c90af5d7b0ab5b477f0d970.tar.gz
historical-cb0c0c6a483faf1c4c90af5d7b0ab5b477f0d970.tar.bz2
historical-cb0c0c6a483faf1c4c90af5d7b0ab5b477f0d970.zip
Make sure the correct boot library path is used. Bug #503746. Patch by Georgi Georgiev
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0xC2BA7F3C!
Diffstat (limited to 'net-libs/rb_libtorrent/rb_libtorrent-0.16.12.ebuild')
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.12.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.12.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.12.ebuild
deleted file mode 100644
index 64ff462407ba..000000000000
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.16.12.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.12.ebuild,v 1.1 2013/10/26 13:11:14 hwoarang Exp $
-
-EAPI="4"
-PYTHON_DEPEND="python? 2:2.6"
-PYTHON_USE_WITH="threads"
-PYTHON_USE_WITH_OPT="python"
-
-inherit multilib python versionator
-
-MY_P=${P/rb_/}
-MY_P=${MY_P/torrent/torrent-rasterbar}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
-SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc examples python ssl static-libs"
-RESTRICT="test"
-
-DEPEND=">=dev-libs/boost-1.48[python?,threads(+)]
- >=sys-devel/libtool-2.2
- sys-libs/zlib
- examples? ( !net-p2p/mldonkey )
- ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- use python && python_convert_shebangs -r 2 .
-}
-
-src_configure() {
- local myconf
-
- # bug 441842
- myconf="--disable-silent-rules"
-
- # use multi-threading versions of boost libs
- if has_version '>=dev-libs/boost-1.52.0-r1'; then
- myconf+=" --with-boost-python=boost_python-${PYTHON_ABI}"
- else
- myconf+=" --with-boost-system=boost_system-mt \
- --with-boost-python=boost_python-${PYTHON_ABI}-mt"
- fi
-
- local LOGGING
- use debug && myconf+=" --enable-logging=verbose"
-
- econf $(use_enable debug) \
- $(use_enable test tests) \
- $(use_enable examples) \
- $(use_enable python python-binding) \
- $(use_enable ssl encryption) \
- $(use_enable static-libs static) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
- dodoc ChangeLog AUTHORS NEWS README
- if use doc; then
- dohtml docs/*
- fi
-}